Página 2 de 2 PrimeiroPrimeiro 12
+ Responder ao Tópico



  1. #21

    Padrão

    Citação Postado originalmente por francisco.william Ver Post
    Consegui fazer funcionar dessa forma:

    ;;; ID Alta Emule TCP
    chain=dstnat in-interface=Link (Interface de entrada do link) protocol=tcp dst-port=50000 (porta a ser usada pelo cliente) action=dst-nat to-addresses=192.168.150.88 (end. do cliente) to-ports=50000 (porta a ser usada pelo cliente)

    ;;; ID Alta Emule UDP
    chain=dstnat in-interface=Link (Interface de entrada do link) protocol=udp dst-port=50000 (porta a ser usada pelo cliente) action=dst-nat to-addresses=192.168.150.88 (end. do cliente) to-ports=50000 (porta a ser usada pelo cliente)

    Deu ID Alta e no teste de portas tb foi aprovado.
    Estas regras podem ser aprimoradas da seguinte forma:

    Para fazer a liberação para todos os usuários, no lugar do endereço do cliente, digite 0.0.0.0/0
    Para liberar um range de portas, no lugar de 50000, digite 50000-60000 (vai liberar todas as portas, entre 50000 e 60000).
    Última edição por catvbrasil; 28-01-2007 às 18:36.

  2. #22

    Padrão

    CATV, estou tentando liberar as portas para o e-mule ganhar uma ID alta,
    mas dessa forma q vc indicou colocando o IP ( 0.0.0.0 ) nao está funcionando..

    Nao está liberando para os IPs internos

    será q está faltando mais algum comando?? pois só funciona se eu colocar o IP interno do cliente..

    valeu.,.

    abraços.



  3. #23

    Padrão

    Citação Postado originalmente por catvbrasil Ver Post
    Estas regras podem ser aprimoradas da seguinte forma:

    Para fazer a liberação para todos os usuários, no lugar do endereço do cliente, digite 0.0.0.0/0
    Para liberar um range de portas, no lugar de 50000, digite 50000-60000 (vai liberar todas as portas, entre 50000 e 60000).
    Se colocar 0.0.0.0/0 seu roteador não saberá qual interface é interna ou externa.
    É impossivel vc criar um dst-nat para todos os clientes como vc colocou...vc testou isso antes de opinar aqui?
    uPNP funciona perfeitamente, vc precisa especificar qual sua interface interna e qual sua interface externa.
    Existem diversos aplicativos que requerem o uso de uPNP e se vc usa NAT na sua rede, é forçado a habilitar no seu roteador.

  4. #24
    Avatar de marcelomg
    Ingresso
    Jan 2006
    Localização
    São Lourenço do Sul, Brazil
    Posts
    1.476

    Padrão

    Citação Postado originalmente por cybersank Ver Post
    Se colocar 0.0.0.0/0 seu roteador não saberá qual interface é interna ou externa.
    É impossivel vc criar um dst-nat para todos os clientes como vc colocou...vc testou isso antes de opinar aqui?
    uPNP funciona perfeitamente, vc precisa especificar qual sua interface interna e qual sua interface externa.
    Existem diversos aplicativos que requerem o uso de uPNP e se vc usa NAT na sua rede, é forçado a habilitar no seu roteador.
    Qual seria a configuração correta?



  5. #25

    Padrão

    Quero reforçar aqui o pedido do amigo Marcelo ao amigo cybersank.
    qual a configuração correta ?
    Já fiz vários testes com uPNP, mas pro p2p ainda não vi resultados de ID Alta.
    Cibersnak - tá sumido rapaz, aparece mais

    valeu ....

  6. #26

    Padrão

    Citação Postado originalmente por cleciorodrigo Ver Post
    Olha tive este tipo de problemas aqui tambem e pelo que percebi isso ocorre apenas em clientes com IP Privado, já clientes com IP Público não tem este problemas, isso ocorre pq o servidor de P2P tenta se conectar nas portas do PC do cliente mais como ele esta atras do NAT a conexão não acontece ou fica lenta por isso o problema de ID baixa, pra resolver fui mudando os clientes que tem problemas pra IP Público.

    Falow

    Clecio
    É isso aí. As unicas maneiras de dar ID alta p/ o cliente são: redirecionar uma porta (qualquer uma serve) para o cliente e ele tem que informar esta porta no soft que ele quer usar. A outra, é fornecer um IP válido para o cliente...



  7. #27

    Padrão

    tb gostaria de saber como uPNP funciona.. pois ja tentei de tudo.. e nao da id alta para os clientes..

  8. #28

    Padrão

    A configuração é como diz no docs do mikrotik, muito simples:
    ip upnp pr
    enabled: yes
    allow-disable-external-interface: no
    show-dummy-rule: yes

    ip upnp interfaces pr
    Flags: X - disabled
    # INTERFACE TYPE
    0 ether1 external
    1 ether2 internal

    Para testar visite esta pagina:
    http://fp.mgillespie.plus.com/upnphelp.htm
    Baixa o aplicativo pra testar e na mesma pagina se encontra dicas do que pode estar errado.

    Se os seus clientes ainda estão com problemas, vc precisar checar suas regras de firewall.

    Se nada disso funcionar, vc precisa estabelecer um servidor de SOCKS.



  9. #29

    Padrão

    CYBER.... como é bom ver vc na área respondendo o post..
    e sempre com ótimas respostas..

    bom.. vou testar de novo o uPNP vamos.. ver se consigo dar ID alta pra todos..

    pois está dificil de criar algo UNIVERSAL para todos os clientes pegar ID alta.. sem ficar configurando porta do cliente e etc..

    Abraços....

    assim.. q eu testar.. eu posto o resultado.. valeu..

  10. #30

    Padrão

    Pois é Cyber.. realmente acho q esse uPNP nao quer funcionar comigo.. ahaha

    ativei um monte de coisa q o prog testa e fala q falhou.. ae passou normal..

    mas quando chega no passo 7 e 8, ele falha.. exatamente o q ira testar o IP..

    Segundo o site fala q o modem nao esta funcionando o PNP..
    eu to usando o glink em bridge passando o ip direto para o computador..

    tb configurei o uPNP conforme vc falou..
    (tenho 3 MK.. 1 central e 2 repetidores.. em bridge e wds)

    Ativei o uPNP no principal.. e nada.. e depois ativei nas repetidoras.. (menos a bridge e o WDS... colocando apenas as placas fisicas)

    e tb nao funcionou?? tenho q ativar em todos os mks mesmo?? ou só no principal.. q tem o DHCP e recebe o link externo??

    Mas de qualquer forma.. tentei dos 2 jeitos.. e nao funcionou no programa de teste.. da falha no final...

    Obs.: utilizo Hotspot.. mas acho q nao atrapalha nisso né??

    Teria alguma outra dica Cyber?? para colocar isso pra funcionar..?? ou mapeamento de portas.. para um range de IP??

    Abraços.. T++



  11. #31

    Question

    Citação Postado originalmente por ruyneto Ver Post
    O problema de por ip publico eh que se o cara tiver 100 clientes pronto vai precisa de meia classe C so pra ele, já em relação as portas so da porta 50000 ate a 60000 são 10 mil portas pra ele usar, o que fica bem mais facil.

    falows
    Cara vc poderia me ajudar nessas regras do ID alto P2P. Fiz algumas regras só que acho que não estão certas pq não funcionram .
    Obrigado

  12. #32

    Padrão

    Se aqui for ADSL como eh que eu faço? E tambem isso eh valido pra o mk que tem server pppoe pra os usuarios se autenticarem?



  13. #33

    Padrão

    Citação Postado originalmente por cybersank Ver Post
    A configuração é como diz no docs do mikrotik, muito simples:
    ip upnp pr
    enabled: yes
    allow-disable-external-interface: no
    show-dummy-rule: yes

    ip upnp interfaces pr
    Flags: X - disabled
    # INTERFACE TYPE
    0 ether1 external
    1 ether2 internal

    Para testar visite esta pagina:
    http://fp.mgillespie.plus.com/upnphelp.htm
    Baixa o aplicativo pra testar e na mesma pagina se encontra dicas do que pode estar errado.

    Se os seus clientes ainda estão com problemas, vc precisar checar suas regras de firewall.

    Se nada disso funcionar, vc precisa estabelecer um servidor de SOCKS.
    Desculpe a ignorancia mas aonde eu coloco isso?

  14. #34

    Padrão

    Sera q alguem com pena dos mais leigos e ignorantes poderia fazer um passo-a-passo pelo amor de Deus.



  15. #35

    Padrão

    alguem poderia ajudar a conseguir essa façanha??? De preferncia com upnp!!! Thks!

  16. #36

    Padrão

    bom eu estou testando com bridge e pppoe vou colocar up ip valido no cliente com uma conexão por 24 ou 12 horas estou testando ainda mas ja achei muita coisa que me ajudou assim que tiver um resultado porto aqui um tutorial....