+ Responder ao Tópico



  1. #1

    Padrão problemas com roteamento no-ip

    Olá pessoal, estou precisando de grande ajuda por aqui.
    Eu gostaria de criar um site a partir de meu server Debian, mas tenho um problema, ip dinamico.
    Hoje, o apache2 está configurado corretamente, pois consigo de qualquer estação da minha rede abrir meu site. O problema são os usuários externos que não funcionam. Cadastrei um dominio (free) no site do no-ip, deixei o mesmo com a primeira opção DNS Host A, o endereço ip era o endereço externo da net e a princpio ok. Alterei as regras de NAT no meu modem D-link 500G para redirecionar para o endereço de meu server (192.168.0.200)...e nada....quando tento acessar com o nome do meu site pelo browser, cai na pagina de login do meu modem de ADSL.
    Alguém por favor poderia me ajudar com meu problema ??

    Gilcimar

  2. #2

    Padrão

    Entra na configuracao do modem, troca a porta de gerenciamento dele e redireciona a porta 80 para o teu servidor. Use uma porta acima de 61000 que ele disponibiliza.
    Não lembro a localização exata desta opção, mas procura em "tools"que vc acha.
    Outra possibilidade, é desabilitar o NAT e deixar ele como bridge, passando o IP válido para sua máquina e deixar ela compartilhando a conexao.
    Espero ter ajudado.
    Abraço!



  3. #3

    Padrão

    Citação Postado originalmente por antoni Ver Post
    Entra na configuracao do modem, troca a porta de gerenciamento dele e redireciona a porta 80 para o teu servidor. Use uma porta acima de 61000 que ele disponibiliza.
    Não lembro a localização exata desta opção, mas procura em "tools"que vc acha.
    Outra possibilidade, é desabilitar o NAT e deixar ele como bridge, passando o IP válido para sua máquina e deixar ela compartilhando a conexao.
    Espero ter ajudado.
    Abraço!
    Olá Antoni, acredito que eu tenha feita isto, pois entrei nas opções de redirecionamento do modem e disse para ele redirecionar todo o trafego que vem para ele(modem) para o meu server(192.168.0.200) e usei a porta 80 para redirecionar isto para meu server. Quando a deixar ele como bridge, fica um pouco mais complicado na minha rede.
    Se vc puder me dar mais uma luz por aqui, agradeço.
    Gilcimar

  4. #4

    Padrão

    É que a porta 80 é a mesma porta que o Dlink usa p/ configurar ele. Qdo vc digita http://ip_do_modem, ele acessa pela porta 80.
    Vc deve mudar a porta do gerenciamento dele para uma porta alta (ele aceita as superiores a 61000), porém não lembro a opção exata p/ isso. Se vc ñ encontrar, responde que a noite estou em casa e olho no meu modem como faz e te passo a resposta.



  5. #5

    Padrão

    Entendi Antoni, mas não achei...se vc puder passar o local, agradeço.

    Gilcimar

  6. #6

    Padrão

    Vai em
    Tools > Admin e na opção: HTTP Remote Access Port(80,61000-62000) altere para 61000.

    Após isso, para acessar seu modem, vc deve digitar: http://ip_do_modem:61000

    Falow, poste o resultado!
    Abraço.



  7. #7

    Padrão

    Olá Antoni....blz ?
    Fiz a troca da porta do modem como vc comentou....a principio está ok, mas como vc redireciou o trafego para a porta 80 ??
    Abraço,

    Gilcimar

  8. #8

    Padrão

    Vá em

    Advanced >> Port Forwarding

    em Private IP, coloque o ip do teu server
    Em protocol type, escolha o protocolo (na duvida deixe all)
    em private port, coloque 80
    e em public port, escolha "single port" e informe novamente a porta 80

    Depois, e' so aplicar e salvar as modificacoes.
    Abraço!