+ Responder ao Tópico



  1. #1

    Cool interface static está perdendo o endereço IP

    Olá Pessoal, gostaria de solicitar a ajuda de vcs.

    Tenho uma rede conectado à um provedor de serviço à internet.

    Minha interface eth0 está com a seguinte configuração:
    auto eth0
    iface eth0 inet static
    address 200.xxx.xxx.xxx
    netmask 255.255.255.240
    gateway 200.xxx.xxx.x254
    dns-nameservers 200.xxx.xxx.131 200.xxx.xxx.130

    O problema é que a interface está perdendo este endereço e pegando um IP via DHCP da rede que a interface está conectada.

    Estou utilizado o Debian, sempre que o problema ocorre executo o comando:
    /etc/init.d/networking restart

    O endereço Ip da interface e configurado corretamente, mas depois de um tempo ele perde o endereço e configura para 192.168.51.240, que é o endereco que o provedor de acesso disponibiliza via DHCP.

    Att

    Humber

  2. #2

    Padrão

    Saudações humber,
    o que mais tem no seu arquivo interfaces? cola ele aqui



  3. #3

    Padrão

    Olá joseguilherme, o arquivo interfaces tem:

    auto lo
    iface lo inet loopback

    auto eth0
    iface eth0 inet static
    address 200.xxx.xxx.x46
    netmask 255.255.255.240
    gateway 200.xxx.xxx.x41
    dns-servers 200.xxx.xxx.x30 200.xxx.xxx.x31

    auto eth1
    iface eth1 inet static
    address 192.168.200.254
    netmask 255.255.255.0
    network 192.168.200.0
    broadcast 192.168.200.255


    O que ocorre é que em um determinado momento a interface eth0 muda o seu IP, eu executo o comando "/etc/init.d/networking restart" a configuração da eth0 volta ao normal, passando algum tempo ele perde o IP configurado e atribui outro.

    t+

    Humber

  4. #4

    Padrão

    tem algum daemon do dhcpc rodando !?!?!



  5. #5

    Padrão

    olá alexandrecorrea,

    tenho somente o dhcp3 rodando, para a interface eth1.

  6. #6

    Padrão

    Você por algum acaso alterou o script de inicialização do serviço? Dá uma olhada e veja o quê ele faz, linha a linha.


    Abraços!



  7. #7

    Padrão

    Pessoal, depois que eu reclamei com a operadora o problema parou. simplismente.

    Obrigado pela ajuda.

    t+