+ Responder ao Tópico



  1. #1

    Padrão Priorizar tráfego (QoS) - Http, pop3, msn, etc..

    Boa tarde pessoal... tenho um pequeno provedor rodando um servidor mkt, no qual controlo banda, mac...
    Gostaria de implementar um sistema de QOS, para priorizar trafego http, email, etc.. sendo q esses protocolos teriam prioridade sobre qualquer outro, como p2p e similares...ah e tb gostaria de saber se esse sistema ira interferir no meu atual controle de banda por io.
    Se alguem puder me ajudar.. fico muito grato.

    Atenciosamente
    Gabriel Siena

  2. #2

    Padrão

    Citação Postado originalmente por gsiena Ver Post
    Boa tarde pessoal... tenho um pequeno provedor rodando um servidor mkt, no qual controlo banda, mac...
    Gostaria de implementar um sistema de QOS, para priorizar trafego http, email, etc.. sendo q esses protocolos teriam prioridade sobre qualquer outro, como p2p e similares...ah e tb gostaria de saber se esse sistema ira interferir no meu atual controle de banda por io.
    Se alguem puder me ajudar.. fico muito grato.

    Atenciosamente
    Gabriel Siena
    A principio você deve marcar o tráfego das portas desejadas e criar uma regra na queue tree, liberando a banda "X" para cada serviço... Tal regra é semelhante a regra de marcação de pacotes P2P... Caso você tenha alguma dúvida sobre o procedimento, posta ae pra gente ve o que pode ser feito...



  3. #3

    Padrão Duvida

    Entao cara sobre o p2p eu fiz e funciona muito bem.. eu libero a banda "X" pra trafego p2p em toda a rede, entao é só fazer o mesmo com outros protocolos de minha nescessidade e deve dar certo... porem me surgiu uma duvida:
    Eu nao gostaria de limitar uma banda "X" pra esses serviços priorizados, como o http... eu deixaria ilimitado. mas se eu fizer isso perco o controle dessas portas no cliente?

    EX; joao contratou 200k de banda.. sem o qos esta limitado a 200k pra absolutamente tudo, certo?
    se eu implementar o qos ilimitado pra porta 80, joao vai ficar com banda ilimitada nessa porta ou ainda permanecem os 200k, com prioridade pra trafego http? entendeu?
    Todavia sua resposta ja me ajudou bastante.. obrigado

  4. #4

    Padrão

    Não irá perder... A regra diz basicamente que "x" protocolo irá ter sempre até "x" de banda mínima... No seu caso você deixará em queue tree para a porta 80 (http) por exemplo, ilimitado a banda... O cliente terá sempre o tráfego que ele contratou (joão 200k), o que irá limitar ou não a banda do serviço é a banda do cliente...



  5. #5

    Padrão

    Citação Postado originalmente por catvbrasil Ver Post
    Não irá perder... A regra diz basicamente que "x" protocolo irá ter sempre até "x" de banda mínima... No seu caso você deixará em queue tree para a porta 80 (http) por exemplo, ilimitado a banda... O cliente terá sempre o tráfego que ele contratou (joão 200k), o que irá limitar ou não a banda do serviço é a banda do cliente...

    David como ficaria essa regra caso eu queira priorizar o tráfego http?

  6. #6

    Padrão

    /ip firewall mangle

    add chain=prerouting connection-mark=http-down action=mark-packet new-packet-mark=HTTP passthrough=yes comment="" \
    disabled=no

    /queue tree
    add name="http_down" parent=global-in packet-mark=HTTP limit-at=948000 queue=default priority=2 max-limit=1000000 \
    burst-limit=0 burst-threshold=0 burst-time=0s disabled=no



  7. #7

    Padrão

    Citação Postado originalmente por rps67 Ver Post
    /ip firewall mangle

    add chain=prerouting connection-mark=http-down action=mark-packet new-packet-mark=HTTP passthrough=yes comment="" \
    disabled=no

    /queue tree
    add name="http_down" parent=global-in packet-mark=HTTP limit-at=948000 queue=default priority=2 max-limit=1000000 \
    burst-limit=0 burst-threshold=0 burst-time=0s disabled=no
    Coloquei aqui mais acho que não tá funcionando, o contador de bytes/packets não sai de 0.

  8. #8

    Padrão

    Citação Postado originalmente por rps67 Ver Post
    /ip firewall mangle

    add chain=prerouting connection-mark=http-down action=mark-packet new-packet-mark=HTTP passthrough=yes comment="" \
    disabled=no

    /queue tree
    add name="http_down" parent=global-in packet-mark=HTTP limit-at=948000 queue=default priority=2 max-limit=1000000 \
    burst-limit=0 burst-threshold=0 burst-time=0s disabled=no
    Por favor me explique o q exatamente faz essa regra, o seu efeito e emq isso pode ajudar?



  9. #9

    Padrão

    Citação Postado originalmente por maxmelo Ver Post
    Por favor me explique o q exatamente faz essa regra, o seu efeito e emq isso pode ajudar?
    Ae em cima são 2 regras, mas basicamente são 1. Esta regra serve pára marcar o tráfego http (porta 80) e garantir a banda de "xx" kpbs... Bascimante é isso... Prioriza o tráfego e pode ser implementada também em um loadbalance...

  10. #10

    Padrão

    Citação Postado originalmente por catvbrasil Ver Post
    Ae em cima são 2 regras, mas basicamente são 1. Esta regra serve pára marcar o tráfego http (porta 80) e garantir a banda de "xx" kpbs... Bascimante é isso... Prioriza o tráfego e pode ser implementada também em um loadbalance...
    Eu tenho um link de 1 mb de qto vc acha q eu devo colocar o XX ?



  11. #11

    Padrão

    Citação Postado originalmente por maxmelo Ver Post
    Eu tenho um link de 1 mb de qto vc acha q eu devo colocar o XX ?
    É aquele negócio... Tudo vai depender do seu cenário ae.... Aqui eu trabalho e configuro desenas de servidores e não aplico esta regra... Acho que ela é eficiente em casos específicos como VOiP (que necessita de banda mínima) ou outra porta que precise de banda mínima pra funcionar.... Como eu disse, estas regras são adaptações de marcadores de pacote, usados em loadbalance... Acho que você deve deixar como está se não está tendo problema e marcar apenas pacotes importantes, como UDP e P2P....

  12. #12

    Padrão

    Citação Postado originalmente por catvbrasil Ver Post
    É aquele negócio... Tudo vai depender do seu cenário ae.... Aqui eu trabalho e configuro desenas de servidores e não aplico esta regra... Acho que ela é eficiente em casos específicos como VOiP (que necessita de banda mínima) ou outra porta que precise de banda mínima pra funcionar.... Como eu disse, estas regras são adaptações de marcadores de pacote, usados em loadbalance... Acho que você deve deixar como está se não está tendo problema e marcar apenas pacotes importantes, como UDP e P2P....
    Obrigado mesmo a sua regra de udp q copiei em outro post esta funcionando muito bem pois os novos emules estavam barrando a protecao p2p, inclusive eu estava fazendo alguns testes e eu mesmo estava chegando a velocidades acima de 40 mesmo com a protecao e depois q coloquei as novas regras caiu drasticamente, aqui fica meu obrigado e vlw pela dica acima.



  13. #13

    Padrão

    Citação Postado originalmente por maxmelo Ver Post
    Obrigado mesmo a sua regra de udp q copiei em outro post esta funcionando muito bem pois os novos emules estavam barrando a protecao p2p, inclusive eu estava fazendo alguns testes e eu mesmo estava chegando a velocidades acima de 40 mesmo com a protecao e depois q coloquei as novas regras caiu drasticamente, aqui fica meu obrigado e vlw pela dica acima.
    Valeu!!! Esta do UDP foi criado por mim mesmo outro dia destes,.,,, Esta é mais uma regra dinâmica, que crio de acordo com o problema!!! hehehehehe

    Obrigado ae!!

  14. #14
    mantovani
    Visitante

    Talking parabens pela atitude...valew

    Citação Postado originalmente por catvbrasil Ver Post
    Ae em cima são 2 regras, mas basicamente são 1. Esta regra serve pára marcar o tráfego http (porta 80) e garantir a banda de "xx" kpbs... Bascimante é isso... Prioriza o tráfego e pode ser implementada também em um loadbalance...
    olha.... essa regra me ajudou muito.... ficou fera a http do meu serviço que estava prejudicada... simplesmente demais...

    será que vc poderia me dizer como implementar um loadbalance no MT para que os dois links que tenho funcionem ao mesmo tempo somando os dois para aumentar minha velocidade?
    muito obrigado



  15. #15

    Padrão

    Apenas cuidado, muitos programas de P2P tbem usam a porta 80, principalmente se você estiver usando um limite de conexões em portas altas...

  16. #16

    Padrão

    Por Favor, alguém posta aí as regras completas de como priorizar HTTP acima dos outros protocolos ?!



  17. #17

    Padrão

    Olá Pessoal,

    Mas tenho uma dúvida :

    Fiz tudo certo como diz a regra aí, tá funcionando etc...

    Mas no meu caso, eu coloquei 1mb para a queue-tree.
    Minha dúvida é ?

    Esse 1 mb é para todos meus 80 clientes ?

    Cada um vai ter sempre 1 MB, creio q não pois nas queues dos clientes, vai barrar ?

    Creio q esta regra, vai tentar manter sempre 1 MB livre para o HTTP..
    Me tirem essa dúvida.

    É super interessante, pois tenho uns clientes que jogam Counter-Strike e estão reclamando um pouco do ping deles, e se eu pudesse priorizar para eles o tráfego na 27015 TCP e outras, seria muito bom.

    Abraços

  18. #18

    Padrão

    Alguém saberia responder minha pergunta e a do colega alandias ?



  19. #19

    Padrão

    Como ninguém deu "ouvidos" a mim e ao colega alamdias, corri atrás e desenvolvi as regras de prioridade HTTP com base nas regras de P2P.

    1º - Marca os pacotes HTTP porta 80:

    / ip firewall mangle
    add chain=prerouting protocol=tcp dst-port=80 action=mark-connection \
    new-connection-mark=http_conn passthrough=yes comment="MARCA PACOTES HTTP" \
    disabled=no
    add chain=prerouting connection-mark=http_conn action=mark-packet \
    new-packet-mark=http passthrough=yes comment="" disabled=no

    2º - Cria a queue tree com reserva de banda desejada e prioriza em 1 ou 2:

    / queue tree
    add name="HTTP_down" parent=global-in packet-mark=http limit-at=100000 queue=default priority=2 max-limit=256000 \
    burst-limit=0 burst-threshold=0 burst-time=0s disabled=no

    Pronto!

  20. #20

    Padrão

    Alguém saberia dizer q tipos de pacotes são usados na hora de fazer download, e quais tipos de pacotes o msn usa?