+ Responder ao Tópico



  1. #1

    Padrão Home do Samba - perfil de usuario

    Amigos, estou com o seguinte problema, eu tenho um servidor dominio (samba / ldap) e os usuarios possuem uma area pessoal que é mapeada como letra M:
    A configuração no smb.conf está assim:
    Código :
     
    [homes]
      comment = Diretorio do Usuario
      read only = No
      create mask = 0664
      directory mask = 0775
      browseable = No
      veto files = /*.mp3/ /*.MP3/ /*.Mp3/ /*.mP3/ /*.WAV/ /*.wav/ /*.MPEG/ /*.mpeg/ /*.MPG/ /*.mpg/ /*.AVI/ /*.avi/ /*SEXO*/ /*sexo*/ /*SAINT*/ /*saint*/ /*ROM*/ /*rom*/
      vfs object = recycle
    Mas todos os usuarios que digitarem \\dominio\nomedeusuario acessa a pasta. Isso quer dizer, se o Joao fizer \\dominio\pedro ele ira acessar a pasta do Pedro.

    Como eu limito a apenas o usuário acessar o mapeamento dele.?

    Me falaram para usar o seguinte:

    Código :
    valid users = %S

  2. #2

    Padrão

    Provavelmente os diretórios dos usuários localizados dentro da pasta /home estão com permissão 755, ao invés de 700. Verifique.


    Abraços!



  3. #3

    Cool

    Pco valeu.
    É isso mesmo. Estava com permissão 766.
    Engraçado que eu vou averiguar quem fez essa arte, pois eu tenho esse server já há quase 2 anos e só agora ocorreu isso. Isso indica quem alguém fez essa arte, isso inclui eu. .!
    Bom, eu aproveitei e voltei no samba a flag :

    Código :
    valid users = %U
    para que não fique pedindo senha caso alguém tentar, assim já dá a mensagem de falta de permissão na hora.

    É tem uma coisa que eu concordo com você, se existisse extensão de usuário seria .f$$

    Valeu a todos.
    T+

  4. #4

    Padrão

    Que bom que resolveu o seu problema, mas se ajudou, é de boa praxe clicar no botão "Agradecer"! =)



  5. #5

    Smile

    Oia. Eu não tinha visto.!!!
    Valeu pco.

    Viva os .fdp, sem eles não existiria razão para evoluirmos ....