Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. Olá pessoal...
    Meu mikrotik está funcionando normalmente, preciso agora implemetar um redirecionamento do tráfego P2P para um link novo que instalei agora.

    Tenho a rede local(clientes) em ETHER2 - 192.168.168.0
    Link1(WAN) principal é na ETHER1(DHCP CLIENT)
    e agora instalei o novo Link2(WAN) - 192.168.1.2

    Quero manter tudo no link1 principal (http, msn, ftp, skype...) e direcionar somente os sistemas p2p para o link2

    Obs.: Clientes se conectam por PPPoE na ETHER2

    o que já tentei fazer:
    Primeiro em /ip route adicionei: DESTINATION 0.0.0.0/0, GATEWAY 192.168.1.2, MARK=P2P
    Depois criei em /firewall nat criei CHAIN SRCNAT, OUT INTERFACE ETHER3 ACTION MASQUERADE
    E por fim em /firewall mangle adicionei CHAIN PREROUTING, P2P ALL-P2P, ACTION MARK ROUTING, NEW ROUTING MARK P2P, PASSTHROUGH YES

    Resultado: Tudo funciona na rede menos P2p que não consegue conectar, daí para teste fiz o seguinte: tirei a opção p2p=all-p2p e coloquei meu ip em src. adress, resultado, acessei a internet (http) através do link novo sem problemas inclusive p2p. agora se eu marco a opção p2p=all-p2p, pronto para de funcionar o p2p.

    Se alguem conhece do assunto favor colaborar com mais esta.

  2. acontece o seguinte,

    quando você manda marcar pacotes p2p, o sistema só entende que é p2p após a conexão estar estabilizada, ou seja, a conexão acontece depois o servidor identifica que tipo de conexão.

    ...quando estamos tentando controlar a banda ou bloquear a conexão isso funciona perfeitamente, porém jogar pra outro link dessa forma não funciona.
    não funciona pois se a conexão já está estabilizada não tem como vc forçar desconectar e conectar pelo outro link

    (espero ter consiguido explicar o funcionamento nas linhas acima)

    mas espere, nem tudo está perdido!!!!
    existe uma solução!!!

    ao invés de você tentar marcar pelo tipo de pacote, vocÊ faz isso pela porta.

    link1 = 80, 443, 110, 25, 143 (nevegação e e-mail)
    link2 = todoas outras portas.

    vc deverá seguir a mesma linha de raciocínio da sua tentative inicial, apenas mudando de p2p para o número da porta!

    faça o teste e poste o resultado aqui pra comnidade.

    []´s



  3. Tem como dar exemplo ai de regras pra fazer isso funcionar?

  4. Citação Postado originalmente por ijr Ver Post
    acontece o seguinte,

    quando você manda marcar pacotes p2p, o sistema só entende que é p2p após a conexão estar estabilizada, ou seja, a conexão acontece depois o servidor identifica que tipo de conexão.

    ...quando estamos tentando controlar a banda ou bloquear a conexão isso funciona perfeitamente, porém jogar pra outro link dessa forma não funciona.
    não funciona pois se a conexão já está estabilizada não tem como vc forçar desconectar e conectar pelo outro link

    (espero ter consiguido explicar o funcionamento nas linhas acima)

    mas espere, nem tudo está perdido!!!!
    existe uma solução!!!

    ao invés de você tentar marcar pelo tipo de pacote, vocÊ faz isso pela porta.

    link1 = 80, 443, 110, 25, 143 (nevegação e e-mail)
    link2 = todoas outras portas.

    vc deverá seguir a mesma linha de raciocínio da sua tentative inicial, apenas mudando de p2p para o número da porta!

    faça o teste e poste o resultado aqui pra comnidade.

    []´s
    a regra pra direcionar as portas listadas blz, mais pra as outras portas todas, como faz...



  5. tenho um load balance que funciona assim,mas o modem funciona como router. Posso te garantir que vai exijir muito conhecimento pra fazer funcionar certim, mas vai ae um exemplo, dê uma estudada pode te auxiliar:
    /ip firewall mangle
    add chain=prerouting dst-address=200.0.0.0/8 protocol=tcp dst-port=0-110 action=mark-routing \
    new-routing-mark=TCP-0-110/200 passthrough=yes comment="" disabled=no
    add chain=prerouting dst-address=201.0.0.0/8 protocol=tcp dst-port=0-110 action=mark-routing \
    new-routing-mark=TCP-0-110/201 passthrough=yes comment="" disabled=no
    add chain=prerouting dst-address=11.0.0.0-201.45.12.1 protocol=tcp dst-port=111-1862 action=mark-routing \
    new-routing-mark=TCP-111-1862/1 passthrough=yes comment="" disabled=no






Tópicos Similares

  1. Respostas: 1
    Último Post: 28-11-2007, 00:49
  2. Respostas: 0
    Último Post: 24-11-2007, 01:18
  3. Redirecionar porta 53 para outro link
    Por bitim no fórum Redes
    Respostas: 5
    Último Post: 13-11-2007, 10:04
  4. Direcionar p2p para outro link
    Por virtualnet no fórum Redes
    Respostas: 2
    Último Post: 11-09-2007, 21:39
  5. Respostas: 9
    Último Post: 21-12-2006, 23:15

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L