+ Responder ao Tópico



  1. #1

    Padrão Contingencia no LoadBalance

    Bom dia,

    Seguindo este manual de LB por rotas estaticas, cheguei a um resultado muito bacana e muito util: Load Balancing over Multiple Gateways - MikroTik Wiki

    Mas, gostaria de um LB um pouco mais inteligente e tambem gostaria de saber se alguem aqui ja tentou fazer algo do tipo, vamos la?! Ex:

    Tenho uma rede

    192.168.0/32

    GW1
    192.168.0.1-192.168.0.50/32

    GW2
    192.168.0.51-192.168.0.101/32

    GW3
    192.168.0.102-192.168.0.152/32

    OK? tudo certo e maravilhoso, mais eu gostaria de adicionar uma função que no momento eu nao tenho ativa. Quando o GW1 ficar fora do AR o proprimo MK reconhece esse problema e passa do grupo do GW1 para o GW2, e que ao GW1 voltar a funcionar o MK tb faça o contrario.

    Existe alguma receitinha de bolo para essa função?
    Existe algum script que consiga automatizar esse tipo de função?

    Vlw galera!

  2. #2

    Padrão

    Citação Postado originalmente por iceblue Ver Post
    Bom dia,

    Seguindo este manual de LB por rotas estaticas, cheguei a um resultado muito bacana e muito util: Load Balancing over Multiple Gateways - MikroTik Wiki

    Mas, gostaria de um LB um pouco mais inteligente e tambem gostaria de saber se alguem aqui ja tentou fazer algo do tipo, vamos la?! Ex:

    Tenho uma rede

    192.168.0/32

    GW1
    192.168.0.1-192.168.0.50/32

    GW2
    192.168.0.51-192.168.0.101/32

    GW3
    192.168.0.102-192.168.0.152/32

    OK? tudo certo e maravilhoso, mais eu gostaria de adicionar uma função que no momento eu nao tenho ativa. Quando o GW1 ficar fora do AR o proprimo MK reconhece esse problema e passa do grupo do GW1 para o GW2, e que ao GW1 voltar a funcionar o MK tb faça o contrario.

    Existe alguma receitinha de bolo para essa função?
    Existe algum script que consiga automatizar esse tipo de função?

    Vlw galera!
    Na verdade são alguns scripts que devem ser incluidos junto a algumas configurações... Dá uma olhada no wiki internacional do mikrotik que lá tem...

    MikroTik Routers and Wireless



  3. #3

    Padrão

    Citação Postado originalmente por catvbrasil Ver Post
    Na verdade são alguns scripts que devem ser incluidos junto a algumas configurações... Dá uma olhada no wiki internacional do mikrotik que lá tem...

    MikroTik Routers and Wireless

    OK, vou dar uma pesquisada e se eu conseguir alguma coisa, posto aqui pra galera...vlw!

  4. #4
    Mikrotik inSide Avatar de luizbe
    Ingresso
    Sep 2005
    Localização
    Governador Valadares
    Posts
    1.212
    Posts de Blog
    1

    Padrão

    iceblue, vou te passar meu msn,
    [email protected] add,

    tenho ajudados varios com esses lados de load balance , sem cobrar.
    não me digo "hyper profissional" mas faço funcionar.

    qualquer coisa,
    estou aqui pra te ajudar.



  5. #5

    Padrão

    Citação Postado originalmente por luizbe Ver Post
    iceblue, vou te passar meu msn,
    [email protected] add,

    tenho ajudados varios com esses lados de load balance , sem cobrar.
    não me digo "hyper profissional" mas faço funcionar.

    qualquer coisa,
    estou aqui pra te ajudar.
    Kra, sou muitooo grato pela sua ajuda e realmente preciso dela, mais eu prefiro que seja feito pelo forum, acredito que boa parte das pessoas que participam tem a mesma duvida.

    Volto a agradecer a presteza e boa vontade!

  6. #6
    Mikrotik inSide Avatar de luizbe
    Ingresso
    Sep 2005
    Localização
    Governador Valadares
    Posts
    1.212
    Posts de Blog
    1

    Padrão

    espero que você intenda, que:

    nós no ramo de telecom.
    é o dia todo ralando, cliente ligando até quando você tá durmindo ou tá jantando.

    é muito dificil, e te garanto 20 a 30 minutos fazendo um tutorial é complicado.

    agora ter tempo pra fazer as regras e aprender com aquilo já é outro.
    é um tempo que nós tiramos pra aprender, e ver funcionando,
    já que na minha estrutura eu não preciso do load.


    qualquer coisa, estarei disposto a lhe ajudar.



  7. #7

    Padrão

    / tool netwatch
    add host=201.10.209.185 timeout=1s interval=45s up-script=link-1M-3613-UP \
    down-script=link-1M-3613-DOWN comment="link-1M-3613" disabled=no
    add host=201.10.249.53 timeout=1s interval=40s up-script=link-1M-5581-UP \
    down-script=link-1M-5581-DOWN comment="link-1M-5581" disabled=no
    add host=200.160.2.3 timeout=1s interval=45s up-script=link-800-5314-UP \
    down-script=link-800-5314-DOWN comment="link-800-5314" disabled=no
    add host=201.10.209.189 timeout=1s interval=45s up-script=link-600-4876-UP \
    down-script=link-600-4876-DOWN comment="link-600-4876" disabled=no
    add host=201.10.249.57 timeout=1s interval=40s up-script=link-1M-5581-UP \
    down-script=link-1M-5581-DOWN comment="link-Dedicado" disabled=no
    -----------------------------------------------------------------------
    / system script
    add name="link-800-5314-UP" source="/ip route set \[/ip route find \
    gateway=10.4.1.1\] disabled=no" policy=ftp,reboot,read,write,test,winbox
    add name="link-800-5314-DOWN" source="/ip route set \[/ip route find \
    gateway=10.4.1.1\] disabled=yes" policy=ftp,reboot,read,write,test,winbox
    add name="link-600-4876-UP" source="/ip route set \[/ip route find \
    gateway=10.5.1.1\] disabled=no" policy=ftp,reboot,read,write,test,winbox
    add name="link-600-4876-DOWN" source="/ip route set \[/ip route find \
    gateway=10.5.1.1\] disabled=yes" policy=ftp,reboot,read,write,test,winbox

    Estudo ae, funciona 100%, não esqueça de colocar no ip route o mesmo ip setado em tool netwatch apontando para o gateway do link específico.

  8. #8

    Padrão

    Citação Postado originalmente por luizbe Ver Post
    espero que você intenda, que:

    nós no ramo de telecom.
    é o dia todo ralando, cliente ligando até quando você tá durmindo ou tá jantando.

    é muito dificil, e te garanto 20 a 30 minutos fazendo um tutorial é complicado.

    agora ter tempo pra fazer as regras e aprender com aquilo já é outro.
    é um tempo que nós tiramos pra aprender, e ver funcionando,
    já que na minha estrutura eu não preciso do load.


    qualquer coisa, estarei disposto a lhe ajudar.

    Obrigado!!



  9. #9

    Padrão

    Citação Postado originalmente por rps67 Ver Post
    / tool netwatch
    add host=201.10.209.185 timeout=1s interval=45s up-script=link-1M-3613-UP \
    down-script=link-1M-3613-DOWN comment="link-1M-3613" disabled=no
    add host=201.10.249.53 timeout=1s interval=40s up-script=link-1M-5581-UP \
    down-script=link-1M-5581-DOWN comment="link-1M-5581" disabled=no
    add host=200.160.2.3 timeout=1s interval=45s up-script=link-800-5314-UP \
    down-script=link-800-5314-DOWN comment="link-800-5314" disabled=no
    add host=201.10.209.189 timeout=1s interval=45s up-script=link-600-4876-UP \
    down-script=link-600-4876-DOWN comment="link-600-4876" disabled=no
    add host=201.10.249.57 timeout=1s interval=40s up-script=link-1M-5581-UP \
    down-script=link-1M-5581-DOWN comment="link-Dedicado" disabled=no
    -----------------------------------------------------------------------
    / system script
    add name="link-800-5314-UP" source="/ip route set \[/ip route find \
    gateway=10.4.1.1\] disabled=no" policy=ftp,reboot,read,write,test,winbox
    add name="link-800-5314-DOWN" source="/ip route set \[/ip route find \
    gateway=10.4.1.1\] disabled=yes" policy=ftp,reboot,read,write,test,winbox
    add name="link-600-4876-UP" source="/ip route set \[/ip route find \
    gateway=10.5.1.1\] disabled=no" policy=ftp,reboot,read,write,test,winbox
    add name="link-600-4876-DOWN" source="/ip route set \[/ip route find \
    gateway=10.5.1.1\] disabled=yes" policy=ftp,reboot,read,write,test,winbox

    Estudo ae, funciona 100%, não esqueça de colocar no ip route o mesmo ip setado em tool netwatch apontando para o gateway do link específico.
    Vou fazer o teste e volto a postar!