+ Responder ao Tópico



  1. #1

    Exclamation 2 Link embratel - Cisco 3800

    Pessoal recebi agora 4mb pela embratel, eles me disseram que estava configurado o balancemanto por pacotes, liguei os modems nas seriais do meu Cisco MC3800, mas não consigo ativar o balanceamento nele... o que foi feito:

    - Configurados os ips de todas as interfaces (serial0, serial1, ethernet)
    - Configurado as 2 rotas padrão de cada serial

    Só que ao fazer isso e eu mandar pingar, ele pinga um e outro não... fica falhando, falei com um amigo e ele disse que tenho que dar o comando ip load-sharing per-packet em cada serial para que o balanceamento por pacotes funcione... só que a versão do IOS do meu router é 12.0, não tem a opção ip load-sharing.... existe alguma outra forma de ativar esse 2 links nesse router por pacote? Se não existir como posso fazer as configuração para que os 2 links funcionem... estou com os circuitos ativados mas sem funcionar por causa desse problema.... Agradeço desde já a quem poder me ajudar e aguardo retorno aqui da comunidade underlinux, obrigado.

  2. #2
    Under-linux.Org Team Avatar de MarcusMaciel
    Ingresso
    Dec 2000
    Localização
    Boston
    Posts
    1.970
    Posts de Blog
    44

    Padrão

    Amigo esse comando vc ativa dentro da interface...


    conf t
    int serial0/0
    ip load-sharing per-packet
    int serial0/1
    ip load-sharing per-packet


    control c
    write mem


    lembrando que vc pode balancear por pacote e por destino...
    e recomendo vc habilitar o cef para diminuir a cpu do roteador

    conf t
    ip cef






  3. #3

    Exclamation

    Olá scorpion, esse é o meu problema, a versão do IOS do meu router não tem o ip load-sharing e muito menos ip cef (IOS 12.0 XK1).... então no meu caso teria que ser por destino o balanceamento num é isso? o que eu quero fazer é colocar apenas as configurações de ips das seriais e depois colocar as 2 rotas padrões desse jeito

    ip route 0.0.0.0 0.0.0.0 s0
    ip route 0.0.0.0 0.0.0.0 s1

    Ai ficaria por destino é isso? Teria que falar com a embratel apenas para mudar lá na ponta deles, pois ele me disseram que está por pacote no momento e do jeito que está quando eu coloco as 2 rotas padrão e mando dar um ping pra qualquer lugar ele pinga um e perde outro.... e fica nesse perde volta, aguardo seu retorno.

    O Roteador é um Cisco MC3810.
    Última edição por TheHawk; 06-06-2007 às 07:20.

  4. #4
    Under-linux.Org Team Avatar de MarcusMaciel
    Ingresso
    Dec 2000
    Localização
    Boston
    Posts
    1.970
    Posts de Blog
    44

    Padrão

    po cara.. teu IOS é o mais simples ne.. bom... so de ter as duas rotas pra serial 0 e serial 1 mesmo assim já é um balanceamento... o ideal é isso mesmo pedir pra embratel configurar o balanceamento por destino para resolver esse pequeno problema...

    mais a longo prazo recomendaria baixar um ios mais atualizado com suporte a balanceamento por pacote e cef...



  5. #5

    Exclamation

    Olá scorpion, segundo a embratel eles habilitaram o balanceamento por destino, mas ai eu adiciono os ips nas seriais, coloco as 2 rotas padrão e o router continua perdendo pacotes, se eu deixar apenas a rota da serial0 funciona uma maravilha, mas quando coloco a segunda rota padrão dá problema, poderia me ajudar na configuração do mesmo? Agradeceria muito.

  6. #6
    Under-linux.Org Team Avatar de MarcusMaciel
    Ingresso
    Dec 2000
    Localização
    Boston
    Posts
    1.970
    Posts de Blog
    44

    Padrão

    vc ja tento so colocar rota padrao pra serial 1 ??? pq dependendo pode ser um problema no teu circuito da serial 1



  7. #7

    Exclamation

    Já sim scorpion, se eu deixar uma das 2 rotas padrão como default, só ela sozinha funciona tudo blz.... mas quando adiciono as 2 rotas ai começa a dar perda de pacote, minha configuração das interfaces e das está abaixo:

    interface Ethernet0
    description FIBRA-INTERNA-03-04
    ip address 189.xxx.xxx.145 255.255.255.128
    no ip directed-broadcast

    interface Serial0
    description XXX IP 0005
    bandwidth 2048
    ip address 189.xxx.xxx.30 255.255.255.252
    ip directed-broadcast
    encapsulation ppp

    interface Serial1
    description XXX IP 0006
    bandwidth 2048
    ip address 189.xxx.xxx.34 255.255.255.252
    ip directed-broadcast
    encapsulation ppp

    ip classless
    ip route 0.0.0.0 0.0.0.0 Serial0
    ip route 0.0.0.0 0.0.0.0 Serial1

    é assim que está a minha configuração, mas quando está as 2 rotas padrões desse jeito ai fica dando perda de pacotes, se eu retirar qualquer uma delas funciona normal, a minha tabela de roteamento abaixo:

    189.xxx.0.0/16 is variably subnetted, 4 subnets, 2 masks
    C 189.xxx.xxx.32/30 is directly connected, Serial1
    C 189.xxx.xxx.33/32 is directly connected, Serial1
    C 189.xxx.xxx.28/30 is directly connected, Serial0
    C 189.xxx.xxx.29/32 is directly connected, Serial0
    189.xxx.0.0/25 is subnetted, 1 subnets
    C 189.xxx.xxx.128 is directly connected, Ethernet0
    S* 0.0.0.0/0 is directly connected, Serial0
    is directly connected, Serial1

    Se poder me dar uma luz eu agradeço.

  8. #8

    Padrão

    Olá, caso você esteja pingando para serial da EBT, vai dar perda mesmo justamente por causa do balanceamento, pois ora ele envia um pacote para uma serial hora para outra, tente pingar um outro endereço, ou mesmo pelo nome e verá que não esta perdendo pacotes o teu link.

    Sds,

    Rwidal.

    P.S.: outra coisa que costuma acontecer, é com relação a acesso remoto, ao tentar acessar o router via telnet pela serial, vai dar problema, também pelo fato do balanceamento, ai é so acessar via telnet pela lan e não pela wan.



  9. #9

    Exclamation

    Olá rwidal, esse é pro.... se fosse só pra ponta da embratel estaria blz... mas quando está com as 2 rotas padrões se eu pingar por exemplo para o uol ele pinga um e perde outro e se eu deixar apenas uma rota padrão (ex: serial0) ele pinga tudo, acessa tudo sem nenhuma perca.... quando está com as 2 rotas não consigo pingar meu bloco de ips reais da rede interna, fica com o mesmo sintoma, passa um pacote, perde outro.... não sei mais o que fazer nesse caso, segundo uma pessoa da embratel ele fizeram a mudança para balanceamento por destino, alguma ideia do que possa ser?

    Ahh... se eu pingar as seriais da embratel não perde pacote... só perde para outros endereços.

  10. #10

    Padrão

    Com 2 Rotas Default nao vai funcionar sem o balanceamento,,,

    Na minha opiniao. O Mais indicado e configurar os destinos com rotas staticas e gerenciar pelo firewall



  11. #11

    Padrão

    Olha funciona sem problemas com o balanciamento por destino, caso ainda não tenha feito faça o seguinte: teste os dois link´s separados e veja se não tem algum com taxa de erros.
    Feito isto verifique se esta apenas com duas rotas defalt apontado cada uma para a o IP da seria da EBT, verificado isto só resta que algum link esteja com problema, mas o mais provavel é que na ebt ainda esteja configurado o balanceamento por pacote que também vai causar esta caracteristica.
    Quais são as designações dos seu link, me informe, pode ser por PV, que vou ver se consigo alguma informação.

  12. #12

    Padrão

    estava vendo a cituação do colega e resolvi ver no que posso ajudar
    tenho tb dois links da embratel 4 mb full

    veja como esta as minhas configurações:

    interface Serial0
    description LINK Embratel 1
    bandwidth 2048
    ip address xxxxxx 255.255.255.252
    encapsulation ppp
    load-interval 30
    !
    interface Serial1
    description Embratel 2
    ip address xxxxxx 255.255.255.252
    encapsulation ppp
    load-interval 30

    ip route 0.0.0.0 0.0.0.0 xx.xx.xx.xx.xx
    ip route 0.0.0.0 0.0.0.0 xx.xx.xx.xx.xx

    e esta fucionando super bem 100% sem perda.



  13. #13

    Talking Problema resolvido gente!!!

    Olá pessoal, desculpe não ter respondido o forum, mas não recebi as notificações das mensagems de vocês (só recebi agora quando o colega fsoaress76 mandou a mensagem dele).... Bem mas minha situação ficou assim.... consegui uma atualização de IOS do meu Cisco 3800 e com isso as opções ip cef e ip load-sharing se tornaram disponiveis, dai foi só configurar as seriais, rotas padrão, ativar o ip cef e o ip load-sharing per-packet em cada serial, não demorou nem 5 min pra ficar tudo pronto, o tecnico da embratel mudou novamente a configuração pra pacotes e todo mundo ficou contente.... , não tive mais problemas e os circuitos estão todos perfeitos, obrigado a todos que me ajudaram aqui, agradeço muito mesmo.... (passei algum tempo com os circuitos desbalanceados, estavam funcionando, mas não estavam 100%, mas agora está tudo ok), até mais pessoal.

  14. #14

    Question

    nao sei se ja solucionou o problema mas porque nao configura um loadbalance para ter um link de saida de 4 mega?
    mesmo quando um para o outro continua funcionando, tera somente uma faixa wan e outra faixa lan.



  15. #15

    Padrão

    Citação Postado originalmente por vernal Ver Post
    nao sei se ja solucionou o problema mas porque nao configura um loadbalance para ter um link de saida de 4 mega?
    mesmo quando um para o outro continua funcionando, tera somente uma faixa wan e outra faixa lan.
    Olá vernal, o problema já foi resolvido, tudo está balanceado e funcionando perfeitamente.... mas você poderia me explicar como é isso ai? Pode vir a servir mais pra frente, me ajudaria e a outros do forum tambem, obrigado e até mais.

  16. #16

    Padrão

    Outra coisa muito importante quando se utiliza link acima de 02Mbps, é deixar setado a velocidade da fast manualmente nunca deixe auto, se a switch trabalhar a 100Mbps deixar em 100 e full-duplex, caso não deixe assim comece a verificar a interface que ou vai estar gerando CRC ou colisões um dois dois, dependendo se estiver em full ou half-duplex.

    Sds,

    Rwidal