+ Responder ao Tópico



  1. Citação Postado originalmente por GEISSONHUGO Ver Post
    funcionou fileh.....


    muito top....
    Eu não quero bloquear o cliente e sim enviar um aviso assim que ele conectar. se vc tiver essa regra eu vou ficar muito agradecido.

    valeu

  2. Citação Postado originalmente por balisteri Ver Post
    Ola pessoal fiz de acordo com as regras que o CATV postou aqui no forum, bom aqui esta funcionando perfeito, o unico problema é que as vezes a pagina não carrega e quando não carrega as vezes redireciona para ela mesma varias vezes para a mesma pagina que esta no ironwall.

    CATV eu não sei se tem um tipo de timer que conta quando o cara acessou assim faz passar direto ou tambem no ironwall pode estar a solução caso você ja tenha maravilha.

    Meus parabens pelo feito e fico o meu agradescimento, precisando de qualquer coisa entra em contato vlw brother.....
    Bom Pessoal aproveitando o tópico e por ter meio que beneficiado comas regras do amigo CATV
    Gostaria de Acrescentar mais informações sobre o sistema de boas vindas no qual justamente tem aquele problema que a página fica dando loop,
    Bom sobre este problema vi no meu caso que só acontecia com o Firefox, acho que deve ser por causa do tempo das conexões que configurei a 10seg para diminuir a quantidade de conexões na tabela do mikrotik (obs. não tenho certeza disso.)
    Então dei uma modificada na regra e ficou assim

    add action=netmap chain=dstnat comment="Tela de Boas Vindas" \
    connection-limit=!1,24 disabled=no dst-address=!178.26.0.1 dst-port=80 \
    limit=0/1m,0 protocol=tcp src-address=176.25.0.2-176.25.0.10 \
    to-addresses=178.26.0.1 to-ports=84

    Bom quero acrescentar que minha pagina esta no meu Server de cachê externo por isso um ip de outra faixa.
    Feito isto eu resolvi um dos meus problemas
    Agora gostaria de sabe por que depois de um tempo ex:20 segundos a paginas volta a ser exibida se aberto o navegador de novo , e por que dentro deste tempo os outros usuário não vem esta mensagem
    Tipo assim se eu exibir no meu PC só daqui 20 seg. vai poder ser exibida de novo mas só vai aparecer somente para um único usuário e assim por diante
    Será que tenho que criar uma regra pra cada ip ?
    Ou será que acontece isso por não ser o mesmo ip dos clientes?



  3. Pessoal, aki uso diferente pra cobrar meus clientes:

    Eu criei um script que de 10 em 10 minutos ele direciona para página de aviso de débitos em abertos, após 1 minuto libera novamente a conexão.

    Vou postar pra galera!

  4. muito interessante isso... muito mesmo... abraços




    Citação Postado originalmente por Kandango Ver Post
    Pessoal, aki uso diferente pra cobrar meus clientes:

    Eu criei um script que de 10 em 10 minutos ele direciona para página de aviso de débitos em abertos, após 1 minuto libera novamente a conexão.

    Vou postar pra galera!



  5. Citação Postado originalmente por catvbrasil Ver Post
    A classificação seria pelo IP do cliente... Vou mandar alguma coisa abaixo pra ter uma idéia da coisa...


    REDIRECIONAMENTO DE CLIENTES PARA PÁGINA INICIAL (PPPOE)

    /ip firewall nat
    add chain=dstnat src-address=10.0.0.1-10.0.0.253 dst-address=!10.0.0.2 \
    protocol=tcp dst-port=80 connection-limit=!1,24 action=dst-nat \
    to-addresses=10.0.0.2 to-ports=81 comment="REGRA PARA DEFINIR PÁGINA \
    INICIAL" disabled=no

    Esta regra acima define quem será a página inicial do cliente. Quando o mesmo entra no PPPoE, será direcionado automaticamente para a página sua que está no servidor local (dentro da rede). Para criar um servidor web simples em uma máquina windows, utilizei o soft "ironwall". Esta regra deve ser colocada logo após a regra de NAT, para seguir a irarquia de priorização do firewall. No exemplo acima o src-address é uma faixa de ips (10.0.0.1-10.0.0.253), na qual é redirecionada para o servidor web (winxp com ironwall) no ip 10.0.0.2. Para ser redirecionado automaticamente para sua página inicial, criei um código fonte dentro desta página inicial, recarrengando ela mesma, gerando assim, algumas conexões simultâneas e mudando automaticamente de página. Basicamente a regra funciona a ação do "conection limit".
    PS: A porta padrão do irowall foi alterada para a 81.


    BLOQUEIO DE CLIENTE PARA PÁGINA INICIAL

    /ip firewall nat
    add chain=dstnat src-address=10.0.0.1 dst-address=!10.0.0.2 protocol=tcp \
    dst-port=80 action=dst-nat to-addresses=10.0.0.2 to-ports=81 comment="REGRA \
    PARA DIRECIONAR CLIENTE PARA UMA MESMA PÁGINA \(D BITO\) - SISTEMA \
    INTELIGÊNTE DE BLOQUEIO" disabled=yes

    Esta regra é a mesma de cima, somente retirando o "conection limit" o mikrotik entenderá que em todas as circustâncias ele deve sempre redirecionar o cliente para o servidor (10.0.0.2). Neste caso o cliente 10.0.0.1 está bloqueado. A mesma página HTML pode ser utilizada (está em anexo), pois quando a mesma for redirecionada após os 10 segundos, irá voltar para ela mesma, criando um loop na qual o cliente não conseguirá sair e exibirá apenas aquela mensagem padrão de bloqueio. O ideal para ficar show, é incluir uma regra como a debaixo para este mesmo cliente, para bloquear todos os serviços, exceto o da página.

    REGRA ANEXA PARA BLOQUEIO DE CLIENTES

    /ip firewall nat
    add chain=src-nat src-address=10.0.0.1 protocol=!tcp \
    src-port=!80 action=drop comment="BLOQUEIO DE CLIENTE" \
    disabled=yes

    Com esta regra acima de exceção, o mikrotik bloqueará todas as portas e protocolos, menos a porta 80 e o protocolo tcp.

    Em anexo o ironwall e os arquivos da página inicial de testes... Dúvidas? Entre em contato que a gente desenvolve qualquer coisa!!!
    Devid assumi recentemente um provedor cujo o servidor foi feito por vc
    mais essa regra naum esta funcionando aguardo.
    ip firewall nat
    0 ;;; LOADBALANCE
    chain=srcnat action=masquerade src-address-list=A

    1 chain=srcnat action=masquerade src-address-list=B

    2 chain=srcnat action=masquerade src-address-list=C

    3 ;;; NAT
    chain=srcnat action=masquerade

    4 chain=dstnat action=dst-nat to-addresses=200.200.200.20 to-ports=80
    src-address=200.200.200.20-200.200.200.254 dst-address=!200.200.200.20
    dst-port=80 protocol=tcp connection-limit=!1,24

    5 ;;; WEB-PROXY
    chain=dstnat action=redirect to-ports=8080 dst-port=80 protocol=tcp
    Última edição por WellitonAndrade; 20-09-2008 às 02:34.






Tópicos Similares

  1. Respostas: 2
    Último Post: 21-06-2016, 17:51
  2. Respostas: 16
    Último Post: 15-10-2015, 15:35
  3. Respostas: 2
    Último Post: 12-07-2014, 09:42
  4. Respostas: 3
    Último Post: 24-08-2012, 12:34
  5. Pegar pagina inicial do cliente sem hotspot e pppoe
    Por cleciorodrigo no fórum Redes
    Respostas: 4
    Último Post: 27-01-2008, 17:12

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L