+ Responder ao Tópico



  1. #1

    Padrão Squid26 - Não completa downloads

    Caros

    recentemente reinstalei um servidor de cliente que usava Mandriva 2006 e atualizei para versão Mandriva 2007 Spring PowerPack, porem o proxy que esta na versao squid-2.6.STABLE7-2mdv2007.1, funciona normalmente quando voçê esta navegando, mais quando faz um downloads de arquivos o proxy não completa do downloads ficando arquivo corrompido (pela metade). Gostaria de sabe si alguem ja passo por isto ...

    Obs.: hardware não tem problemas, quando tiro o redirecionamento do proxy o downloads são comcluidos, as configurações são basicamente as mesma daque usava na versão anterior.

    Desde ja agradeço qualquer sujestão.

  2. #2

    Padrão

    procura o /var/log/squid/cache.log

    e cola aqui.. veja se no /var/log/messages da algum erro no squid !! se tiver.. cola tambem..

    isto esta parecendo erro de memoria (nao fisica) .. linux deve limitar os processos e o squid tenta consumir mais do que o linux permite.. entao ele da erro e da um "quick restart" .. tive este problema aqui..



  3. #3

    Padrão

    Saudações amigos,
    Eu já tive um problema desse tipo sub-zero.
    A gente havia desenvolvido um front-end em php para o squid, e havia um agendamento no cron para rodar o squid -k reconfigure a cada 2 minutos.
    Toda vez que havia alguém baixando algum arquivo ao rodar o squid -k reconfigure o download terminava abruptamente ou ficava corrompido.
    Não sei se isso se encaixa no seu caso.

    Abraço

  4. #4
    marlosboutin
    Visitante

    Padrão

    Olá a todos, estou com o mesmo problema, o pior é que estava funcionando normalmente até que isso começou a ocorrer emais:
    Este é o roteador de internet da rede Proxy / Firewall, já virei do avesso os logs e nada...
    Downloads param, e-mails deixam de ser baixados (para e não vai)
    conexão SSH de fora trava
    Obs os servidores DNS estão configurados no squid e nas estações.
    Desespero...
    HEHEHE
    Se alguém puder me ajudar Agradeço!
    Um abraço



  5. #5

    Padrão

    /var/log/squid

    da uma limpada nos logs

    talvez resolva

    ANTES de limpar, verifique o conteudo do cache.log e veja se ha algum erro !!


    cya !

  6. #6
    marlosboutin
    Visitante

    Padrão

    OK, Obrigado Alexandre farei isso e postarei o resultado...
    Um abraço



  7. #7
    marlosboutin
    Visitante

    Padrão Puxa VIDA

    Caro Alexandre
    Verifiquei os logs e estão normais, pelo sim pelo não apaguei tudo e recriei do zero, incluindo o cache e nada o problema persiste....
    Quando acesso a máquina remotamente via SSH a conexão trava!
    Absurdo, os poucos cabelos que eu tinha em cima cairam e os que ficaram ficaram completamente brancos...
    No squid não tem erro nenhum NADA não dá pau no stop, start restart
    continua autenticando usuáios, tenho mais de 60gb de espaço em disco SOCORRO! hehehehe
    Se alguém souber de mais alguma coisa dê um grito por favor, e se solucionar posto a solução encontrada...
    Abraço a todos

  8. #8

    Padrão

    entao.. talvez seja problema no sistema, nao ?

    se vc tirar o squid.. o servidor trava o ssh ? qual a configuracao do seu squid ?



  9. #9
    marlosboutin
    Visitante

    Padrão Tá na mão

    http_port 192.168.1.1:3128
    cache_mem 32 MB
    maximum_object_size 4096 KB
    cache_dir ufs /var/cache/squid 100 16 256
    cache_access_log /var/log/squid/access.log
    cache_log /var/log/squid/cache.log
    cache_store_log /var/log/squid/store.log
    emulate_httpd_log off
    error_directory /usr/share/squid/errors/Portuguese
    hierarchy_stoplist cgi-bin ?
    acl QUERY urlpath_regex cgi-bin \?
    dns_nameservers 200.203.217.11 201.10.120.2 201.10.128.3

    auth_param basic program /usr/sbin/ncsa_auth /etc/squid/passwd
    auth_param basic children 5
    auth_param basic realm Controle de Internet
    auth_param basic realm Autenticao de usuario
    auth_param basic credentialsttl 2 hours

    refresh_pattern ^ftp: 1440 20% 10080
    refresh_pattern ^gopher: 1440 0% 1440
    refresh_pattern . 0 20% 4320

    acl all src 0.0.0.0/0.0.0.0
    acl REDE src 192.168.1.0/24
    acl IPs_Liberados src "/etc/squid/diretoria"
    acl seminternet src "/etc/squid/seminternet"
    acl URLsNegadas dstdom_regex -i "/etc/squid/URLnegadas"
    acl PalavrasNegadas url_regex -i "/etc/squid/PalavrasNegadas"
    acl PalavrasLiberadas url_regex -i "/etc/squid/PalavrasLiberadas"
    acl semcache url_regex -i "/etc/squid/semcache"

    acl manager proto cache_object
    acl localhost src 127.0.0.1/255.255.255.255
    acl to_localhost dst 127.0.0.0/8
    acl SSL_ports port 443 563
    acl Safe_ports port 80 # http
    acl Safe_ports port 21 # ftp
    acl Safe_ports port 443 563 # https, snews
    acl Safe_ports port 70 # gopher
    acl Safe_ports port 210 # wais
    acl Safe_ports port 1025-65535 # unregistered ports
    acl Safe_ports port 280 # http-mgmt
    acl Safe_ports port 488 # gss-http
    acl Safe_ports port 591 # filemaker
    acl Safe_ports port 777 # multiling http
    acl CONNECT method CONNECT

    acl autentica proxy_auth "/etc/squid/passwd"
    acl auten proxy_auth REQUIRED
    no_cache deny QUERY semcache

    http_access allow manager localhost
    http_access deny manager
    http_access deny !Safe_ports
    http_access deny CONNECT !SSL_ports
    http_access allow localhost

    http_access allow IPs_Liberados
    http_access deny seminternet
    http_access deny URLsNegadas
    http_access deny PalavrasNegadas !PalavrasLiberadas
    http_access allow autentica
    http_access allow REDE

    http_access deny all

    http_reply_access allow all

    icp_access allow all

    coredump_dir /var/cache/squid

    logfile_rotate 4

    visible_hostname proxy

  10. #10
    marlosboutin
    Visitante

    Talking Resolvido

    O problema era o MODEM!!!!!! DSLink dos infernos!
    Mudamos de 800Kb p/ 1Mb / 512 e coloquei um Siemens SpeedStream 4200 e funcionou sem problemas depois de muita luda com as confs originais!
    Acabou!!!!
    Obrigado Alexandre pela força!
    Um abraço