+ Responder ao Tópico



  1. #1

    Padrão porta 443 no balanceamento

    Olá pessoal, tenho um problema, pesquizei no forum e achei essas regras para direcionar a porta dos bancos 433 fixa por um link:

    ip route --> add gateway=192.168.200.254 routing-mark=adsl2

    ip firewall --> mangle --> add chain=prerouting protocol=tcp src-port=443 action=mark-routing new-routing-mark=adsl2

    segue a imagem das minahs configurações

    http://img69.imageshack.us/img69/9225/mk3rs2.th.jpg

    O problema é qdo coloco essas regras acaba ñ abrindo mais as páginas de bancos, alguém poderia me ajudar, grato!

  2. #2

    Padrão

    Citação Postado originalmente por faieppi Ver Post
    Olá pessoal, tenho um problema, pesquizei no forum e achei essas regras para direcionar a porta dos bancos 433 fixa por um link:

    ip route --> add gateway=192.168.200.254 routing-mark=adsl2

    ip firewall --> mangle --> add chain=prerouting protocol=tcp src-port=443 action=mark-routing new-routing-mark=adsl2

    segue a imagem das minahs configurações

    http://img69.imageshack.us/img69/9225/mk3rs2.th.jpg

    O problema é qdo coloco essas regras acaba ñ abrindo mais as páginas de bancos, alguém poderia me ajudar, grato!
    Olá pessoal, dei uma olhada na regra melhor e resolvi usar em vez de:

    src-port=443

    usei:

    dst-port=443

    reiniciei o mk e acabou funcionando a regra, hehe, vou fazer mais uns teste e confirmo se realmente sanou o problema...



  3. #3

    Padrão

    É pessoal, preciso de ajuda, ñ está 100%, tem horas q as páginas do banco abrem e faz td normalmente, mas tem hora q barra e o site diz q houve mudança de IP e encerra a cessão, alguém tem uma luz aí para fazer a navegação dos sites dos bancos navegarem por um link e ñ entrarem no balanceamento? Valeuuuu

  4. #4

    Padrão load

    o teu balanceamento esta funcionado ok me mande o tuto dele pois o meu so navega por um link so outro nao vai fica sempre parado


    Citação Postado originalmente por faieppi Ver Post
    Olá pessoal, tenho um problema, pesquizei no forum e achei essas regras para direcionar a porta dos bancos 433 fixa por um link:

    ip route --> add gateway=192.168.200.254 routing-mark=adsl2

    ip firewall --> mangle --> add chain=prerouting protocol=tcp src-port=443 action=mark-routing new-routing-mark=adsl2

    segue a imagem das minahs configurações

    http://img69.imageshack.us/img69/9225/mk3rs2.th.jpg

    O problema é qdo coloco essas regras acaba ñ abrindo mais as páginas de bancos, alguém poderia me ajudar, grato!



  5. #5

    Padrão

    Citação Postado originalmente por faieppi Ver Post
    Olá pessoal, tenho um problema, pesquizei no forum e achei essas regras para direcionar a porta dos bancos 433 fixa por um link:

    ip route --> add gateway=192.168.200.254 routing-mark=adsl2

    ip firewall --> mangle --> add chain=prerouting protocol=tcp src-port=443 action=mark-routing new-routing-mark=adsl2

    segue a imagem das minahs configurações

    http://img69.imageshack.us/img69/9225/mk3rs2.th.jpg

    O problema é qdo coloco essas regras acaba ñ abrindo mais as páginas de bancos, alguém poderia me ajudar, grato!


    Amigo, eu ja vi o script desse loadbalance no wiki do mk.....+ nao saquei como ele faz pra dividir os usuarios..

    Como ele faz pra jogar o usuario pra um link ou para outro? como eu faço pra saber se um usuario pegou um link ou outro?

    se puder dar uma força eu agradeço!...flw!

  6. #6

    Padrão

    Citação Postado originalmente por iceblue Ver Post
    Amigo, eu ja vi o script desse loadbalance no wiki do mk.....+ nao saquei como ele faz pra dividir os usuarios..

    Como ele faz pra jogar o usuario pra um link ou para outro? como eu faço pra saber se um usuario pegou um link ou outro?

    se puder dar uma força eu agradeço!...flw!
    Olá amigo, tenho duas formas, balanceamento por pacote, tipo qdo um coneta ele navega pelos dois links e assim sucessivamente para os outros usuários e tenho outra forma q é fixar o cliente somente por um link, tipo, coloco o cliente 1,3,5,7,9 no link 1 e os clientes 2,4,6,8,10 no link 2, é esse q vc tá falando?



  7. #7

    Padrão

    Citação Postado originalmente por faieppi Ver Post
    Olá amigo, tenho duas formas, balanceamento por pacote, tipo qdo um coneta ele navega pelos dois links e assim sucessivamente para os outros usuários e tenho outra forma q é fixar o cliente somente por um link, tipo, coloco o cliente 1,3,5,7,9 no link 1 e os clientes 2,4,6,8,10 no link 2, é esse q vc tá falando?
    Esse aqui: Load Balancing Persistent - MikroTik Wiki

    Como ele divide os usuarios?

  8. #8

    Padrão

    Colega Faieppi,
    Enquanto vc não partir prum load balance com rotas estáticas, terá esses problemas sempre. Diga preciosa pra vc que é um kra dedicado:
    Deixe um link como default e acrescente para o segundo link essa regra
    ip firewall --> mangle --> add chain=prerouting protocol=tcp src-port=443 action=mark-routing new-routing-mark=adsl2
    Distance 1
    Depois poste resultados aqui ...........
    Lembra de mim né ?
    Abraços



  9. #9

    Padrão

    Sugestao:

    Deixe um link como padrao, e redirecione serviços prioritários para o segundo link, como a porta 80, 443, 25, 110 e etc.

  10. #10

    Padrão

    Citação Postado originalmente por rps67 Ver Post
    Colega Faieppi,
    Enquanto vc não partir prum load balance com rotas estáticas, terá esses problemas sempre. Diga preciosa pra vc que é um kra dedicado:
    Deixe um link como default e acrescente para o segundo link essa regra
    ip firewall --> mangle --> add chain=prerouting protocol=tcp src-port=443 action=mark-routing new-routing-mark=adsl2
    Distance 1
    Depois poste resultados aqui ...........
    Lembra de mim né ?
    Abraços
    Olá kara, blz? Já consegui fazer esse por rotas, um link default e o outro somente as portas q quero, deixei tipo porta 80, 443 e tal, mas tô tendo problemas do tipo, qdo tem trafego no link default o link q tem a porta da navegação dá pausas, tipo clico para abrir a página e depois de uns 10 segundos q abre, pesquizei muito aqui e consegui fazer várias formas o mk, tô aos pouco conseguindo fazer algo, mas tem esse problema ainda.......



  11. #11

    Padrão

    Citação Postado originalmente por antoni Ver Post
    Sugestao:

    Deixe um link como padrao, e redirecione serviços prioritários para o segundo link, como a porta 80, 443, 25, 110 e etc.
    Olá amigo, eu fiz isso, veja a imagem e os scripts abaixo

    http://img292.imageshack.us/img292/8256/mk4ve4.th.jpg

    / ip route
    add dst-address=0.0.0.0/0 gateway=192.168.100.254 scope=255 target-scope=10 \ comment="" disabled=no
    add dst-address=0.0.0.0/0 gateway=192.168.200.254 scope=255 target-scope=10 \
    routing-mark=link2 comment="Pacotes marcados redirecionados para o link2" \
    disabled=no


    / ip firewall mangle
    add chain=prerouting protocol=tcp dst-port=80 action=mark-routing new-routing-mark=link2 passthrough=yes \
    comment="Portas 80 e 443 direcionada para o link2" disabled=no
    add chain=prerouting protocol=tcp dst-port=443 action=mark-routing new-routing-mark=link2 passthrough=yes \
    comment="" disabled=no
    add chain=prerouting routing-mark=link2 action=mark-packet new-packet-mark=link2 passthrough=yes \
    comment="Pacotes marcados das portas 80 e 443 e outras com o link2" disabled=no
    add chain=prerouting protocol=tcp dst-port=21 action=mark-routing new-routing-mark=link2 passthrough=yes \
    comment="Outras portas redirecionada para o link2" disabled=no
    add chain=prerouting protocol=tcp dst-port=22 action=mark-routing new-routing-mark=link2 passthrough=yes \
    comment="" disabled=no
    add chain=prerouting protocol=tcp dst-port=23 action=mark-routing new-routing-mark=link2 passthrough=yes \
    comment="" disabled=no
    add chain=prerouting protocol=tcp dst-port=25 action=mark-routing new-routing-mark=link2 passthrough=yes \
    comment="" disabled=no
    add chain=prerouting protocol=tcp dst-port=53 action=mark-routing new-routing-mark=link2 passthrough=yes \
    comment="" disabled=no
    add chain=prerouting protocol=tcp dst-port=110 action=mark-routing new-routing-mark=link2 passthrough=yes \
    comment="" disabled=no


    Eu deixei o link 1 como padrão e o link2 eu direcionei as portas 80, 443 e etc, acontece q qdo o link1 ou seja, o padrão ñ tem trafego o link2 funciona normal, navega, abre sites de banco, td blz, mas qdo ligo o e-mule por ex q começa a baixar arquivos pelo link1 padrão o link2 q está a porta 80 e 443 começa a parar, dá pausas enormes, tipo, vc clica e depois de 10 segundo q abre e as vezes nem abre, dá erro de página, o q está acontecendo? será q falta algo? Valeuuu

  12. #12

    Padrão

    Citação Postado originalmente por aprinou Ver Post
    o teu balanceamento esta funcionado ok me mande o tuto dele pois o meu so navega por um link so outro nao vai fica sempre parado
    o meu funciona sim, normalmente, somente estou com problemas nos sites dos bancos....



  13. #13

    Padrão

    Citação Postado originalmente por faieppi Ver Post
    Olá amigo, eu fiz isso, veja a imagem e os scripts abaixo

    http://img292.imageshack.us/img292/8256/mk4ve4.th.jpg

    / ip route
    add dst-address=0.0.0.0/0 gateway=192.168.100.254 scope=255 target-scope=10 \ comment="" disabled=no
    add dst-address=0.0.0.0/0 gateway=192.168.200.254 scope=255 target-scope=10 \
    routing-mark=link2 comment="Pacotes marcados redirecionados para o link2" \
    disabled=no


    / ip firewall mangle
    add chain=prerouting protocol=tcp dst-port=80 action=mark-routing new-routing-mark=link2 passthrough=yes \
    comment="Portas 80 e 443 direcionada para o link2" disabled=no
    add chain=prerouting protocol=tcp dst-port=443 action=mark-routing new-routing-mark=link2 passthrough=yes \
    comment="" disabled=no
    add chain=prerouting routing-mark=link2 action=mark-packet new-packet-mark=link2 passthrough=yes \
    comment="Pacotes marcados das portas 80 e 443 e outras com o link2" disabled=no
    add chain=prerouting protocol=tcp dst-port=21 action=mark-routing new-routing-mark=link2 passthrough=yes \
    comment="Outras portas redirecionada para o link2" disabled=no
    add chain=prerouting protocol=tcp dst-port=22 action=mark-routing new-routing-mark=link2 passthrough=yes \
    comment="" disabled=no
    add chain=prerouting protocol=tcp dst-port=23 action=mark-routing new-routing-mark=link2 passthrough=yes \
    comment="" disabled=no
    add chain=prerouting protocol=tcp dst-port=25 action=mark-routing new-routing-mark=link2 passthrough=yes \
    comment="" disabled=no
    add chain=prerouting protocol=tcp dst-port=53 action=mark-routing new-routing-mark=link2 passthrough=yes \
    comment="" disabled=no
    add chain=prerouting protocol=tcp dst-port=110 action=mark-routing new-routing-mark=link2 passthrough=yes \
    comment="" disabled=no


    Eu deixei o link 1 como padrão e o link2 eu direcionei as portas 80, 443 e etc, acontece q qdo o link1 ou seja, o padrão ñ tem trafego o link2 funciona normal, navega, abre sites de banco, td blz, mas qdo ligo o e-mule por ex q começa a baixar arquivos pelo link1 padrão o link2 q está a porta 80 e 443 começa a parar, dá pausas enormes, tipo, vc clica e depois de 10 segundo q abre e as vezes nem abre, dá erro de página, o q está acontecendo? será q falta algo? Valeuuu
    Coloca esta regra por último na tabela mangle do mk:

    add chain=prerouting routing-mark=link2 action=mark-packet new-packet-mark=link2 passthrough=yes \
    comment="Pacotes marcados das portas 80 e 443 e outras com o link2" disabled=no

    Ela já está lá, só coloque ela após todas as regras "routing-mark".
    Tenha ela apenas uma vez, mas depois de todas as outras que marcam as conexoes.

  14. #14

    Padrão

    Citação Postado originalmente por antoni Ver Post
    Coloca esta regra por último na tabela mangle do mk:

    add chain=prerouting routing-mark=link2 action=mark-packet new-packet-mark=link2 passthrough=yes \
    comment="Pacotes marcados das portas 80 e 443 e outras com o link2" disabled=no

    Ela já está lá, só coloque ela após todas as regras "routing-mark".
    Tenha ela apenas uma vez, mas depois de todas as outras que marcam as conexoes.
    Olá, blz amigo, mais tarde vou testar pra ver se funfa, mais uma coisa, testei outro balanceamento, aquele q ele divide os pacotes solicitados entre os dois link de cada usuário, com essas regras abaixo:

    / ip address

    add address=192.168.0.1/24 network=192.168.0.0 broadcast=192.168.0.255 interface=ether1 comment="" \
    disabled=no

    add address=10.111.0.2/24 network=10.111.0.0 broadcast=10.111.0.255 interface=ether2 \
    comment="" disabled=no

    add address=10.112.0.2/24 network=10.112.0.0 broadcast=10.112.0.255 interface=ether3 \
    comment="" disabled=no


    / ip firewall mangle

    add chain=prerouting in-interface=ether1 connection-state=new nth=1,1,0 \
    action=mark-connection new-connection-mark=odd passthrough=yes comment="" \
    disabled=no

    add chain=prerouting in-interface=ether1 connection-mark=odd action=mark-routing \
    new-routing-mark=odd passthrough=no comment="" disabled=no

    add chain=prerouting in-interface=ether1 connection-state=new nth=1,1,1 \
    action=mark-connection new-connection-mark=even passthrough=yes comment="" \
    disabled=no

    add chain=prerouting in-interface=ether1 connection-mark=even action=mark-routing \
    new-routing-mark=even passthrough=no comment="" disabled=no



    / ip firewall nat

    add chain=srcnat connection-mark=odd action=src-nat to-addresses=10.111.0.2 \
    to-ports=0-65535 comment="" disabled=no

    add chain=srcnat connection-mark=even action=src-nat to-addresses=10.112.0.2 \
    to-ports=0-65535 comment="" disabled=no



    / ip route

    add dst-address=0.0.0.0/0 gateway=10.111.0.1 scope=255 target-scope=10 routing-mark=odd \
    comment="" disabled=no

    add dst-address=0.0.0.0/0 gateway=10.112.0.1 scope=255 target-scope=10 routing-mark=even \
    comment="" disabled=no

    add dst-address=0.0.0.0/0 gateway=10.112.0.1 scope=255 target-scope=10 comment="" \
    disabled=no



    só q tô tendo problemas nos sites dos bancos, mudei os IP acima q foi q achei aqui no mk para adaptar na minha rede e funciona blz, veja as regras na imagem abaixo, mas depois q coloco essas regras abaixo para direcionar a porta 443 para somente um link acaba ñ abrindo mais os sites de bancos, o q será q falta? Tem algo errado amigo, valeu.

    ip route --> add gateway=192.168.200.254 routing-mark=adsl2

    ip firewall --> mangle --> add chain=prerouting protocol=tcp src-port=443 action=mark-routing new-routing-mark=adsl2

    http://img69.imageshack.us/img69/9225/mk3rs2.th.jpg
    Última edição por faieppi; 19-08-2007 às 15:18.