+ Responder ao Tópico



  1. #1

    Angry Problemas com rc.local

    Galera, boa tarde
    Eu estou com um problema com o meu rc.local.

    Nada do que eu coloco para startar nele roda
    Eu já tentei modificar o arquivo de diretório, colocar outras formas de rodar dentro dele (chamando direto o diretório, sem executar o arquivo rc.xxx), mas até agora não consegui nada.

    Alguém tem alguma sugestão sobre o que eu posso fazer???

    Preciso inicializar anti-spam, tomcat, e mais umas coisas...

    Fico no aguardo.

    Obrigado
    Última edição por infinnitum; 05-11-2007 às 21:49.

  2. #2

    Padrão

    O arquivo rc.local está com permissão de execução ?



  3. #3

    Padrão

    Prezado Márcio, obrigado pela resposta.

    O arquivo está sim, com formato para ser executado (chmod +x).
    Tentei já mudar para chmod 777, chmod 744, mas nada acontece.

    Não sei o que está realmente acontecendo :/

    O problema é que é um server web, e daí se reiniciar (se por um acaso acaba o tempo do no-break), daí tem que fazer na mão os comandos :/

    Isso que é fogo, eheheh..

    Vlw, abração.

  4. #4

    Padrão

    E nos logs, não tem nenhuma mensagem de erro ?

    Você, por um acaso, editou esse arquivo em algum editor Ruindous ?
    Pode ser que os caracteres 'fim-de-linha' estejam errados, já vi isso acontecer, por incrível que pareça heheheh

    Verifique com o comando: file rc.local

    Muito estranho.



  5. #5

    Padrão

    Verifique se no arquivo /etc/rc.d/rc.M ele está sendo chamado (fica no final do arquivo):

    # Start the local setup procedure.
    if [ -x /etc/rc.d/rc.local ]; then
    . /etc/rc.d/rc.local
    fi

    Boa sorte.

  6. #6

    Padrão

    Prezado Marcio.
    Eu acesso o servidor via SSH, e edito os arquivos diretamente com o PICO.
    Já verifiquei com o file rc.local, e está normal :/
    Não sei mais o que fazer...

    Agora para o Prezado Lipse.
    Eu já verifiquei dentro do rc.M, e está chamando certinho ;/
    Inclusive já tentei chamar de outro diretório, alterando o rc.M e até agora nada...

    Obrigado pelas respostas.

    Um abraço.



  7. #7

  8. #8

    Thumbs up

    É se fosse possível, seria legal mesmo se você pudesse postar o seu rc.local para o pessoal dar uma olhada.
    Ficamos no aguardo .....
    Um grande abraço ....



  9. #9

    Padrão

    Meu rc.local está assim:

    # Inicia Firewall
    #./rc.firewall start

    # Inicia Apache
    /usr/sbin/apachectl start

    /etc/rc.d/rc.spamd start

    /etc/rc.d/rc.tomcat start

    ##############################
    O rc.spamd está abaixo
    ##############################
    #!/bin/sh

    # Spamd init script for Slackware 9.0
    # August, 2th 2003
    # Martin Ostlund, nomicon
    # Modified slightly by Troy Belding for Qmailrocks - February 23, 2004

    PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/bin
    DAEMON=/usr/bin/spamd
    NAME=spamd
    SNAME=rc.spamd
    DESC="Filtro de e-mail SpamAssassin"
    PIDFILE="/var/run/$NAME.pid"
    PNAME="spamd"

    DOPTIONS="-x -u spamd -H /home/spamd -d --pidfile=$PIDFILE"

    KILL="/bin/kill"
    KILLALL="/bin/killall"
    # Defaults - don't touch, edit /etc/mail/spamassassin/local.cf
    ENABLED=0
    OPTIONS=""

    set -e

    case "$1" in
    start)
    echo -n "Starting $DESC: "
    $PNAME $OPTIONS $DOPTIONS

    echo "$NAME."
    ;;
    stop)
    echo -n "Stopping $DESC: "
    $KILL -9 `cat $PIDFILE`
    /bin/rm $PIDFILE
    echo "$NAME."
    ;;
    restart|force-reload)
    echo -n "Restarting $DESC: "
    $0 stop
    $0 start

    echo "$NAME."
    ;;
    *)
    ME=/etc/rc.d/$SNAME
    echo "Usage: $ME {start|stop|restart|force-reload}" >&2
    exit 1
    ;;
    esac

    exit 0


    ###############################
    O rc.tomcat abaixo
    ###############################
    #!/bin/sh
    # Tomcat Startup Script

    CATALINA_HOME=/usr/local/tomcat; export CATALINA_HOME
    JAVA_HOME=/usr/lib/java; export JAVA_HOME
    TOMCAT_OWNER=tomcat; export TOMCAT_OWNER

    start() {
    echo -n "Starting Tomcat: "
    su $TOMCAT_OWNER -c $CATALINA_HOME/bin/startup.sh
    sleep 2
    }
    stop() {
    echo -n "Stopping Tomcat: "
    su $TOMCAT_OWNER -c $CATALINA_HOME/bin/shutdown.sh
    }

    # See how we were called.
    case "$1" in
    start)
    start
    ;;
    stop)
    stop
    ;;
    restart)
    stop
    start
    ;;
    *)
    echo $"Usage: tomcat {start|stop|restart}"
    exit
    esac


    #################################

    O estranho é que quando eu executo ele pela linha de comando ele roda certinho, então não é problema no rc.local (eu acho), ehehehe..

    Valeu galera.

    Um abraço.

  10. #10

    Padrão

    sinceramente, eu não manjo de sheel script,
    porém, eu tentaria fazer um arquivo com o
    "#!/bin/bash" para baixo
    e chamar esse script a partir do rc.local

    mas pode ser besteira isso, é um chute



  11. #11

    Padrão

    Prezado Lacovisk

    O único conteúdo do meu rc.local é o seguinte:

    # Inicia Firewall
    #./rc.firewall start

    # Inicia Apache
    /usr/sbin/apachectl start

    /etc/rc.d/rc.spamd start

    /etc/rc.d/rc.tomcat start


    O restante eu coloquei só pra vocês verem o que ele está chamando

    Um abraço.

  12. #12

    Padrão

    Na última linha do rc.spamd tem:

    exit 0

    remova essa linha...
    A única dica que tenho...



  13. #13

    Padrão

    Galeraaaaaaaaaaaa.. Descobri o problema.

    Seguinte, quando o linux starta no rc.M (MultiUser né ), ele tem a sequência de início (rc.mysql, rc.httpd), e tal...
    Pois bem, depois de muiiiiiiiito tentar e tentar, eu descobri o seguinte:

    Quando o MySql starta, ele trava o rc.local, não deixando nada que está dentro dele rodar... Não entendi direito o porquê, mas é assim que está acontecendo, eheheh..

    O que eu fiz foi o seguinte: (minha solução mágica)
    Comentei as linhas do MySql dentro do rc.M, e daí coloquei o MySql para rodar como último comando dentro do rc.local.


    Depois que eu fiz isso, tuuuuuuuuuuuuuuudo que está dentro do rc.local funciona como uma maravilha..

    Espero que isso sirva de contribuição para alguém, pois esse probleminha é chato demais

    Um abraço à todos que ajudaram aí, ok?

    Valeu mesmo

  14. #14

    Padrão

    quem bom que você resolveu....
    talvez fosse a falta de um "&" no final de um comando



  15. #15

    Padrão

    Beleza Lacovisk

    Eu vou dar uma olhada mais a fundo no script de inicialização do MySql, pois é ele que está travando tudo, eheheh..

    Valeu aí

    Um abraço.