Página 1 de 19 123456 ... ÚltimoÚltimo
+ Responder ao Tópico



  1. #1

    Padrão Resolvendo o problema do CACHE-FULL - CATVBRASIL

    Então galera. Aproveitando a dica do amigo Tiago Matias, analizei a regra e criei a solução para resolver o uso do CACHE-FULL sem estourar todo o link. Para isso incluimos mais uma regra de return, a qual irá pegar os pacotes, após analiza-los com as regras tradicionais e voltar para dentro do router. Consequentemente será encaminhado normalmente para fora da internet sem usar a banda toda. Não precisamos mais esperar até a versão 3.0, pois está testado e aprovado em alguns clientes meus que implantei. Segue as regras:

    /ip firewall mangle
    add chain=output protocol=tcp src-port=8080 action=mark-connection \
    new-connection-mark=proxyfull passthrough=yes comment="PROXY FULL" \
    disabled=no
    add chain=output connection-mark=proxyfull action=mark-packet \
    new-packet-mark=proxyfull passthrough=yes comment="" disabled=no
    add chain=output connection-mark=proxyfull action=return comment="" \
    disabled=no

    Note que há uma mudança na regra de marcação de pacotes (segunda regra), na qual o passtrought fica neste caso ligado, enviando os pacotes para a próxima regra de RETURN. A regra de RETURN, terá que ficar na última linha do conjunto, pois ela pegará os pacotes analizados e marcados pelas regras anteriores e retornará a sua origem aqueles que não são do proxy full (consequentemente só colocando na queue simple do proxyfull aqueles pacotes a qual são realmente vindos do cache). Tae a dica e façam bom proveito, pois tive que me lascar durante uma semana aqui estudando manuais, firewall e regras para desenvolver esta regra. rssss

    CATVBRASIL
    Miniaturas de Anexos Miniaturas de Anexos Clique na imagem para uma versão maior

Nome:	         proxyfull.jpg
Visualizações:	4048
Tamanho: 	136,4 KB
ID:      	1280  
    Última edição por catvbrasil; 02-11-2007 às 15:49.

  2. #2

    Padrão

    Citação Postado originalmente por catvbrasil Ver Post
    Então galera. Aproveitando a dica do amigo Tiago Matias, analizei a regra e criei a solução para resolver o uso do CACHE-FULL sem estourar todo o link. Para isso incluimos mais uma regra de return, a qual irá pegar os pacotes, após analiza-los com as regras tradicionais e voltar para dentro do router. Consequentemente será encaminhado normalmente para fora da internet sem usar a banda toda. Não precisamos mais esperar até a versão 3.0, pois está testado e aprovado em alguns clientes meus que implantei. Segue as regras:

    /ip firewall mangle
    add chain=output protocol=tcp src-port=8080 action=mark-connection \
    new-connection-mark=proxyfull passthrough=yes comment="PROXY FULL" \
    disabled=no
    add chain=output connection-mark=proxyfull action=mark-packet \
    new-packet-mark=proxyfull passthrough=yes comment="" disabled=no
    add chain=output connection-mark=proxyfull action=return comment="" \
    disabled=no

    Note que há uma mudança na regra de marcação de pacotes (segunda regra), na qual o passtrought fica neste caso ligado, enviando os pacotes para a próxima regra de RETURN. A regra de RETURN, terá que ficar na última linha do conjunto, pois ela pegará os pacotes analizados e marcados pelas regras anteriores e retornará a sua origem aqueles que não são do proxy full (consequentemente só colocando na queue simple do proxyfull aqueles pacotes a qual são realmente vindos do cache). Tae a dica e façam bom proveito, pois tive que me lascar durante uma semana aqui estudando manuais, firewall e regras para desenvolver esta regra. rssss

    CATVBRASIL


    ola catv,

    nesse caso,, os clientes vao passar direto no controle de banda, em relaçao a arquivos em cache neh isso,,,

    mais,, será que esse procedimento nao vai comer a largura de banda dos aps?
    ex.. um cliente pegando o msn vindo do cache,,, nao vai cogestionar a rede???



  3. #3

    Padrão

    Citação Postado originalmente por alanvictorjp Ver Post
    ola catv,

    nesse caso,, os clientes vao passar direto no controle de banda, em relaçao a arquivos em cache neh isso,,,

    mais,, será que esse procedimento nao vai comer a largura de banda dos aps?
    ex.. um cliente pegando o msn vindo do cache,,, nao vai cogestionar a rede???
    Em testes práticos não, tendo em vista que a maioria das páginas são menos de 100k e também sabemos que é muito melhor o cara pegar um MSN de 10mb em 5 segundos, do que passar 5 minutos baixando a 30k. Pode ficar tranquilo que só fica cache full para o que está no cache. O que está na NET ele vai com a banda normal.

  4. #4

    Padrão Cache...

    Como fica a arquitetura nessa caso?

    Internet-Router--Cache--MK--

    ou posso deixar uma maquina com cache em paralelo com o MK?



  5. #5

    Padrão

    Citação Postado originalmente por terencerocha Ver Post
    Como fica a arquitetura nessa caso?

    Internet-Router--Cache--MK--

    ou posso deixar uma maquina com cache em paralelo com o MK?
    Este exemplo é para ser empregado com uso do web-proxy interno do MK, para usar SQUID externo, não fiz os testes se funciona.

  6. #6

    Padrão

    fiz aqui e parece q funfou perfeito! parabens mais uma vez catv!



  7. #7

    Padrão

    copiei as regras aqui
    coloquei no topo da lista do mangle
    mas nao marca nada de pacote

  8. #8

    Padrão

    Citação Postado originalmente por raa_ Ver Post
    copiei as regras aqui
    coloquei no topo da lista do mangle
    mas nao marca nada de pacote
    Amigo, analize a regra. A porta do meu web-proxy é a 8080. Qual é a sua??? Mude a porta que garanto que irá funcionar...



  9. #9

    Padrão

    Citação Postado originalmente por catvbrasil Ver Post
    Amigo, analize a regra. A porta do meu web-proxy é a 8080. Qual é a sua??? Mude a porta que garanto que irá funcionar...
    certo catv
    eu coloquei 3126 e me confundi a minha era 3128
    obg

    e desculpa

  10. #10

    Padrão

    Aqui ate marca os pacotes, mais o contador do quees não marca nada e não desce full.



  11. #11

    Padrão

    Citação Postado originalmente por valeonline Ver Post
    Aqui ate marca os pacotes, mais o contador do quees não marca nada e não desce full.
    Meu amigo, mais uma vez... Você analizou a regra? Notou que o nome que dei para a marcação dos pacotes é "proxyfull"? Você mudou a marcação de pacote na queue para "proxyfull"? Acho que não... Usou somente o copiar colar né?? rssssssss

  12. #12

    Padrão

    Mais uma vez parabêns pela iniciativa. Continue com essa dedicação e espírito de colaboração pois saiba q tem muitos amigos aki q se inspiram em vc.
    Valeu.



  13. #13

    Padrão Estranho não deu certo

    coloquei as seguintes regras e não funcionou???!!!

    no ip firewal mangle

    add chain=output protocol=tcp src-port=8080 action=mark-connection \
    new-connection-mark=proxy_conn passthrough=yes comment="Conexao ProxyFull" \
    disabled=no
    add chain=output connection-mark=proxy_conn action=mark-packet new-packet-mark=proxy \
    passthrough=yes comment="" disabled=no
    add chain=output connection-mark=proxy_conn action=return comment="" disabled=no

    No queue simplre
    add name="ProxyFull" dst-address=0.0.0.0/0 interface=all parent=none packet-marks=proxy \
    priority=8 queue=default/default limit-at=1000000/1000000 max-limit=1000000/1000000 \
    total-queue=default disabled=no

    Estranho acho q conferi e esta tudo certo e aqui não deu certo a minha versão e a 2.9.6

  14. #14

    Padrão opa

    ola catv vi sua regra e realmente funciona agora para que eu possa aqui no meu servidor isolar os pacotes de entrada tive que aplicar como segue a regra com uma unica diferença !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!


    0 chain=output protocol=tcp src-port=3126 action=mark-connection
    new-connection-mark=proxy full passthrough=yes

    1 chain=output connection-mark=proxy full action=mark-packet
    new-packet-mark=cache full passthrough=yes

    2 chain=output connection-mark=!proxy full action=return



  15. #15

    Padrão

    Boa noite a todos, é um prazer pra mim estar participando deste forum e principalmente deste tópico, comecei neste ramo de provedor agora...e to usando mikrotik, mas pouco conheço sobre ele, lendo o tópico decidi destar, ja que tanta gente fala sobre isso...proxyfull....
    eu fiz como os amigos mostraram ai...mas quando deixo enabled as regras, elas liberam total para o usuario...tudos navegam com a minha banda toda....oque será eu devo estar fazendo de errado???
    ps: quando eu deixo a regra do simple queues que libera a banda toda....
    Anderson
    Última edição por andersonscinfo; 03-11-2007 às 01:50.

  16. #16

    Padrão

    Citação Postado originalmente por catvbrasil Ver Post
    Meu amigo, mais uma vez... Você analizou a regra? Notou que o nome que dei para a marcação dos pacotes é "proxyfull"? Você mudou a marcação de pacote na queue para "proxyfull"? Acho que não... Usou somente o copiar colar né?? rssssssss
    Aqui eu mudei mas nao marca nada na queue! O que pode ser?



  17. #17

    Padrão

    Realmente muito bom, mas e ae CATV, pra quando podemos esperar a literatura completa sobre Mikrotik ? Terá uma versão PDF gratuita ? ou somente via editora ?

    Grato

    M4D3

  18. #18

    Padrão

    Citação Postado originalmente por netleandromt Ver Post
    Aqui eu mudei mas nao marca nada na queue! O que pode ser?
    amigo, joga sua regra de queue acima de todas, em advanced packet mark, escolha a marcaçao de pacote feita,,

    em mangle, certifique-se q a porta q vc usa no webproxy, estejah correta!
    vlw



  19. #19

    Padrão Resolvendo problema cache full

    Parabens grande colaborador do forum, acredito q torna-se até redundante tantos agradecimentos, mas não deixaria essa passar em branco. adicionei aqui essas novas regras e funcionou perfeitamente! mais uma vez, o meu muito obrigado!!!!

  20. #20

    Padrão

    Muito boa sua regra Catv, so uma coisa essa regra tem de ficar em cima de todas as outras no queue, pois toda vez q um cliente loga a regra desce, como fazer pra ela ficar em cima de todas?