Página 3 de 19 PrimeiroPrimeiro 12345678 ... ÚltimoÚltimo
+ Responder ao Tópico



  1. #41

    Padrão

    aqui tambem, marca pacote mas no queue nao da nada.
    eu tambem selecionei a opcao de packet mark messmo assim nao vai...

  2. #42

    Padrão

    Citação Postado originalmente por alexsuarezferreira Ver Post
    aqui tambem, marca pacote mas no queue nao da nada.
    eu tambem selecionei a opcao de packet mark messmo assim nao vai...
    PS: Coloca a regra no início do firewall... Caso não consiga, envie suas regras...



  3. #43

    Padrão

    catv vao ai minhas regras de firewall
    Flags: X - disabled, I - invalid, D - dynamic
    0 ;;; Mascarade Rede
    chain=srcnat out-interface=pppoe-out1 action=masquerade

    1 ;;; Conectividade Social - Caixa Economica Federal
    chain=dstnat dst-address=200.201.174.0/24 action=accept

    2 ;;; Radio UOL
    chain=dstnat dst-address=200.154.0.0/16 action=accept

    3 ;;; Radio Terra
    chain=dstnat dst-address=200.221.0.0/16 action=accept

    4 chain=dstnat in-interface=Rede protocol=tcp dst-port=80 action=redirect
    to-ports=3129
    aqui faz marcaçâo de pacotes, mas no queues nao vai, verifiquei varias veces la e nada, obriado se puder me dar uma lus hehehe--

  4. #44

    Padrão

    Citação Postado originalmente por alexsuarezferreira Ver Post
    catv vao ai minhas regras de firewall
    Flags: X - disabled, I - invalid, D - dynamic
    0 ;;; Mascarade Rede
    chain=srcnat out-interface=pppoe-out1 action=masquerade

    1 ;;; Conectividade Social - Caixa Economica Federal
    chain=dstnat dst-address=200.201.174.0/24 action=accept

    2 ;;; Radio UOL
    chain=dstnat dst-address=200.154.0.0/16 action=accept

    3 ;;; Radio Terra
    chain=dstnat dst-address=200.221.0.0/16 action=accept

    4 chain=dstnat in-interface=Rede protocol=tcp dst-port=80 action=redirect
    to-ports=3129
    aqui faz marcaçâo de pacotes, mas no queues nao vai, verifiquei varias veces la e nada, obriado se puder me dar uma lus hehehe--
    Amigo a marcação de pacotes é na aba MANGLE. As regras devem ser inclusas lá.



  5. #45

    Talking resolvido !

    Citação Postado originalmente por catvbrasil Ver Post
    Amigo a marcação de pacotes é na aba MANGLE. As regras devem ser inclusas lá.
    opa me enganei , mas tambem ja achei o problema seguinte, o queue do cache full deve estar em primeiro, pois senao nao funciona aqui ja esta funcionando, lembrei que pasei por isso com o teste que fis do cache do tiago matias.
    era somente isso, obrigado..
    ja estou testando o cahche full.
    Última edição por alexsuarezferreira; 03-11-2007 às 21:53.

  6. #46

    Padrão

    vlw irmão catv brigadão pela ajuda...........testando cache full funcionando.........até segunda posto os resultados,,,,,,,,



  7. #47

    Padrão

    gente, sei la oque eu to fazendo de errado, só sei que quando eu abilito estas regras libera total....fica todos com velocidade total....

  8. #48

    Padrão

    Citação Postado originalmente por andersonscinfo Ver Post
    gente, sei la oque eu to fazendo de errado, só sei que quando eu abilito estas regras libera total....fica todos com velocidade total....
    Posta suas configurações....



  9. #49

    Padrão

    vou postar o backup do mk....porque não concigo escrever todas as regras que estão no mk, foi um backup de um amigo que me passou...sou leigo em mk.....

    opa....
    usuario anderson
    senha brasillax158t
    Arquivos Anexos Arquivos Anexos
    Última edição por andersonscinfo; 04-11-2007 às 01:05.

  10. #50

    Padrão

    desculpa sair um pouco do tópico inicial, mas é necessário pra mim resolver isso antes de implementar essa regra.

    Eu acredito que apenas eu mesmo esteja usando o webcache do mkt, e que todos meus clientes não estejam usufruindo. Quero saber como checar isso. No log, apenas meu ip aparece relacionado a webproxy.

    E esta foto, indicando apenas 1 cliente. Não sei se esse cliente quer dizer apenas uma interface, ou apenas um cliente mesmo conectado, no caso eu mesmo.

    Grato pela atenção, e grato pela dica David.
    Miniaturas de Anexos Miniaturas de Anexos Clique na imagem para uma versão maior

Nome:	         webproxy.JPG
Visualizações:	340
Tamanho: 	125,3 KB
ID:      	1283  



  11. #51
    Moderador Avatar de Magal
    Ingresso
    Mar 2007
    Localização
    Rio de Janeiro
    Posts
    2.043
    Posts de Blog
    118

    Padrão Cache-full

    Valeu mais uma vez CATV, aqui deu tudo certo.

  12. #52

    Padrão

    Citação Postado originalmente por Gosulator Ver Post
    desculpa sair um pouco do tópico inicial, mas é necessário pra mim resolver isso antes de implementar essa regra.

    Eu acredito que apenas eu mesmo esteja usando o webcache do mkt, e que todos meus clientes não estejam usufruindo. Quero saber como checar isso. No log, apenas meu ip aparece relacionado a webproxy.

    E esta foto, indicando apenas 1 cliente. Não sei se esse cliente quer dizer apenas uma interface, ou apenas um cliente mesmo conectado, no caso eu mesmo.

    Grato pela atenção, e grato pela dica David.
    Amigo, acho que tem algo errado com suas regras. Poste-as para a gente analizar... Valeu!!



  13. #53

    Padrão

    enabled: yes
    src-address: 0.0.0.0
    port: 3128
    hostname: "proxy"
    transparent-proxy: yes
    parent-proxy: 0.0.0.0:0
    cache-administrator: "webmaster"
    max-object-size: 60000KiB
    cache-drive: system
    max-cache-size: unlimited
    max-ram-cache-size: unlimited
    status: running
    reserved-for-cache: 3514368KiB
    reserved-for-ram-cache: 326656KiB

    Postei apenas as configs do proxy, mas acho que apenas isso não resolve, de outro modo acho que eu teria visto o erro logo de cara. O que mais de informação você precisa?

    Valeu a força, abraço

  14. #54

    Padrão

    Citação Postado originalmente por Gosulator Ver Post
    enabled: yes
    src-address: 0.0.0.0
    port: 3128
    hostname: "proxy"
    transparent-proxy: yes
    parent-proxy: 0.0.0.0:0
    cache-administrator: "webmaster"
    max-object-size: 60000KiB
    cache-drive: system
    max-cache-size: unlimited
    max-ram-cache-size: unlimited
    status: running
    reserved-for-cache: 3514368KiB
    reserved-for-ram-cache: 326656KiB

    Postei apenas as configs do proxy, mas acho que apenas isso não resolve, de outro modo acho que eu teria visto o erro logo de cara. O que mais de informação você precisa?

    Valeu a força, abraço
    Não seriam estas regras (estão corretas!!), são as regras de redirecionamento do web-proxy do NAT.



  15. #55

    Padrão

    depois que deixei minha resposta, fui dar uma geral procurando por coisas relacionadas ao proxy, e achei as regras de redirect relativas ao proxy, em ip>firewall>nat. E realmente tinha algo muito tosco lá. Só tinha uma regra (tenho 2 interfaces p/ clientes), e ela tinha no "src. adress" o ip do meu pppoe (ip que o mkt dá pra o meu pc quando eu me conecto). Com ctz era isso. Outra pessoa deve ter configurado isso, me passou despercebido . Bem, desativei essa regra, e criei 2 parecidas, uma para cada interface:

    3 ;;; REDIRECIONAMENTO WEB-PROXY INTERFACE _ETHER_
    chain=dstnat in-interface=ETH1 protocol=tcp dst-port=80 action=redirect to-ports=3128


    4 ;;; REDIRECIONAMENTO WEB-PROXY INTERFACE _WLAN_
    chain=dstnat in-interface=WLAN1 protocol=tcp dst-port=80 action=redirect to-ports=3128

    como faço agora, para checar se está tudo funcionando?

    edit: parece que ainda não está funcionando. Fiz um dl, limpei o cache do meu desktop (não o cache do webcache) e fiz de novo, e ele puxou de novo da internet, e não do proxy (ví pela velocidade de transmissão das interfaces. O link com a net estava a todo o vapor durante o dl.

    Preciso dar um restart no mkt, ou desativar e reativar o proxy pra a coisa funcionar? Lembrando que quando tava setado pra funfar o cache apenas para o meu ip, estava funcionando para mim, apareciam os logs de requerimento de dados ao cache pelo meu ip. Agora não mais.

    Vou também testar em vez de apontar a interface, apontar o range de ips que meus clientes utilizam. Pois se quando estava apontado o meu it no src. adress, funcionava, provavelmente vá funcionar pros clientes se eu colocar o range. Só espero que o mkt aceite o range, e não apenas um ip, senão vou ter que criar uma regra pra cada usuário :S

    Grato pela atenção!
    Última edição por Gosulator; 04-11-2007 às 03:36.

  16. #56

    Padrão

    Citação Postado originalmente por Gosulator Ver Post
    depois que deixei minha resposta, fui dar uma geral procurando por coisas relacionadas ao proxy, e achei as regras de redirect relativas ao proxy, em ip>firewall>nat. E realmente tinha algo muito tosco lá. Só tinha uma regra (tenho 2 interfaces p/ clientes), e ela tinha no "src. adress" o ip do meu pppoe (ip que o mkt dá pra o meu pc quando eu me conecto). Com ctz era isso. Outra pessoa deve ter configurado isso, me passou despercebido . Bem, desativei essa regra, e criei 2 parecidas, uma para cada interface:

    3 ;;; REDIRECIONAMENTO WEB-PROXY INTERFACE _ETHER_
    chain=dstnat in-interface=ETH1 protocol=tcp dst-port=80 action=redirect to-ports=3128


    4 ;;; REDIRECIONAMENTO WEB-PROXY INTERFACE _WLAN_
    chain=dstnat in-interface=WLAN1 protocol=tcp dst-port=80 action=redirect to-ports=3128

    como faço agora, para checar se está tudo funcionando?
    Amigo, primeiro passo é você ajustar corretamente esta regra. Apaga uma e muda a in-interface para !seu link de saida. Desta forma você estará corrigindo o problema. Não esquece do "!".



  17. #57

    Padrão

    funcionou com a exclamação!!!!! Bendita exclamação!

    Valeu David!

    Essa exclamação significa o que exatamente? Todos os ips dentro daquela interface?

    Quanto ao que você disse
    Apaga uma e muda a in-interface para !seu link de saida. Desta forma você estará corrigindo o problema. Não esquece do "!".
    Você diz para eu apagar uma das duas regras? Mas eu tenho duas interfaces de saída para clientes, creio que eu tenho que ter as duas regras, uma para cada. Né não?

    Valeu pela ajuda, abraçao!

    edit: parece que faz sentido mesmo deixar apenas uma regra, mesmo tendo duas interfaces. A regra estava ativada apenas para a interface A, mas clientes conectados à interface B estavam usando o cache. Vou checar
    Última edição por Gosulator; 04-11-2007 às 03:48.

  18. #58

    Padrão

    Citação Postado originalmente por Gosulator Ver Post
    funcionou com a exclamação!!!!! Bendita exclamação!

    Valeu David!

    Essa exclamação significa o que exatamente? Todos os ips dentro daquela interface?

    Quanto ao que você disse


    Você diz para eu apagar uma das duas regras? Mas eu tenho duas interfaces de saída para clientes, creio que eu tenho que ter as duas regras, uma para cada. Né não?

    Valeu pela ajuda, abraçao!
    Quando você coloca o "!" junto da sua interface de saída, você fala:

    MIKROTIK, inclua todas as minhas interfaces, MENOS a interface de saída. Faça isso que dará certo.



  19. #59

  20. #60

    Padrão

    Notei algo interessante analisando o cache, e vou deixar as perguntas pra vocês;

    Tinha feito o dl de um arquivo de 15mb, quando a regra de cache estava funcionando apenas para o meu ip. Limpei o cache do meu pc e refiz o download, e o download foi feito direto do cache do mkt. quando desativei o cache exclusivo pro meu ip, e ativei o cache para todas as interfaces de saída, fui fazer o download de novo e surpresa, ele não estava baixando do cache. Esperei o download terminar, limpei todo o cache do meu pc, e mandei refazer o download. Baixou do cache.

    Quero saber porquê isso aconteceu. E principalmente, se o cache é exclusivo para quem puxou aqueles dados da internet. Exemplo: o cliente 192.168.0.1 navegou em página www.lerolero.com Coming Soon!, e o mkt adicionou toda aquela página no webproxy. Quando o cliente acessar o www.lerolero.com Coming Soon! de novo, ele vai puxar os dados do webcache, com excessão do que tiver mudado do último acesso para o acesso em questão. OK. Mas se o cliente 192.168.0.2 coincidentemente acessa essa mesma página, www.lerolero.com Coming Soon! , ele vai carregar a página do webcache ou da internet? Se ele carregar da internet vai diminuir um bocado a eficiência que poderia ter o webcache.

    Outra dúvida. No log do webcache, tem as expressões TCP_MISS e TCP_HIT. O que querem dizer? TCP_MISS = não achou a página no cache e TCP_HIT = achou? Tem alguma sigla para quando ele adiciona uma página para o webcache? Tipo TCP_ADD ?

    Quando o webcache fica cheio, o que acontece? Para de salvar novas páginas, deleta a página mais antiga salva para salvar a mais nova ou deleta algum dado randomico para salvar a informação nova?

    Como eu faço pra checar o quanto já foi BAIXADO do cache? Para ter uma idéia de quanto de banda do link eu economizei usando webcache. Um monitor de tráfego ao vivo também seria interessante, pra ver o volume de dados sendo baixados do webcache em determinado momento.

    abraços!