+ Responder ao Tópico



  1. galera com certeza mta gente sabe esse script
    o q mta gente naum sabe e porque hora ele funfa e hora naum
    e o seuguinte!!!
    vc tem q ir em ip - dns e clicar em settings
    ai vc coloca os dns no meu caso os da brasiltelecom
    fazendo isso vc pode criar o seu script
    va em system scripts e adicione dessa forma

    :global ddnsuser "gotch"
    :global ddnspass "elemento"
    :global ddnshost "cardiofit.ddns.info"

    :global ddnssystem ("mt-" . [/system package get [/system package find name=system] version] )

    :foreach int in=[/ip route find dst-address=0.0.0.0/0 active=yes ] do={
    :if ([:typeof [/ip route get $int routing-mark ]] = nothing ) do={
    :global ddnsinterface [/ip route get $int interface]
    }
    }

    :global ddnsip [ /ip address get [/ip address find interface=$ddnsinterface] address ]

    :if ([ :typeof $ddnslastip ] = nil ) do={ :global ddnslastip 0.0.0.0/0 }

    :if ([ :typeof $ddnsip ] = nil ) do={

    :log info ("DDNS: No ip address present on " . $ddnsinterface . ", please check.")

    } else={

    :if ($ddnsip != $ddnslastip) do={

    :log info "DDNS: Sending UPDATE!"
    :log info [ ut [/tool dns-update name=$ddnshost address=[ick $ddnsip 0 [:find $ddnsip "/"] ] key-name=$ddnsuser key=$ddnspass ] ]
    :global ddnslastip $ddnsip

    } else={

    }

    }


    preste atencao na linlha log info q tem a carinha de um boneco! a primeira e : put e no lugar da segunda é dois : pick so q juntinho com apenas um espaco do colchete@@@

    bom espero ajudar@@ pois sempre tive essa duvida... e nunca li a respeito@! agora ta ai o problema e q as vezes instalo com dns e as vezes naum
    Última edição por gotch; 02-12-2007 às 18:18.

  2. concerta a linha da forma q ela ficaria pois ficou redundante a resposta sem saber se eh
    :ick
    ::
    repete ai por favor



  3. Citação Postado originalmente por terencerocha Ver Post
    concerta a linha da forma q ela ficaria pois ficou redundante a resposta sem saber se eh
    :ick
    ::
    repete ai por favor


    :global ddnsuser "gotch"
    :global ddnspass "elemento"
    :global ddnshost "cardiofit.ddns.info"

    :global ddnssystem ("mt-" . [/system package get [/system package find name=system] version] )

    :foreach int in=[/ip route find dst-address=0.0.0.0/0 active=yes ] do={
    :if ([:typeof [/ip route get $int routing-mark ]] = nothing ) do={
    :global ddnsinterface [/ip route get $int interface]
    }
    }

    :global ddnsip [ /ip address get [/ip address find interface=$ddnsinterface] address ]

    :if ([ :typeof $ddnslastip ] = nil ) do={ :global ddnslastip 0.0.0.0/0 }

    :if ([ :typeof $ddnsip ] = nil ) do={

    :log info ("DDNS: No ip address present on " . $ddnsinterface . ", please check.")

    } else={

    :if ($ddnsip != $ddnslastip) do={

    :log info "DDNS: Sending UPDATE!"
    :log info [ ut [/tool dns-update name=$ddnshost address=[ick $ddnsip 0 [:find $ddnsip "/"] ] key-name=$ddnsuser key=$ddnspass ] ]
    :global ddnslastip $ddnsip

    } else={

    }

    }


    galera a primeira carinha e : put e a segunda é : pick o dois pontos e colado no pick e no put ! ambos tem um espaço depois do colchetes






Tópicos Similares

  1. Mikrotik não pinga no ip válido do meu Gateway
    Por wandosantosrc no fórum Servidores de Rede
    Respostas: 0
    Último Post: 16-02-2014, 10:16
  2. Respostas: 4
    Último Post: 07-03-2009, 18:15
  3. Cache não funciona nos clientes wireless do mk
    Por wfantunes no fórum Redes
    Respostas: 5
    Último Post: 23-12-2008, 20:43
  4. sem ascesso a pagina do mk remotamente!
    Por kraddv no fórum Redes
    Respostas: 1
    Último Post: 09-06-2007, 18:15
  5. navegar sem o IP do proxy no navegador???
    Por eduardounai no fórum Servidores de Rede
    Respostas: 6
    Último Post: 26-01-2006, 10:42

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L