• Wireshark: Atualizações para Corrigir Vulnerabilidades Críticas

    Foram liberadas as versões 1.2.15 e 1.4.4 para o analisador cross-platform de protocolo de rede, Wireshark. As atualizações de segurança abordam duas vulnerabilidades altamente críticas, que podem causar falhas no aplicativo.

    A primeira questão (CVE-2011-0538), descoberta por Huzaifa Sidhpurwala da Red Hat Security Response Team, poderia levar à corrupção de memória ao ler um arquivo .pcap no formato pcap-ng, que poderia ser explorada por um atacante remoto para realizar um ataque Denial-of-Service (DoS). A outra falha (CVE-2011-0713), poderia levar a ocorrência de um buffer overflow ao ler um arquivo de rastreamento especialmente criado para esta finalidade nociva, possivelmente levando a execução de código arbitrário.

    Outras mudanças incluem correções para sistemas de 32 bits durante a leitura de um pacote 6LoWPAN e atualizações diversas. Todos os usuários são aconselhados a fazer a atualização para as versões mais recentes o mais rápido possível. Os binários do Wireshark estão disponíveis para Windows e Mac OS X, bem como o código-fonte, além de uma documentação que também é fornecida.

    No período de 13 à 16 de junho, na Califórnia, será realizada a Sharkfest 2011. Trata-se de um encontro anual, instanciado em 2007, com o objetivo de proporcionar um fórum para a partilha de conhecimentos entre a comunidade global do Wireshark e usuários de um dos analisadores de rede mais populares do mundo.


    Saiba Mais:

    [1] Weireshark: http://www.wireshark.org/news/20110301.html
    [2] Área de Download: http://www.wireshark.org/download.html
    [3] SharkFest 2011: http://sharkfest.wireshark.org/

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L