• Puppet: Atualizações para Corrigir Falhas de Segurança

    Os desenvolvedores da Puppet Labs lançaram atualizações importantes para a sua plataforma de sistema de gerenciamento e automação, com o intuito de corrigir uma série de falhas de segurança. As correções são aplicadas ao Puppet 2.6.17 e versões anteriores, 2.7.20 e anteriores, e versão 3.1, bem como Puppet Enterprise 1.2.6 e anteriores, e 2.7.1 e versões anteriores. As falhas incluem uma série de problemas de execução remota de código, ou não autenticado - abordadas no CVE-2013-1655 para Puppet 2.7.x e 3.1 - ou autenticada em nós master - CVE-2013-2274 2.6.x para 1.2.x e Enterprise e CVE -2013-1640 para todas as versões, além de abordagens no CVE-2013-1653 para Puppet 2.7.x e 3.1, e Enterprise Puppet 2.7.1.


    Havia também problemas com vulnerabilidades de downgrade SSL ( CVE-2013-1654 ) corrigidos pela desativação de SSLv2, validação de entrada insuficiente (CVE-2013-1652), e mal configuração no ACL padrão (CVE-2013-2275), que afetou todas as versões. Sendo assim, a Puppet Labs já lançou versões 2.6.18 , 2.7.21 e 3.1.1 e versões Puppet Enterprise 1.2.7 e 2.7.2.


    Saiba Mais:

    [1] Heise On-line http://www.h-online.com/security/new...s-1823672.html

    Sobre o Autor: Camilla Lemke


Visite: BR-Linux ·  VivaOLinux ·  Dicas-L