Ver Feed RSS

underwanderson

Fazer Cache Full versão 2.9.X

Avalie este Post de Blog
Antes de mais nada, o que é o chamado cache full?
Cache full é um metodo usado em servidores de internet para dar folga ao link de internet, fazendo com que tudo que já tiver gravado no cache do web proxy ou somente proxy possa ser entregue em velocidade muito superior a velocidade designada a maquina cliente onde o administrador especifica valores absurdos mas desde que não atole a saída do equipamento que faz a entrega, seja ele um router ou um rádio ap wireless, por exemplo se tem um ap que esta configurado para trabalhar com a banda B com certeza a taxa maxima de entrega de serviço dele é de 11Mb e se for G 54Mb se na banda B ele esta trabalhando com um servidor que o cache full está mandando 15Mb de up e 15de down com certeza se der o azar de muitas solicitações forem feitas do cache direto com certeza o ap vai travar então sempre configura com valores que dão folga ao ap.
Então vamos lá primeiro marcar os pacotes do web proxy cache em:
/ ip firewall mangle
add chain=output protocol=tcp src-port=3128 content="X-Cache: HIT" action=mark-connection \

new-connection-mark=conn_squid-up passthrough=yes comment="CACHE FULL" disabled=no add chain=output connection-mark=conn_squid-up action=mark-packet new-packet-mark=pacotes_squid-up \
passthrough=yes comment="" disabled=no
add chain=prerouting protocol=tcp dst-port=3128 action=mark-connection new-connection-mark=conn_squid-down \

passthrough=yes comment="" disabled=no
add chain=prerouting connection-mark=conn_squid-down action=mark-packet new-packet-mark=pacotes_squid-down \

passthrough=yes comment="" disabled=no

Agora vamos fazer com que o firewall aceite todas requisições dos clientes ao cache em:
/ip firewall filter
add chain=input protocol=tcp dst-port=3128 action=accept comment="ACEITAR CONEXOES PROXY" disabled=no

É bom utilizar esta regra sempre abaixo da regra de bloqueio ao acesso externo ao proxy!

depois de fechar o firewall com as regras de marcação de pacotes e liberação do trafego ao cache pela rede local vamos configurar o controle de limite de banda do nosso cache em:
/ queue tree
add name="CACHE-FULL-Download" parent=global-in packet-mark=pacotes_squid-down limit-at=0 queue=default priority=1 max-limit=15000000 burst-limit=0 burst-threshold=0 burst-time=0s disabled=no
add name="CACHE-FULL-Upload" parent=global-out packet-mark=pacotes_squid-up limit-at=0 queue=default priority=1 max-limit=15000000 burst-limit=0 burst-threshold=0 burst-time=0s disabled=no


Assim estou informando meu servidor que só enviaremos requisições a dados já gravado em cache a no máximo 15Mb, mas lembre-se que aqui esta em 15Mb e pode ser utilizada em uma rede cabeada, no entanto não utilize em redes wireless banda B para não saturar o trafego em certos picos que houver na sua rede pois a rede cabeada como todos já sabem vai a 100Mb ou mais dependendo a infraestrutura.

Gente se falei alguma besteira ou postei algo que não condiz com a realidade é a hora de ajudar.
Obrigado!

agradecimentos ao David CATV do under linux e edilson sousa do forum web
Categorias
Não Categorizado

Comentários

  1. Avatar de superxandaoce
    Parabéns, acrescenta as regras para versao 3, marcando TOS que fica como fonte de referencia para as duas versoes !
  2. Avatar de underwanderson
    Boa!
    Obrigado por visitar este Blog!
  3. Avatar de alexandrecorrea
    ctrl+c ctrl+v ??

+ Enviar Comentário





Visite: BR-Linux ·  VivaOLinux ·  Dicas-L