Ver Feed RSS

ultralaser

Script para Acesso remoto qdo se utiliza modem discado

Avalie este Post de Blog
Citação Postado originalmente por ultralaser Ver Post
Nunca fiz um post aqui no Under, pois sempre achei posts atualizados e sempre bem feitos por nossos amigos, mas estava procurando scripts para fazer um acesso remoto a um servidor em outra localidade sendo que este utliza um modem discado e a todo momento muda o IP de entrada, procurei e achei varios scripts que pra mim não funcionaram infelizmente ou felizmente neh... rs... primeiramente precisa-se ter uma conta no DynDns ou no Changeip, após soh utilizar o script abaixo, detalhe para versão 3.X do Mikrotik.

==================================
# Define User Variables
:global ddnsuser "nome de usuario de login no DynDns ou no Changeip"
:global ddnspass "senha do DynDns ou do Changeip"
:global ddnshost "host criado dentro do DynDns ou do Changeip"
:global ddnsinterface "Interface de entrada que faz a discagem, exppoe-out1"
# Define Global Variables
:global ddnsip
:global ddnslastip
:if ([ :typeof $ddnslastip ] = nil ) do={ :global ddnslastip "0" }
:global ddnsinterface
:global ddnssystem ("mt-" . [/system package get system version] )
# Define Local Variables
:local int
# Loop thru interfaces and look for ones containing
# default gateways without routing-marks
:foreach int in=[/ip route find dst-address=0.0.0.0/0 active=yes ] do={
:if ([:typeof [/ip route get $int routing-mark ]] != str ) do={
:global ddnsinterface [/ip route get $int interface]
}
}
# Grab the current IP address on that interface.
:global ddnsip [ /ip address get [/ip address find interface=$ddnsinterface ] address ]
# Did we get an IP address to compare?
:if ([ :typeof $ddnsip ] = nil ) do={
:log info ("DDNS: No ip address present on " . $ddnsinterface . ", please check.")
} else={
:if ($ddnsip != $ddnslastip) do={
:log info "DDNS: Sending UPDATE!"
:log info [ ut [/tool dns-update name=$ddnshost address=[ick $ddnsip 0 [:find $ddnsip "/"] ] key-name=$ddnsuser key=$ddnspass ] ]
:global ddnslastip $ddnsip
} else={
:log info "DDNS: No update required."
}
}
# End of script
==================================================

Atualizado 02-12-2011 em 16:08 por ultralaser

Categorias
Não Categorizado

Comentários

  1. Avatar de puricao
    massa isso ai vai ajudar muita gente eu mesmo estava precisando para o meu ddns
    parabens!!!!
  2. Avatar de Wellison
    flw, ajudou muito amigo.
    abraços!!!!!!

+ Enviar Comentário



Visite: BR-Linux ·  VivaOLinux ·  Dicas-L