Ver Feed RSS

Geeek

Bonding no Mikrotik rOS com Rocket M

Avaliação: 9 votos, 5,00 média.

Introdução


Bonding é um mecanismo do software no qual voce pode agregar multiplas interfaces de rede para obter um maior throughput com um alto nivel de disponibilidade.Vamos ver aqui como configura-lo com duas interfaces de cada lado, mas lembre-se que mais links podem ser colados para atingir velocidades superiores ou de disponibilidade.

Principais tipos de bonding:

  1. Balance-RR (Round Robin) – Forma genérica para dual LAN enviando pacotes de forma sequencial pelas placas, provendo bom balanço entre “load balancing” e tolerância à falhas.
  2. Active Backup (failover) – Usa apenas uma das placas de rede durante todo o tempo e passa a usar a segunda em caso de falha da primeira (apenas tolerância a falhas).
  3. Balance XOR – Ao longo do tempo mapeia algumas estações destino para placas específica fazendo a divisão de carga e da banda entre os acessos.
  4. Broadcast – Envia o mesmo conjunto de pacotes pelas duas placas, serve para prover tolerância a falhas.
  5. IEE 802.3ad Dynamic Link Agregation – Usa um algoritmo complexo para agregar a largura de banda usando a especificação 802.3ad. Exige suporte explícito do SWITCH para 802.3ad.
  6. Balance-tlb Adaptive Transmit Load Balance – Equilibra a carga dinamicamente pela velocidade e volume de tráfego dos pacotes de SAÍDA (leituras). Não requer suporte especial do SWITCH. Atua trocando dinamicamente o endereço MAC no caso da placa destino não ser capaz de atender a solicitação provendo agregação e tolerância a falhas.
  7. Balance-alb Adaptive Load Balance – similar ao Balance-tlb, mas também consegue redistribuir pacotes de ENTRADA (gravações) provendo agregação e tolerância a falhas.

A visualização gráfica do que iremos fazer:

Nome:      Layout.jpg
Visitas:     12794
Tamanho:  25,5 KB


Requisitos


  • 4 Rádios Ubiquiti (Rocket M) A / B / G / N, dependendo da sua aplicação.
  • 2 (RBs) routers Mikrotik com 2 portas Ethernet disponiveis, cuidado com pps, recomendável RB 450G ou mais.
  • 4 Conectividade direta na camada 2 entre os dois dispositivos Mikrotik em todos os links que serão utilizados na Bonding.
    • Isso pode ser realizado por AP-WDS/STATION-WDS nos dispositivos UBNT ou usando EoIP dentro do software da Mikrotik. Discutiremos a abordagem WDS.


Configuração das Rocket M

Nós faremos a nossa configuração através da Web GUI.

A1


  1. Na na guia link setup, defina: mode “Access Point WDS”.
  2. Na guia network, defina: modo Bridge, o endereço IP 192.168.0.11, máscara de sub-rede 255.255.255.0 e Gateway 192.168.0.10.
  3. Na guia system dê ao dispositivo um nome descritivo e altere a senha.

A2


  1. Na guia link setup, defina: mode “Access Point WDS”.
  2. Na guia network, defina: Modo Bridge, o endereço IP 192.168.0.12, a máscara de sub-rede 255.255.255.0 e Gateway 192.168.0.10.
  3. Na guia system dê ao dispositivo um nome descritivo e altere a senha.

B1


  1. Na guia link setup, defina: mode “Station WDS”.
  2. Na guia network, defina: modo Bridge, o endereço IP 192.168.0.21, a máscara de sub-rede 255.255.255.0 e Gateway 192.168.0.10.
  3. Na guia system dê ao dispositivo um nome descritivo e altere a senha.

B2


  1. Na guia link setup, defina: modo “Station WDS”.
  2. Na guia network, defina: Modo Bridge, o endereço IP 192.168.0.22, a máscara de sub-rede 255.255.255.0 e Gateway 192.168.0.10.
  3. Na guia system dê ao dispositivo um nome descritivo e altere a senha.

Configuração das routerboard Mikrotik (RB 450g)

.
A conexão ao router Mikrotik pode ser feito com Putty ou por Winbox e está bem documentado na sua Wiki e Manual . Este documento irá explicar a configuração de linha de comando, que pode facilmente ser seguidas com o GUI Mikrotik (Winbox). E para evitar confusão A1 vai na Ether1 e A2 vai na Ether2 e o mesmo para a outra torre, exceto substitui o A com B.

Router A


Entre em seu router Mikrotik
  1. Crie uma interface de bonding: Aqui você diz ao roteador que interfaces devem ser incluídos no laço.
  2. Iremos fazerno modo round-robin mode *balance-rr*,Adicione ether1 e ether2 como escravos e de o nome da interface de “bonding1″. Os diferentes modos de bonding são explicados no Mikrotik’s Wiki / Bonding .
    • Código :
      /interface bonding add slaves=ether1,ether2 name=bonding1 mode=balance-rr

  3. Atribua um endereço IP para a interface de bonding. Nunca atribua ip’s para as interfaces escravas.
    • Código :
      /ip address add address 192.168.0.10/24 interface=bonding1

  4. Adicione Monitoramento de Link para que o seu router saiba quando uma bonding está com problema.
  5. Usaremos o ARP para a monitoração da bonding e diremos ao router para prestar atenção ao ARP em 192.168.0.20 .
  6. Um explicação dos diferentes tipos de monitoramento link pode ser encontrado no Mikrotik’s Wiki / Bonding .
    • Código :
      /interface bonding set bonding1 link-monitoring=arp arp-ip-targets=192.168.0.20


Router B


  1. Entre em seu router Mikrotik
  2. Crie uma interface de bonding: Aqui você diz ao roteador que interfaces devem ser incluídos no laço.
  3. Iremos fazerno modo round-robin mode *balance-rr*,Adicione ether1 e ether2 como escravos e de o nome da interface de “bonding1″. Os diferentes modos de bonding são explicados no Mikrotik’s Wiki / Bonding .
    • Código :
      /interface bonding add slaves=ether1,ether2 name=bonding1 mode=balance-rr

  4. Atribua um endereço IP para a interface de bonding. Nunca atribua ip’s para as interfaces escravas.
    • Código :
      /ip address add address 192.168.0.20/24 interface=bonding1

  5. Adicione Monitoramento de Link para que o seu router saiba quando uma bonding está com problema.
  6. Usaremos o ARP para a monitoração da bonding e diremos ao router para prestar atenção ao ARP em 192.168.0.10 .
  7. Um explicação dos diferentes tipos de monitoramento link pode ser encontrado no Mikrotik’s Wiki / Bonding .
    • Código :
      /interface bonding set bonding1 link-monitoring=arp arp-ip-targets=192.168.0.10


Ensaio

Temos de testar e certificar-se a bonding está funcionamdo. Siga estes passos para garantir que tudo está funcionando corretamente.

  1. Entre no Router A
  2. Execute um ping para o roteador B
    • Código :
      /ping 192.168.0.20

  3. Execute a ferramenta de teste de velocidade para o Roteador B
    • Código :
      /tool bandwidth-test 192.168.0.20 direction=receive
    • Deve aparecer algo parecido como a descrição abaixo:


    Nome:      andsdsnfsdfsdsjvns.jpg
Visitas:     13732
Tamanho:  15,9 KB


Conclusão

Um par de coisas que eu gostaria de ressaltar aqui.
A largura de banda total realizável aqui é 2x a velocidade do link mais lento.
Exemplo:
Vamos dizer que um link faz 90 Mbit e que o outro faz 80 Mbit sua soma total deve ser em cerca de 160 Mbits (80 x 2).
A configuração da bonding descrita aqui é uma bonding half-duplex. A bonding trabalhará através de ligações multi-hop, enquanto houver conexão na camada 2 entre os pontos finais da bonding.
Agora é por em produção e Boa Sorte!

Fonte: Mikrotik bonding - Ubiquiti Wiki
Nome:      t56572_1282979873.jpg
Visitas:     8366
Tamanho:  1,5 KB
Rodrigo Gregório (Geeek)
MTCNA - MikroTik Certified Network Associate
Consultor Mikrotik Oficial in Rio de Janeiro
Tel:
+55 21 (7907-2777) TIM
Meu telefone, rádio e msn é somente para Consultoria!
http://under-linux.org/signaturepics/sigpic53142_3.gif

Atualizado 03-07-2012 em 16:56 por Geeek

Categorias
Artigos , Dicas , Reviews , Tutoriais

Comentários

Página 1 de 2 12 ÚltimoÚltimo
  1. Avatar de alexsuarezferreira
    poxavida ta de parabem´s, a muito tempo não aparesia algo tão interesante no under, otimo material, otimo mesmo, so tenho uma pergunta, daria para aplicar isso a dois bullet M com antena dupla, esa e minha duvida, obrigado...
  2. Avatar de Gustavinho
    Bom post amigo!!!parabens....um tema muito bacana de se discutir!!!
  3. Avatar de MarceloGOIAS
    Bom dia,

    não tive tempo de testar, mas parece muito bom. Parabéns.
  4. Avatar de edcomrocha
    Parabens, belo post.

    E veio a na hora certa, eu ja tinha começado a procurar uma soluçao assim ontem mesmo.

    Muito obrigado

    Grande Abraço.
  5. Avatar de byosni
    Opa cara,
    parabéns... muito bem explicado. Vou postar um link no meu blog para este post. Ok.
  6. Avatar de Não Registrado(s)
    Maravilhoso post, ja esta na hora dos Administradores criarem uma área dedicada só a ubiquiti.
    Esta de parabéns Geeek
  7. Avatar de Geeek
    Citação Postado originalmente por alexsuarezferreira
    poxavida ta de parabem´s, a muito tempo não aparesia algo tão interesante no under, otimo material, otimo mesmo, so tenho uma pergunta, daria para aplicar isso a dois bullet M com antena dupla, esa e minha duvida, obrigado...
    Seguindo a Lógica da coisa da para fazer sim amigo; independente de Rocket, Bullet, Cartões mini pci e etc...
  8. Avatar de leandrolopeswifi
    Bom Dia Rogério! Mandoubem irmão!!parabéns!!
  9. Avatar de Geeek
    Citação Postado originalmente por leandrolopeswifi
    Bom Dia Rogério! Mandou bem irmão!!parabéns!!
    Obrigado Man mas, é Rodrigo e tu sempre troca meu nome kkkk...
  10. Avatar de luizbe
    cara , excelente post.
    pensei nisso esses dias, fazer o bonding com 2x2 Rockets.
  11. Avatar de ederamboni
    Cara impressionante mesmo.... parabens!!!!!!
    estava justamente precisando de algo assim...Obrigado
  12. Avatar de hiranneri
    Parabens pelo post.
  13. Avatar de alamdias
    Top !!! Eu estava procurando ! Onde pago ? heheheheh

    abraços

    alam dias
  14. Avatar de Sp4celan
    Com sua permisa irei divulgar no forum do bfw parabens
  15. Avatar de Não Registrado(s)
    Cara justamente o que eu estava precisando para fazer na minha rede aqui em MG, obrigado geek Te amo!
  16. Avatar de Squire
    Fantástico! Vou por em pática futuramente um de ptp pra 70Mb e essa estrutura vai ser uma mão na roda heheh ;D `òtimo post.. Parabens!
  17. Avatar de soaresdebarros
    Simples e direto muito legal seu post
  18. Avatar de m4d3
    Ta ficando bom no visio Geeek, pode informar onde consigo biblioteca da Ubiquiti e Mikrotik pra uso no visio ?

    Abraço
  19. Avatar de Geeek
    Citação Postado originalmente por m4d3
    Ta ficando bom no visio Geeek, pode informar onde consigo biblioteca da Ubiquiti e Mikrotik pra uso no visio ?

    Abraço
    Vou ficar te devendo essa amigo m4d3.
  20. Avatar de Oldayr
    Valeu !!!!! Mandou bem !!!
  21. Avatar de netxtreme
    Parabéns Rodrigo, excelente post, merecia até uma medalha!!!!
    Grande Abrs.
  22. Avatar de kleberbrasil
    Eis um Under de verdade! Isso ai, compartilhar informação engrandece a pessoa, parabéns por pensar e agir assim!!
  23. Avatar de owner
    Parabéns pela tradução.
    Você só esqueceu de postar os créditos!!!

    Mikrotik bonding - Ubiquiti Wiki
  24. Avatar de Geeek
    Citação Postado originalmente por owner
    Parabéns pela tradução.
    Você só esqueceu de postar os créditos!!!

    Mikrotik bonding - Ubiquiti Wiki
    Perdoe-me senhores realmente esqueci a fonte, eu tinha entendido a relação entre a fonte da Wiki da Mikrotik no post, Ja está corrigido lá.
    Atualizado 22-11-2010 em 22:24 por Geeek
  25. Avatar de kleberbrasil
    Citação Postado originalmente por Geeek
    O prórpio post faz referência a Wiki da Mikrotik diversas vezes.
    Geek, insere lá: fonte (inglês: Mikrotik bonding - Ubiquiti Wiki) e acaba com essa polêmica. Reconhecer os créditos é uma postura que não desmerecerá seu esforço.
  26. Avatar de Geeek
    Citação Postado originalmente por kleberbrasil
    Geek, insere lá: fonte (inglês: Mikrotik bonding - Ubiquiti Wiki) e acaba com essa polêmica. Reconhecer os créditos é uma postura que não desmerecerá seu esforço.
    Obrigado Kleber, ja está corrigido!
  27. Avatar de FilipiGrijo
    Aew muleke, sempre nos ajudando abraçoss !!!
  28. Avatar de lacierdias
    Ótimo artigo.
  29. Avatar de FANTOXY
    Very Good, Great God illuminated his life ... Ever so .
    بسیار خوب است ، خدا بزرگ زندگی خود را روشن... تا همیشه..
    非常好,他的生活照大神...她真叫..

    São tantos indiomas que não sei lhe agradecer....
  30. Avatar de rodrigoferro
    E Ae galera, é uma ótima solução mesmo, já estamos aplicando por aqui....vide foto link:
    ImageShack
    Abraços
Página 1 de 2 12 ÚltimoÚltimo

+ Enviar Comentário



Visite: BR-Linux ·  VivaOLinux ·  Dicas-L