Ver Feed RSS

Dicas, truques e curiosidades

PCC / Load Balance de forma rápida e fácil para iniciantes

Avalie este Post de Blog
Vejo diversos post ótimos aqui mostrando como é um bom pcc, mas quem esta iniciando no mikrotik tem certa dificuldade de fazer como manda o tuto, então pensando nisso e a pedido de alguns colegas eu fiz um script simples porém funcional de pcc
é bem simples, use-o como um quebra galho para entender,


;;;;;;;;;;Pcc com 2 links


;;;;;;;;;;Primeiro renomei as interfaces


EthClientes = saida pro servidor
EthLink1 = modem 1 em bridg
EthLink2 = modem 2 em bridg


;;;;;;;;;;segundo Fazer 2 PPPOE com os nomes abaixo


Discador1
Discador2


OBS: quando vc fizer os discadores você deixa marcado SÓ a OPÇÂO "ADD DEFAUT ROUTE"


;;;;;;;;;Treceiro fazer o nat dos discadores


Código :
/ip firewall nat
add action=masquerade chain=srcnat comment="MASCARAMENTO PCC" disabled=no out-interface=\
    EthLink1
add action=masquerade chain=srcnat comment="" disabled=no out-interface=EthLink2


;;;;;;;;;;Adicionar um IP no Adress


192.168.10.1


Código :
/ip address
add address=192.168.10.1/24 broadcast=192.168.10.255 comment="IP PCC" disabled=no \
    interface=EthClientes network=192.168.10.0




;;;;;;;;;;;DNS


200.165.132.155
200.149.55.142


não esquece de colocar o DNS e marca o "allow remote requests...


;;;;;;;;;;;Mangle

Código :
/ip firewall mangle
add action=accept chain=prerouting comment="Sem Balance" disabled=no dst-address-list=\
    sem_balance in-interface=EthClientes
 
 
add action=mark-connection chain=input comment="" connection-state=new disabled=no \
    in-interface=EthLink1 new-connection-mark=conn_na passthrough=yes
 
 
add action=mark-connection chain=input comment="" connection-state=new disabled=no \
    in-interface=EthLink2 new-connection-mark=conn_nb passthrough=yes
 
 
add action=mark-connection chain=prerouting comment="" disabled=no dst-address-type=\
    !local in-interface=EthClientes new-connection-mark=conn_ma0 passthrough=yes \
    per-connection-classifier=both-addresses:6/0
 
 
add action=mark-connection chain=prerouting comment="" disabled=no dst-address-type=\
    !local in-interface=EthClientes new-connection-mark=conn_mb1 passthrough=yes \
    per-connection-classifier=both-addresses:6/1
 
 
add action=mark-routing chain=prerouting comment="" connection-mark=conn_ma0 disabled=no \
    in-interface=EthClientes new-routing-mark=to_nra passthrough=no
 
 
add action=mark-routing chain=prerouting comment="" connection-mark=conn_mb1 disabled=no \
    in-interface=EthClientes new-routing-mark=to_nrb passthrough=no


;;;;;;;;;;;;;;Route


Código :
/ip route
add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=Discador1
 
 
add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=Discador1 \
    routing-mark=to_nra
 
 
add comment="" disabled=no distance=2 dst-address=0.0.0.0/0 gateway=Discador2
 
 
add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=Discador2 \
    routing-mark=to_nrb


Agora vai o PULO DO GATO


servidor MK 3.22 configuração


primeiro em IP Address coloca o IP


192.168.10.2/24


segundo vc vai lá em route e coloca essa regra


Código :
/ip route
add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=\
    192.168.10.1 scope=30 target-scope=10

não esquece de colocar o DNS e marca o "allow remote requests"
Categorias
Artigos , Dicas

Comentários

  1. Avatar de lucivan
    Boa Tarde amigo será que vc poderia mim ajudar olha o meu msn : lucivan17@hotmail.com
  2. Avatar de paulomc66
    ola amigo gostei muito deste poste eu tenho aqui 1linkdedicado de 3megas e 2 adsl de 15megas como seriam estas regras desde ja agradeço
  3. Avatar de m4d3
    Quando citar material de terceiro não esqueça de citar as fontes, é algo que faz sentido pra mim:

    http://under-linux.org/f227/pcc-bala...r-m4d3-131343/
  4. Avatar de Acronimo
    Amigo m4d3 nem preciso citar vc, pois o seu script esta anos luz melhor que o meu pois esta completo nao posso nem contar quantas vezes o seu post me ajudou, a entender o PCC
    sou imensamente grato a vc, nao so pelo pcc mas outros post que vc tem
    me perdoe pela gafe estou vendo se tenho como editar para colocar a sua assinatura
  5. Avatar de m4d3
    Capaz fera ficou bacana o post, sei que tem colaborado com muita gente dentro e fora dos fóruns, mas a dica é válida.

    Abraço Rodrigo, nos vemos no mum.
  6. Avatar de Kasteds
    Olá acronimo, gostei muito do seu script, muito bem explicado, sou iniciante no MK e gostaria de saber se funciona na v5.20 com rb450g, a porta clientes é eth5, gostaria como faria para trabalhar com 2 switch também nas portas eth3 e eth4.


    desde já de agradeço!

    Edson kast
  7. Avatar de Adriano Leite Mmn
    Alguém sabe onde encontro, ou quem tem um link pra baixar a .iso do MIKROTIK 6.2 comprimido em RAR, (winrar), POIS DE ONDE ACESSO TEM PROXY E FOI BLOQUEADO A EXTENSÃO .iso OBRIGADO!
  8. Avatar de Acronimo
  9. Avatar de Acronimo
    Citação Postado originalmente por Kasteds
    Olá acronimo, gostei muito do seu script, muito bem explicado, sou iniciante no MK e gostaria de saber se funciona na v5.20 com rb450g, a porta clientes é eth5, gostaria como faria para trabalhar com 2 switch também nas portas eth3 e eth4.


    desde já de agradeço!

    Edson kast

    entre em contato comigo (31)9223-0075 Tim
  10. Avatar de Acronimo
    Citação Postado originalmente por Adriano Leite Mmn
    Alguém sabe onde encontro, ou quem tem um link pra baixar a .iso do MIKROTIK 6.2 comprimido em RAR, (winrar), POIS DE ONDE ACESSO TEM PROXY E FOI BLOQUEADO A EXTENSÃO .iso OBRIGADO!

    iso compactada

    http://www.4shared.com/rar/WaX8iVW4/mikrotik-62.html?

+ Enviar Comentário



Visite: BR-Linux ·  VivaOLinux ·  Dicas-L