Ver Feed RSS

interhome

[DICA] 32 - MIKROTIK - BONDING - Agregar múltiplos Enlaces

Avalie este Post de Blog
Introdução


Através do BONDING no MIKROTIK, podemos agregar múltiplas interfaces de rede para alcançar mais produtividade com um maior nível de disponibilidade.


Principais tipos de bonding:



  1. Balance-RR (Round Robin) – Forma genérica para dual LAN enviando pacotes de forma sequencial pelas placas, provendo bom balanço entre “load balancing” e tolerância à falhas.
  2. Active Backup (failover) – Usa apenas uma das placas de rede durante todo o tempo e passa a usar a segunda em caso de falha da primeira (apenas tolerância a falhas).
  3. Balance XOR – Ao longo do tempo mapeia algumas estações destino para placas específica fazendo a divisão de carga e da banda entre os acessos.
  4. Broadcast – Envia o mesmo conjunto de pacotes pelas duas placas, serve para prover tolerância a falhas.
  5. IEE 802.3ad Dynamic Link Agregation – Usa um algoritmo complexo para agregar a largura de banda usando a especificação 802.3ad. Exige suporte explícito do SWITCH para 802.3ad.
  6. Balance-tlb Adaptive Transmit Load Balance – Equilibra a carga dinamicamente pela velocidade e volume de tráfego dos pacotes de SAÍDA (leituras). Não requer suporte especial do SWITCH. Atua trocando dinamicamente o endereço MAC no caso da placa destino não ser capaz de atender a solicitação provendo agregação e tolerância a falhas.
  7. Balance-alb Adaptive Load Balance – similar ao Balance-tlb, mas também consegue redistribuir pacotes de ENTRADA (gravações) provendo agregação e tolerância a falhas.

Vamos discutir uma ligação dupla aqui, mas tenha em mente que mais links pode ser ligado para alcançar maior velocidade / disponibilidade.


A visualização do que estamos tentando realizar:

https://m.ak.fbcdn.net/sphotos-c.ak/...40157012_n.jpg

Requisitos


  • 4 Ubiquiti Rádios A / B / G / N, dependendo da sua aplicação
  • 2 roteadores Mikrotik com 2 portas Ethernet availible
  • 4 Antenas e cabos apropriados (se estiver usando um dispositivo UBNT que não tê-los incorporado)
  • Verdadeira Layer 2 a conectividade entre os dois dispositivos Mikrotik em todos os links que serão utilizados no vínculo
    • Isto pode ser conseguido por AP-WDS/STA-WDS nos dispositivos UBNT ou usando EOIP dentro software Mikrotik. Vamos discutir a abordagem WDS.


Configuração Dispositivos UBNT

Configuração e acesso de dispositivos UBNT é descrita no Guia de airos-configuração rápida . Faremos o nosso configuração através da interface gráfica web.
A1


  1. Sob a guia sem fio, defina: Mode "Access Point WDS"
  2. Sob a guia de rede, defina: Modo Bridge, endereço IP para 192.168.0.11, a máscara de sub-rede para 255.255.255.0 e Gateway para 192.168.0.10
  3. Dê ao dispositivo um nome descritivo e alterar a senha

A2


  1. Sob a guia sem fio, defina: Mode "Access Point WDS"
  2. Sob a guia de rede, defina: Modo Bridge, endereço IP para 192.168.0.12, a máscara de sub-rede para 255.255.255.0 e Gateway para 192.168.0.10
  3. Dê um nome ao dispositivo descritivo e alterar a senha


B1


  1. Sob a guia sem fio, defina: Mode "Station WDS"
  2. Sob a guia de rede, defina: Modo Bridge, endereço IP para 192.168.0.21, a máscara de sub-rede para 255.255.255.0 e Gateway para 192.168.0.20
  3. Dê ao dispositivo um nome descritivo e alterar a senha

B2


  1. Sob a guia sem fio, defina: Mode "Station WDS"
  2. Sob a guia de rede, defina: Modo Bridge, endereço IP para 192.168.0.22, a máscara de sub-rede para 255.255.255.0 e Gateway para 192.168.0.20
  3. Dê ao dispositivo um nome descritivo e alterar a senha

Mikrotik engrenagem



Ligar para o seu router Mikrotik pode ser feito com Putty ou Winbox e está bem documentado na sua Wiki e manual . Este documento explica a configuração da linha de comando, que pode ser facilmente realizado com o Mikrotik GUI (WinBox). E para evitar confusão A1 vai para ether1 e A2 vai para ether2 eo mesmo para a outra torre, exceto substituir o A com um B.
Router A


  1. Faça o login no seu router Mikrotik
  2. Criar uma interface de vinculação: Aqui você dizer o roteador que interfaces devem ser incluídos no vínculo. Nós vamos usar o modo round-robin, faça ether1 e ether2 os escravos e dar a interface de um nome de "bonding1". Os diferentes modos são explicados em Mikrotik Wiki / Bonding .

    • /interface bonding add slaves=ether1,ether2 name=bonding1 mode=balance-rr
  3. Atribua um IP à interface de ligação. Nunca atribuir ip do que as próprias interfaces de escravos.

    • /ip address add address 192.168.0.10/24 interface=bonding1
  4. Adicionar monitoramento de link para que o seu router sabe quando uma ligação está a ter um problema. Vamos usar ARP para monitoramento de link e dizer ao router para assistir a ARP em 192.168.0.20. Um explaniation dos diferentes tipos de monitoramento de link podem ser encontradas em Mikrotik Wiki / Bonding .

    • /interface bonding set bonding1 link-monitoring=arp arp-ip-targets=192.168.0.20

Router B


  1. Faça o login no seu router Mikrotik
  2. Criar uma interface de vinculação: Aqui você dizer o roteador que interfaces devem ser incluídos no vínculo. Nós vamos usar o modo round-robin, faça ether1 e ether2 os escravos e dar a interface de um nome de "bonding1". Os diferentes modos são explicados em Mikrotik Wiki / Bonding .

    • /interface bonding add slaves=ether1,ether2 name=bonding1 mode=balance-rr
  3. Atribua um IP à interface de ligação. Nunca atribuir ip do que as próprias interfaces de escravos.

    • /ip address add address 192.168.0.20/24 interface=bonding1
  4. Adicionar monitoramento de link para que o seu router sabe quando uma ligação está a ter um problema. Vamos usar ARP para monitoramento de link e dizer ao router para assistir a ARP em 192.168.0.10. Um explaniation dos diferentes tipos de monitoramento de link podem ser encontradas em Mikrotik Wiki / Bonding .

    • /interface bonding set bonding1 link-monitoring=arp arp-ip-targets=192.168.0.10

Prova

Precisamos testar e certificar-se o vínculo está funcionando. Siga estes passos para garantir que tudo está funcionando corretamente.

  1. Faça o login no Router A
  2. Execute um ping para o roteador B

    • /ping 192.168.0.20
  3. Execute a ferramenta de teste de velocidade para Router B
    • /tool bandwidth-test 192.168.0.20 direction=receive


status: running
duration: 9s
rx-current: 213.4Mbps
rx-10-second-average: 69.4Mbps
rx-total-average: 69.4Mbps
lost-packets: 0
random-data: no
direction: receive
rx-size: 1500

Enquanto o speedtest está funcionando desligar um de seus éter do conectado ao seu engrenagem UBNT, você deve obter alguns pings perdidos depois ver algo semelhante ao seguinte.
status: running
duration: 8s
rx-current: 93.3Mbps
rx-10-second-average: 38.1Mbps
rx-total-average: 38.1Mbps
lost-packets: 0
random-data: no
direction: receive
rx-size: 1500


Conclusão



Um par de coisas que eu gostaria de salientar aqui. A largura de banda total realizável aqui é 2X a velocidade da ligação mais lenta.

Exemplo:

Vamos dizer que um elo faz 90 Mbit e o outro faz 80 Mbit seu rendimento total deve ser de cerca de 160 Mbit (80 x 2). A configuração de ligação descrito aqui é um link half-duplex. Bonding funcionará através de ligações multi-hop, enquanto há camada de 2 a conectividade entre os pontos finais que fazem a ligação.


- Rebel2234 15:47, 23 de junho de 2010 (UTC)


REFERENCIAS:

https://under-linux.org/entry.php?b=...age=3#comments . Autor Rodrigo Gregório (Geeek) . Acessado em 02/12/2013 as 19:59:00
http://wiki.ubnt.com/Mikrotik_bonding . Autor Rebel2234 15:47, 23 de junho de 2010 (UTC) . Acessado em 02/12/2013 as 19:59:00


https://m.ak.fbcdn.net/sphotos-h.ak/...07825342_n.jpgSkype: inter-homesolucoes
Curtam nossa página. Obrigado.

Avalie nosso Post e nos ajude a continuar escrevendo. Obrigado.
Categorias
Artigos , Dicas , Tutoriais

Comentários

  1. Avatar de netuai
    Muito bom, e detalhado, parabéns pela iniciativa
  2. Avatar de wans1105
    Essa seria uma forma de dividir travego ou seria mais uma forma de de evitar que a rede pare de vez?

+ Enviar Comentário



Visite: BR-Linux ·  VivaOLinux ·  Dicas-L