Ver Feed RSS

Raniel

Sistema de aviso - avisa que faltou Internet

Avalie este Post de Blog
Olá pessoal,
Como é do interesse de todos, fiz alguns testes, e ainda há muitos a serem feitos, criei uma sistema de aviso para quando a comunicação com a internet falhar. Vou explicar aqui o que consegui fazer para que isto funcionasse.

Obs.: Ao descobrirem algo a mais que possa ser feito, não ocultem, postem aí para ajudar num sistema eficaz.

A topologia da rede onde foi apliacada:
■ Mikrotik 2.9.51
■ Slackware 12.1 com apache2
■ 3 placas de rede no mikrotik (wan, lan e linux)
■ rede linux 192.168.2.0/30
■ rede clientes 192.168.1.1/24
■ conexão com a internet
■ sites usados: uol, google e orkut

O que fiz:
■ Criei uma lista dos sites mais usados pelos clientes, principalmente aqueles que ficam na home;
■ Configurei o netwatch para ficar monitorando o link
■ Na aba up do netwatch criei um script para remover a lista dos sites não-dinamicos. (o site criado pelo hotspot profile é dinamico);
■ Na aba down criei um script para inserir todos os sites listados no /ip dns static com o endereço do meu servidor apache (uol.com.br com o address 192.168.2.2)

Obs:
■ Não precisei add o meu address no walled-garden mas pode ser o caso de alguns.

Pedido:
■ Tenho uma dica para o pessoal que está disposto a quebrar a cuca: "para que não seje necessário inserir a lista de links, podemos procurar desenvolver um script para capturar o host que o usuário está tentando acessar e redirecioná-lo para o apache."
■ Conto com este pessoal.

Vamos as configurações

Obs.: Cuidado ao copiar e colar, pois posso ter deixado de digitar algo.

Passo 1 - Configurando o mikrotik:
■ As interfaces:
/interface ethernet set ether1 name=wan
/interface ethernet set ether2 name=lan
/interface ethernet set ether3 name=linux

■ Os endereços:
/ip add add address=192.168.200.4/24 interface=wan comment="internet"
/ip add add address=192.168.1.1/24 interface=wan comment="clientes"
/ip add add address=192.168.2.1/30 interface=wan comment="apache, cache linux"

■ O gateway:
/ip route add gateway=192.168.200.1

■ O dns:
/ip dns set primary-dns=200.223.0.84 cache-size=10240 allow-remote-requests=yes

■ O hotspot:
/ip hotspot profile add name=pservidor dns-name=networkings.com.br hotspot-address=192.168.1.1 trial-uptime=15m/15m login-by=http-chap,trial
/ip hotspot user add name=admin password=admin
/ip hotspot add name=servidor interface=lan profile=pservidor address-pool=none

■ Compartilhar a internet:
/ip firewall nat add chain=srcnat out-interface=wan action=masquerade comment="compartilhar a internet"

■ Configurar o netwatch:
/tool netwatch add host=192.168.200.1 timeout=100 interval=5s down-script="/ip dsn static add name=uol.com.br address=192.168.2.2" up-script="/ip dns static remove [/ip dns static find dynamic=no]"

Passo 2 - Configurar o linux
■ Add o endereço ip:
# ifconfig eth0 192.168.2.2 netmask 255.255.255.252 up
# route add default gw 192.168.2.1
# echo "nameserver 200.223.0.84" > /etc/resolv.conf

■ Configurar o apache:
Fazer uma busca na internet que irão achar vários materiais.

Atualizado 15-01-2009 em 23:16 por Raniel

Categorias
Não Categorizado

Comentários

Página 1 de 4 1234 ÚltimoÚltimo
  1. Avatar de Magal
    Post para o fórum.

    Obs: Bom material.
    Atualizado 17-01-2009 em 02:39 por Magal
  2. Avatar de alexandrecorrea
    otimizando este script, voce pode fazer um redirect de tudo que for para porta 80.. e mandar para seu servidor WEB quando o netwatch for executado..

    ai nao precisa fazer a regra do dns !!
  3. Avatar de alexandrecorrea
    mais uma dica .. para melhorar seu sistema ai !!

    no nome la do DNS, no lugar de colocar os sites.. basta colocar:

    .*

    que ele vai resolver TODOS os sites para o ip que voce informar...


    veja esta imagem:

    http://img57.imageshack.us/img57/756/dnsmkxj9.jpg

    (http://img57.imageshack.us/img57/756/dnsmkxj9.jpg)
  4. Avatar de Raniel
    Testei as regras de redirecionamento, mas só a do dns é mais eficaz. Engraçado que eu testei com o .* e ele não redirecionou. Valeu alexandre, muito obrigado.
  5. Avatar de MarcusMaciel
    pro video ficar melhor veja em full screen
Página 1 de 4 1234 ÚltimoÚltimo

+ Enviar Comentário



Visite: BR-Linux ·  VivaOLinux ·  Dicas-L