Ver Feed RSS

droptux

Tutorial: Backup via e-Mail Routerboard

Avalie este Post de Blog

Tudo certo pessoal ?!

Quem nunca passou por uma situação onde precisava de uma cópia da configuração feita anteriormente de algum equipamento, sistemas e afins e não tinha em mãos. Hoje vou mostrar um script simples para realizarmos a cópia das configurações de nosso Routerboard e enviar essas configurações para uma conta do gmail(poderia ser para qualquer outro serviço de e-Mail). Foi usado uma RB 750 com o RouterOS versão 6.27.

Abra o terminal em sua RB e cole o seguinte código alterando o valor da variável 'para' entre aspas duplas(SEU_EMAIL@gmail.com) para a sua conta usada no serviço Gmail:


Código :
/system script
add name=backupEmail policy=ftp,reboot,read,write,policy,test,password,sniff,sensitive source="# Script para realizacao de copia do equipamento,\
    \n# os arquivos .rsc e .backup serao gerados na\
    \n# rotina abaixo\
    \n\
    \n# declarando variaveis gerais\
    \nlocal nomeSys [/system identity get name];\
    \nlocal data [/system clock get date];\
    \nlocal dia [:pick \$data 4 6]\
    \nlocal mes [:pick \$data 0 3];\
    \nlocal ano [:pick \$data 7 11];\
    \nlocal horas [/system clock get time];\
    \nlocal hora [:pick \$horas 0 2];\
    \nlocal minuto [:pick \$horas 3 5];\
    \nlocal nomeArquivo  (\$nomeSys . \"_\" . \$dia . \"-\" . \$mes . \"-\" . \$ano . \"_\" . \$hora . \"-\" . \$minuto);\
    \nlocal assunto (\"Backup RB \" . \$nomeSys);\
    \nlocal para \"SEU_EMAIL@gmail.com\";\
    \n\
    \n# gerando arquivos de backup\
    \n:log info \"Iniciando arquivos para backup ...\";\
    \n\
    \n# gerando e enviando arquivo .rsc por e-Mail\
    \n/system export file=\"\$nomeArquivo\"\
    \ndelay 10s;\
    \n:log info \"Arquivo .rsc criado ...\";\
    \n:log info \"Enviando arquivo .rsc por e-Mail ...\";\
    \n/tool e-mail send subject=\$assunto to=\$para file=\"\$nomeArquivo.rsc\"; \
    \n:delay 10s;\
    \n\
    \n# gerando e enviando arquivo .backup por e-Mail\
    \n/system backup save name=\$nomeArquivo\
    \n:delay 10s;\
    \n:log info \"Arquivo .backup criado ...\";\
    \n:log info \"Enviando arquivo .backup por e-Mail ...\";\
    \n/tool e-mail send subject=\$assunto to=\$para file=\"\$nomeArquivo.backup\";\
    \n:delay 10s;\
    \n\
    \n# removendo arquivos gerados no inicio do procedimento\
    \n:log info \"Removendo arquivos gerados ...\";\
    \n/file remove [find name=\"\$nomeArquivo.rsc\"];\
    \n/file remove [find name=\"\$nomeArquivo.backup\"]\
    \n\
    \n:log info \"Procedimento de backup finalizado !\";"

O script acima gera um arquivo das configurações de seu RB com o nome seguindo o formato abaixo:



  • NomeSistema-dia_mes_ano-hora_minuto.rsc
  • NomeSistema-dia_mes_ano-hora_minuto.backup


Após a geração dos arquivos o script envia um e-Mail para conta de e-Mail especificada na variável 'para' anexando os arquivos gerados anteriormente. Finalizando o procedimento os arquivos gerados são removidos.

Vamos configurar nossa RB para que: quando os e-Mails forem enviados, esses e-Mails sejam apontados para o serviço de e-Mail do Gmail, segue abaixo configuração para tal:
Código :
/tool e-mail
set address=64.233.186.108 from=SEU_EMAIL@gmail.com password=suaSenhadoSeuEmailGmail port=587 start-tls=yes  user=SEU_EMAIL@gmail.com
Os parametros acima vão mudar de acordo com a implementação do serviço de e-Mail selecinado, em nosso caso eu coloquei em 'address' o ip do serviço de smtp do Gmail(smtp.gmail.com) o remetente da mensagem a própria conta de e-Mail, senha de acesso a conta de e-Mail, o usuário do serviço de e-Mail que no caso também é a conta usada no Gmail, porta segura do smtp e o uso de comunicação segura no serviço de smtp.

Com o script já funcionando, você pode executar o comando abaixo em seu terminal e testar o script:
Código :
/system script backupEmail
Se tudo ocorreu bem você receberá os e-Mails com os arquivos em anexo do seu equipamento RB.

Abaixo segue um agendamento feito na RB para que o script seja executado todos os dias às 23:00hrs:
Código :
/system scheduler
add interval=1d name="Backup e-Mail" on-event="/system script backupEmail" start-date=jun/02/2015 start-time=23:00:00
Finalizamos aqui a configuração em nossa RB, foi uma solução simples no entanto pode salvar nossa pele(rerererere). Em relação a conta do Gmail pode ser que o serviço de e-Mail reclame da forma que a conta está sendo acessada. Se for conveniente crie uma conta especifica para tal tarefa e ative o acesso a aplicativos menos seguros como sugerido pelo Gmail.

Comentários


+ Enviar Comentário



Visite: BR-Linux ·  VivaOLinux ·  Dicas-L