Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1

    Padrão Bonding Mikrotik perdendo pacote, 2 Enlaces no ar.

    Bom dia, pesquisei pesquisei mas não achei solução, estava com enlace saturado e resolvi subir outro e utilizar o Bonding, ate ai tudo bem só que em bancada (Rb´s interligada através de cabos) tudo funcionou lindo, porem quando ativei a rb entre os 2 enlaces o bonding ficou horrível, perdendo pacote, porem se eu deixar um ou outro enlace funciona normal, mas se ativar os 2 fica uma porcaria (os enlaces estão bem alinhados e configurados) fica como se estivesse em loop, alguém aqui tem bonding em produção? com enlaces em radio para me da uma dica, ficaria muito grato obrigado!.
    Última edição por isaquebrumel; 20-06-2017 às 13:58.

  2. #2

    Padrão Re: Bonding Mikrotik perdendo pacote, 2 Enlaces no ar.

    algum filho de Deus!!!???



  3. #3
    Moderador Avatar de Bruno
    Ingresso
    Nov 2002
    Localização
    Guarapuava-PR
    Posts
    4.167
    Posts de Blog
    1

    Padrão Re: Bonding Mikrotik perdendo pacote, 2 Enlaces no ar.

    Citação Postado originalmente por isaquebrumel Ver Post
    algum filho de Deus!!!???
    se vc não postar mais detalhes ninguém vai ter interesse em te ajudar
    como esta a configuração do seu lacp ?

  4. #4

    Padrão Re: Bonding Mikrotik perdendo pacote, 2 Enlaces no ar.

    Bonding é para agregar meios com as mesmas especificações de banda e latência. Dois enlaces de rádio em frequência aberta vão, muito provavelmente, ter latências variantes e algum nível de retransmissão. Isso faz com que pacotes de uma mesma conexão cheguem desordenados do outro lado.

    Se você conseguir fazer os dois enlances terem 100% de CCQ, travado, e latência constante e igual em nível de nanossegundos, deve funcionar bem.

    Porém, acho que esse problema ocorre mais quando você usa hashes de camada 2 e 3 apenas. Mude para hash de camada 3 e 4, se já não estiver assim, para garantir que os pacotes de uma mesma conexão passem sempre pelo mesmo enlace.

    Sem ter mais detalhes de como estão os enlaces e como configurou o bonding, essa é a única coisa que consigo elaborar agora. O que você pode tentar também é abandonar bonding e balancear a carga desses dois enlaces por ECMP, que me parece mais certo de sucesso.



  5. #5

    Padrão Re: Bonding Mikrotik perdendo pacote, 2 Enlaces no ar.

    name="bondingENLACE" mtu=1500 mac-address=4C:5E:0C:45:51:8A arp=enabled
    arp-timeout=auto slaves=ether2,ether3 mode=balance-rr primary=none
    link-monitoring=arp arp-interval=100ms arp-ip-targets=192.168.210.2
    mii-interval=100ms down-delay=0ms up-delay=0ms lacp-rate=30secs
    transmit-hash-policy=layer-2-and-3 min-links=0

    name="bridge1" mtu=auto actual-mtu=1500 l2mtu=1598 arp=enabled
    arp-timeout=auto mac-address=4C:5E:0C:45:51:89 protocol-mode=rstp
    priority=0x8000 auto-mac=yes admin-mac=00:00:00:00:00:00
    max-message-age=20s forward-delay=15s transmit-hold-count=6
    ageing-time=5m

    # ADDRESS NETWORK INTERFACE
    0 ;;; ACESSO AO BONDING
    192.168.210.1/24 192.168.210.0 bondingENLACE

    do outro lado esta do mesmo jeito so muda o ip para 192.168.210.1

  6. #6

    Padrão Re: Bonding Mikrotik perdendo pacote, 2 Enlaces no ar.

    Citação Postado originalmente por TsouzaR Ver Post
    Bonding é para agregar meios com as mesmas especificações de banda e latência. Dois enlaces de rádio em frequência aberta vão, muito provavelmente, ter latências variantes e algum nível de retransmissão. Isso faz com que pacotes de uma mesma conexão cheguem desordenados do outro lado.

    Se você conseguir fazer os dois enlances terem 100% de CCQ, travado, e latência constante e igual em nível de nanossegundos, deve funcionar bem.

    Porém, acho que esse problema ocorre mais quando você usa hashes de camada 2 e 3 apenas. Mude para hash de camada 3 e 4, se já não estiver assim, para garantir que os pacotes de uma mesma conexão passem sempre pelo mesmo enlace.

    Sem ter mais detalhes de como estão os enlaces e como configurou o bonding, essa é a única coisa que consigo elaborar agora. O que você pode tentar também é abandonar bonding e balancear a carga desses dois enlaces por ECMP, que me parece mais certo de sucesso.
    ainda nao testei camada 3 e 4, vou ver como se comporta, mesmo assim obrigado.



  7. #7

    Padrão Re: Bonding Mikrotik perdendo pacote, 2 Enlaces no ar.

    Olá amigo eu ja pensei em fazer isso porem se vc for pensar bem isso não irar funcionar por que se 1 dos enlace tiver uma perca de redimento ira atrapalhar o outro pois o booding não ira saber que tem 1 enlace mais fraco mais vou te passar umas soluções, oque você pode fazer é dividir a rede tipo escolher em vai passar por x antena e por y no meu caso eu fiz o seguinte recebia o link na ether1 e sai o link na ether 4 e 5 a ether 4 tinha o ip 10.0.0.1 e a ether 5 11.0.0.1 ai se eu quisesse passar pela ether4 é so botar o ip da ether 4 e pronto, outra solução é você simular 1 loadbalance nesse enlace

  8. #8

    Padrão Re: Bonding Mikrotik perdendo pacote, 2 Enlaces no ar.

    Ia sugerir um load balance mesmo. Acho mais simples de evitar BO

    Ainda pode colocar um como backup da outra



  9. #9

    Padrão Re: Bonding Mikrotik perdendo pacote, 2 Enlaces no ar.

    Você não deixou a interface de bonding e as interfaces participantes na bridge né?
    Fica somente o bonding na bridge em ambas as pontas.

  10. #10

    Padrão Re: Bonding Mikrotik perdendo pacote, 2 Enlaces no ar.

    Testa desabilitando o rtsp da bridge, deixando o protocol mode = none



  11. #11

    Padrão Re: Bonding Mikrotik perdendo pacote, 2 Enlaces no ar.

    Citação Postado originalmente por TsouzaR Ver Post
    Bonding é para agregar meios com as mesmas especificações de banda e latência. Dois enlaces de rádio em frequência aberta vão, muito provavelmente, ter latências variantes e algum nível de retransmissão. Isso faz com que pacotes de uma mesma conexão cheguem desordenados do outro lado.

    Se você conseguir fazer os dois enlances terem 100% de CCQ, travado, e latência constante e igual em nível de nanossegundos, deve funcionar bem.

    Porém, acho que esse problema ocorre mais quando você usa hashes de camada 2 e 3 apenas. Mude para hash de camada 3 e 4, se já não estiver assim, para garantir que os pacotes de uma mesma conexão passem sempre pelo mesmo enlace.

    Sem ter mais detalhes de como estão os enlaces e como configurou o bonding, essa é a única coisa que consigo elaborar agora. O que você pode tentar também é abandonar bonding e balancear a carga desses dois enlaces por ECMP, que me parece mais certo de sucesso.
    Como funciona o ECMP

  12. #12

    Padrão Re: Bonding Mikrotik perdendo pacote, 2 Enlaces no ar.




  13. #13

    Padrão Re: Bonding Mikrotik perdendo pacote, 2 Enlaces no ar.

    Citação Postado originalmente por klabundee Ver Post
    Você não deixou a interface de bonding e as interfaces participantes na bridge né?
    Fica somente o bonding na bridge em ambas as pontas.


    recebo o link na porta 1, 2 e 3 sao as interfaces participates, na bridge esta a porta 1 e bonding.

  14. #14

    Padrão Re: Bonding Mikrotik perdendo pacote, 2 Enlaces no ar.

    Citação Postado originalmente por rfm Ver Post
    Testa desabilitando o rtsp da bridge, deixando o protocol mode = none
    vou testar ja mando o feedback



  15. #15
    Moderador Avatar de Bruno
    Ingresso
    Nov 2002
    Localização
    Guarapuava-PR
    Posts
    4.167
    Posts de Blog
    1

    Padrão Re: Bonding Mikrotik perdendo pacote, 2 Enlaces no ar.

    vi que vc esta usando em modo balance-rr tu ja tentou mudar para xor ou tlb

    eu aki uso em balance-xor

  16. #16

    Padrão Re: Bonding Mikrotik perdendo pacote, 2 Enlaces no ar.

    Citação Postado originalmente por Bruno Ver Post
    vi que vc esta usando em modo balance-rr tu ja tentou mudar para xor ou tlb

    eu aki uso em balance-xor

    boa tarde bruno, tentei o ''xor'', mas sem sucesso, tem como vc postar suas configurações? teu bonding esta rodando com enlaces no radio 5.8?



  17. #17

    Padrão Re: Bonding Mikrotik perdendo pacote, 2 Enlaces no ar.

    @Bruno, aproveitando o tópico sobre o bonding, eu tenho uma dúvida que não ficou bem clara no manual do Mikrotik. E como nunca usei gostaria de saber.

    O bonding não soma os links só balanceia né? Ou soma? Por exemplo dois links de 10mega o cliente não vai atingir 20mega . Ou vai? Dia desses surgiu um pessoa falando e até postando print de Speetest e dizia que somava.

  18. #18
    Moderador Avatar de Bruno
    Ingresso
    Nov 2002
    Localização
    Guarapuava-PR
    Posts
    4.167
    Posts de Blog
    1

    Padrão Re: Bonding Mikrotik perdendo pacote, 2 Enlaces no ar.

    as conf são as mesma



  19. #19
    Moderador Avatar de Bruno
    Ingresso
    Nov 2002
    Localização
    Guarapuava-PR
    Posts
    4.167
    Posts de Blog
    1

    Padrão Re: Bonding Mikrotik perdendo pacote, 2 Enlaces no ar.

    Citação Postado originalmente por 1929 Ver Post
    @Bruno, aproveitando o tópico sobre o bonding, eu tenho uma dúvida que não ficou bem clara no manual do Mikrotik. E como nunca usei gostaria de saber.

    O bonding não soma os links só balanceia né? Ou soma? Por exemplo dois links de 10mega o cliente não vai atingir 20mega . Ou vai? Dia desses surgiu um pessoa falando e até postando print de Speetest e dizia que somava.
    ele tem o mesmo conceito do lacp do cisco que é agregação ele soma sim
    o bonding soma

  20. #20

    Padrão Re: Bonding Mikrotik perdendo pacote, 2 Enlaces no ar.

    Mas ele soma só esse intervalo @1929

    Dali para frente não soma, ou seja, os links internet recebidos continuam separados

    Essas somas de link que o pessoal posta só acredito nos casos de balance por conexão e usando download manager. Não sei como o speedtest funciona mas se soma, deve fragmentar em vários acessos. Tem de ver qual algoritmo de balance o cara usou.