+ Responder ao Tópico



  1. #1

    Padrão Squid3 + Sarg + Mikrotik

    Ola galera, eu estou quebrando a cabeça para fazer isso. Vamos ver se vcs conseguem me ajudar.

    minha topologia é assim, como na imagem abaixo.

    Clique na imagem para uma versão maior

Nome:	         topologia.jpg
Visualizações:	155
Tamanho: 	42,1 KB
ID:      	67246

    Agora eu consegui colocar instalar o squid3 + sarg

    nessas configurações do squid.conf

    #------------------------------------------------------------------
    acl all src 0.0.0.0/0.0.0.0
    acl manager proto cache_object
    acl redelocal src 193.168.104.0/30
    acl localhost src 127.0.0.1/32
    acl clientes src 192.168.180.0/22
    #------------------------------------------------------------------
    acl SSL_ports port 443 # https
    acl SSL_ports port 563 # snews
    acl SSL_ports port 873 # rsync
    acl Safe_ports port 80 # http
    acl Safe_ports port 21 # ftp
    acl Safe_ports port 443 # https
    acl Safe_ports port 70 # gopher
    acl Safe_ports port 210 # wais
    acl Safe_ports port 1025-65535 # unregistered ports
    acl Safe_ports port 280 # http-mgmt
    acl Safe_ports port 488 # gss-http
    acl Safe_ports port 591 # filemaker
    acl Safe_ports port 777 # multiling http
    acl Safe_ports port 631 # cups
    acl Safe_ports port 873 # rsync
    acl Safe_ports port 901 # SWAT
    acl Safe_ports port 5000 # VPN
    #------------------------------------------------------------------
    acl CONNECT method CONNECT
    acl purge method PURGE
    #------------------------------------------------------------------
    http_access allow manager localhost
    http_access deny manager
    http_access allow purge localhost
    http_access deny purge
    #------------------------------------------------------------------
    http_access deny !Safe_ports
    http_access deny CONNECT !SSL_ports
    #------------------------------------------------------------------
    http_access allow localhost
    http_access allow redelocal
    http_access allow clientes
    #------------------------------------------------------------------
    http_access deny all
    #------------------------------------------------------------------
    http_port 3128 intercept
    #------------------------------------------------------------------
    cache_mem 128 MB
    #------------------------------------------------------------------
    maximum_object_size_in_memory 512 KB
    #------------------------------------------------------------------
    memory_replacement_policy heap GDSF
    #------------------------------------------------------------------
    cache_replacement_policy heap LFUDA
    #------------------------------------------------------------------
    cache_dir aufs /var/spool/squid3 20048 16 256
    #------------------------------------------------------------------
    minimum_object_size 0 KB
    maximum_object_size 4 GB
    #------------------------------------------------------------------
    cache_swap_low 70
    cache_swap_high 80
    #------------------------------------------------------------------
    access_log /var/log/squid3/access.log squid
    #------------------------------------------------------------------
    cache_store_log none
    #------------------------------------------------------------------
    mime_table /usr/share/squid3/mime.conf
    #------------------------------------------------------------------
    cache_log /var/log/squid3/cache.log
    #------------------------------------------------------------------
    coredump_dir /var/spool/squid3
    #------------------------------------------------------------------
    refresh_pattern ^ftp: 1440 20% 10080
    refresh_pattern ^gopher: 1440 0% 1440
    refresh_pattern -i (/cgi-bin/|\?) 0 0% 0
    refresh_pattern (Release|Packages(.gz)*)$ 0 20% 2880
    refresh_pattern . 0 20% 4320
    #------------------------------------------------------------------
    cache_mgr [email protected]
    #------------------------------------------------------------------
    visible_hostname linux
    #------------------------------------------------------------------
    detect_broken_pconn on
    #------------------------------------------------------------------
    global_internal_static on
    #------------------------------------------------------------------
    error_directory /usr/share/squid3/errors/Portuguese
    #------------------------------------------------------------------
    memory_pools on
    memory_pools_limit 32 MB
    #------------------------------------------------------------------
    pipeline_prefetch on
    #------------------------------------------------------------------

    Agora as regras no mikrotik

    /ip firewall nat
    add action=accept chain=dstnat disabled=no dst-address-list=!fora_proxy \
    dst-port=80 protocol=tcp
    add action=dst-nat chain=dstnat disabled=no dst-address-list=!fora_proxy \
    dst-port=80 protocol=tcp src-address=192.168.180.0/22 to-addresses=\
    193.168.104.2 to-ports=3128
    add action=masquerade chain=srcnat comment="MASCARADE DO LINK" disabled=no




    /ip firewall address-list
    add address=23.64.0.0/14 comment=Akamai disabled=no list=fora_proxy
    add address=192.168.180.0/22 disabled=no list=clientes

    Na tela do /var/log/squid3/access.log

    Clique na imagem para uma versão maior

Nome:	         access_log.jpg
Visualizações:	98
Tamanho: 	165,9 KB
ID:      	67247

    porem não da os ips do clientes, como faço para dar os ips do clientes?

    Desde ja agradeço a ajuda.

  2. #2
    Moderador Avatar de minelli
    Ingresso
    Aug 2006
    Localização
    Pres. Venceslau - SP | Pres. Prudente - SP
    Posts
    1.410
    Posts de Blog
    10

    Padrão Re: Squid3 + Sarg + Mikrotik

    Bom dia, corrige sua regra de NAT.



  3. #3

    Padrão Re: Squid3 + Sarg + Mikrotik

    Para qual regra?

  4. #4
    Moderador Avatar de minelli
    Ingresso
    Aug 2006
    Localização
    Pres. Venceslau - SP | Pres. Prudente - SP
    Posts
    1.410
    Posts de Blog
    10

    Padrão Re: Squid3 + Sarg + Mikrotik

    Vc deve estar fazendo NAT para a classe de ip. Faça o NAT chaim: src-nat, out-intercafe: interface link, action: masquerade.



  5. #5

    Padrão Re: Squid3 + Sarg + Mikrotik

    Eu fiz quando eu habilito assim, os pessoas ficam sem internet

  6. #6

    Padrão Re: Squid3 + Sarg + Mikrotik

    apareceu os IP como na imagem abaixo, so que os clientes ficam sem internet

    Clique na imagem para uma versão maior

Nome:	         sarg.jpg
Visualizações:	106
Tamanho: 	182,0 KB
ID:      	67253



  7. #7

    Padrão Re: Squid3 + Sarg + Mikrotik

    Citação Postado originalmente por minelli Ver Post
    Vc deve estar fazendo NAT para a classe de ip. Faça o NAT chaim: src-nat, out-intercafe: interface link, action: masquerade.
    Se eu coloco essa regra ai, ate aparece os ip porem os clientes ficam sem internet e o proxy tbm fica sem, ele não pinga para fora.

  8. #8

    Padrão Re: Squid3 + Sarg + Mikrotik

    Obrigado @minelli ja consegui fazer funcionar.