Página 2 de 2 PrimeiroPrimeiro 12
+ Responder ao Tópico



  1. #7

    Padrão Re: prolongar o tempo em que o cliente fica conectado

    Citação Postado originalmente por brunovalmorbida Ver Post
    Isso por exemplo se a luz fica 10 segundos fora, coloca o keepalive de 30s, aí mesmo sem luz o PPPoe ficara conectado durante 30 segundos, ele não ira navegar, mas não precisara ele consultar o mk-auth.
    Cara não foi isso que o amigo pediu... Ele pediu se mesmo que CAIR a conexão, tem como reconectar sem ter conectividade com o radius... Vamos tentar ler com calma pra não falar besteira...
    @gandhi o único meio seria ter os logins dentro da rb, eu particularmente não sei se o mk-auth faz um "Export" dos logins... Talvez algum colega com mais conhecimento no mk-auth possa ajudar...

    E novamente, por favor, ler antes de falar, uma boa observação e chegaremos a conclusão que temos duas orelhas e uma boca...

  2. #8

    Padrão Re: prolongar o tempo em que o cliente fica conectado

    Citação Postado originalmente por brunovalmorbida Ver Post
    Bom dia, a solução é você ir em PPP, e no seu PPPoE Server tem a opção "Keepalive Timeout", essa opção diz o tempo em segundos que o PPPoE permanece conectado mesmo sem estar pingando/respondendo, aí você coloca o tempo que você desejar.
    Mas no caso dele o servidor desligou... por cerca de 30 minutos. Então não poderia ninguém navegar mesmo. Daí não seria o caso de cliente voltar a reconectar automaticamente quando o servidor voltar?



  3. #9

    Padrão Re: prolongar o tempo em que o cliente fica conectado

    Seria isso mesmo @1929 e @andrecarlim, pois la caiu a energia e logo voltou e aqui ficou na média 30 minutos sem energia, deixando o cliente sem navegação, sendo assim, então não tem o que fazer?? pois acabei de comprar esse nobreak, e não deveria de segurar o servidor ligado??? gastei 1200 reais no no-break, e fica sendo usado 25% da capacidade dele, não deveria de ser problema.. mas obrigado mesmo assim, creio que não terá solução então nessa parte, a não ser comprar um nobreak online senoidal.

  4. #10

    Padrão Re: prolongar o tempo em que o cliente fica conectado

    Bom dia, no caso do export, tem a opção sim.
    http://www.mk-auth.com.br/tool_fetch/pppoe.txt
    porem ele tem que configurar de acordo com o mk-auth dele substituindo onde está em negrito pelo ip e key:

    /system scheduler add interval=45m name=ler_pppoe on-event=":execute script=ler_pppoe;"
    /system script add name=ler_pppoe source="#===============================\r\
    \n:global IPMKAUTH "172.31.255.2"; \r\
    \n:global KEY "key_api"; \r\
    \n:global RAMAL "todos";\r\
    \n:global done "";\r\
    \n/tool fetch mode=http url="https://\$IPMKAUTH/mkt/pppoe.php\\\?key=\$KEY&ramal=\$RAMAL" src-path=mkt_pppoe.php dst-path=mkt_pppoe.rsc;\r\
    \n:set done "true";\r\
    \n\r\
    \n:if ( [/file find name=mkt_pppoe.rsc] != "" ) do={\r\
    \n :log warning "Importando PPPoE";\r\
    \n /import mkt_pppoe.rsc;\r\
    \n /file remove mkt_pppoe.rsc;\r\
    \n}\r\
    \n"

    assim o mk-auth exporta os usuários de 45 em 45 minutos para o mikrotik, caso o radius caia os clientes estarão no mikrotik.