+ Responder ao Tópico



  1. #1

    Padrão Dúvida queue?

    Pessoal uma dúvida...Tem como eu habilitar uma regra da queue tree por 30 segundos e depois ela se desabilitar sozinha, para depois de um tempo pré-definido ela ligar novamente e depois de trinta segundos desligar novamente e assim por diante?


    Obrigado a todos...

  2. #2



  3. #3

    Padrão

    Citação Postado originalmente por daniloacr Ver Post
    é so usar as tarefas agendadas


    Olá camarada!!!


    Isso eu sei, que se pode agendar as tarefas, mas você sabe como fazer isso?

  4. #4

    Padrão

    entao vamos lá passo a passo!

    primeiro acesse o menu "system / scripts"
    adicione o script responsavel por abilitar a tree, aqui darei nome de tree_on



    por incrivel que pareça eu estava aki no horario de almoço e meu irmão chegou me chamando, acabou o meu horario de almoço e já estou atrasado se eu tiver tempo la na loja eu completo pra vc,

    desculpa ai qualquer coisa.



  5. #5

    Padrão

    Alguém poderia preparar um script para mim que habilite uma regra da queue-tree por 30 segundos e desligue por 5 minutos, depois volte a ligar por 30 segundos e desligar por 5 minutos, isso contínuamente, ou seja todos os dias?

  6. #6

    Padrão

    estou curioso em relação à utilidade da regra. O que você quer fazer com esses scripts e agendamentos?



  7. #7

    Padrão

    Citação Postado originalmente por Gosulator Ver Post
    estou curioso em relação à utilidade da regra. O que você quer fazer com esses scripts e agendamentos?
    Agora não!!! (eheheh) Se der certo garanto que repassarei a todos no forum, foi uma idéia que tive, só preciso do script.


    Abração.

  8. #8

    Padrão

    entao amigo agora cheguei em casa e posso continuar vamos la do começo!

    primeiro acesse o menu "system / scripts"
    adicione o script responsavel por habilitar a tree, aqui darei nome de tree_on

    *** codigo do tree_on ***
    /system script add name="tree_on" source="/queue tree { enable \[find name=nome_do_tree\] }" \
    policy=ftp,reboot,read,write,policy,test,winbox,password


    agora adicione o script responsavel por desabilitar a tree, aqui darei nome de tree_off

    *** codigo do tree_off ***
    /system script add name="tree_off" source="/queue tree { disable \[find name=nome_do_tree\] }" \
    policy=ftp,reboot,read,write,policy,test,winbox,password



    agora é so fazer o agendamento!

    os agendamentos terá o nome de Habilita_tree e Desbilita_tree



    ***codigos dos agendamentos***

    /system scheduler add name="Habilita_tree" on-event=tree_on start-date=dec/14/2007 start-time=00:00:00 interval=5m comment="" disabled=no

    /system scheduler add name="Desbilita_tree" on-event=tree_off start-date=dec/14/2007 start-time=00:00:00 interval=5m30s comment="" \
    disabled=no

    se for isso que vc queria espero ter ajudado!



  9. #9

    Padrão

    Eu usava aki no provedor pros clientes que consumiam banda full continuamente eu criava duas queues com o mesmo ip mas com velocidades distinttas, ex: 600k e 300k, tinha cliente que consumia os 600k o dia inteiro baixando trecos, dai criei uma regra de de meia em meia hora desabilitava a de 600 e habilitava a de 300, mas ficou feio pq tinha muitos clientes que consumia assim dai meu mikrotik virou uma zona.

  10. #10

    Padrão

    Citação Postado originalmente por daniloacr Ver Post
    entao amigo agora cheguei em casa e posso continuar vamos la do começo!

    primeiro acesse o menu "system / scripts"
    adicione o script responsavel por habilitar a tree, aqui darei nome de tree_on

    *** codigo do tree_on ***
    /system script add name="tree_on" source="/queue tree { enable \[find name=nome_do_tree\] }" \
    policy=ftp,reboot,read,write,policy,test,winbox,password


    agora adicione o script responsavel por desabilitar a tree, aqui darei nome de tree_off

    *** codigo do tree_off ***
    /system script add name="tree_off" source="/queue tree { disable \[find name=nome_do_tree\] }" \
    policy=ftp,reboot,read,write,policy,test,winbox,password



    agora é so fazer o agendamento!

    os agendamentos terá o nome de Habilita_tree e Desbilita_tree



    ***codigos dos agendamentos***

    /system scheduler add name="Habilita_tree" on-event=tree_on start-date=dec/14/2007 start-time=00:00:00 interval=5m comment="" disabled=no

    /system scheduler add name="Desbilita_tree" on-event=tree_off start-date=dec/14/2007 start-time=00:00:00 interval=5m30s comment="" \
    disabled=no

    se for isso que vc queria espero ter ajudado!


    Ajudou e muito colega...Muito obrigado!



  11. #11

    Padrão

    Citação Postado originalmente por daniloacr Ver Post
    entao amigo agora cheguei em casa e posso continuar vamos la do começo!

    primeiro acesse o menu "system / scripts"
    adicione o script responsavel por habilitar a tree, aqui darei nome de tree_on

    *** codigo do tree_on ***
    /system script add name="tree_on" source="/queue tree { enable \[find name=nome_do_tree\] }" \
    policy=ftp,reboot,read,write,policy,test,winbox,password


    agora adicione o script responsavel por desabilitar a tree, aqui darei nome de tree_off

    *** codigo do tree_off ***
    /system script add name="tree_off" source="/queue tree { disable \[find name=nome_do_tree\] }" \
    policy=ftp,reboot,read,write,policy,test,winbox,password



    agora é so fazer o agendamento!

    os agendamentos terá o nome de Habilita_tree e Desbilita_tree



    ***codigos dos agendamentos***

    /system scheduler add name="Habilita_tree" on-event=tree_on start-date=dec/14/2007 start-time=00:00:00 interval=5m comment="" disabled=no

    /system scheduler add name="Desbilita_tree" on-event=tree_off start-date=dec/14/2007 start-time=00:00:00 interval=5m30s comment="" \
    disabled=no

    se for isso que vc queria espero ter ajudado!


    Danilo a regra funcionou perfeitamente, já perguntei a alguns clientes depois de uma hora que a regra está funcionando e me responderam que a conexão está ótima e que nunca esteve tão boa, vou testar mais um pouco e deppois postar aqui para os colegas fazerem também, mas ainda tenho uma dúvida...


    Está faltando um sincronismo entre o (on e o off) como faço para sincronizar a partida e o desligamento? Terminei deixando o off com 30 segundos para que ele desligue exatamente 30 segundos depois...tem alguma sugestão?


    Abração e obrigado mais uma vez.

  12. #12

    Padrão

    vc pode criar uma regra pra desabilitar um e habilitar o outro e assim sucessivamente assim quando a regra habilitar um vai comecar a contar os 5 min pra desabilitar a outra e habilitar essa novamente.



  13. #13

    Padrão

    Citação Postado originalmente por admskill Ver Post
    vc pode criar uma regra pra desabilitar um e habilitar o outro e assim sucessivamente assim quando a regra habilitar um vai comecar a contar os 5 min pra desabilitar a outra e habilitar essa novamente.
    Desculpa camarada, mas não compreendi o que você quiz me passar...da pra exemplificar mais um pouco ?




    Mas mesmo assim obrigado.

  14. #14

    Padrão

    Citação Postado originalmente por Roberto21 Ver Post
    Desculpa camarada, mas não compreendi o que você quiz me passar...da pra exemplificar mais um pouco ?




    Mas mesmo assim obrigado.
    me add no msn que assim que eu chegar em casa em monto a regra e passo ela pra vc e ponho aqui no fórum !



    [email protected]