Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. Olá pessoal!!!

    Hoje estou dando uma contribuição ao forum de uma idéia que tive e apliquei em minha rede wireless e deu certo, é o seguinte:


    Quando configuramos na queue simple a velocidade de nossoa clientes também configuramos o bust limit para dar uma incrementada na velocidade de conexão de nossos clientes principalmente aqueles que gostam de todo tempo ficar medindo a velocidade de conexão em sites como rjnet.

    Então o que bolei foi um bust limit mas não para a velocidade individual dos clientes e sim para o proxy.

    marquei a conexão do proxy no mangle, em ''output'' e criei uma queue tree com prioridade 1 para essa marcação, com a ajuda de um colega do forum fiz um script para que essa regra seja ativada e desativada a cada período determinado, então no meu caso a cada 5 minutos a regra é ativada por 39 segundos e tudo que está no cache sai sem limite de conexão para os clientes.

    Agora você me perguntaria...para que serve isso?

    Imagine a situação em que seu cliente está baixando um vídeo que já está em cache, mas ele está baixando na velocidade de sua conexão, vou colocar aqui que você vende 100K para seus clientes então a taxa de download dele será em média 12k, se o vídeo tiver dez megas ele certamente passará mais de dez minutos baixando esse vídeo o que causará um trafego constante nos seus ap's, dessa forma se dez clientes seus estiverem fazendo esse tipo de download mesmo que esteja em cache ocupará por um certo período a banda do seu ap.

    Então fazendo essa regra de cinco em cinco minutos é liberado por 39 segundos tudo que está em cache e está sendo baixado por seus clientes, liberando assim os ap's por que o download se fará imediatamente, certo que essa regra também vai liberar o link mas é só por alguns segundos e você ganhará em desempenho na rede por que limpará o excesso de tráfego nos ap's.

    Depois dos 39 segundos seus ap's estaram limpos de tráfego como se fosse uma conexão com poucos clientes conectados.Alguns clientes de vocês já devem ter falado que de manhã ou de madrugada a conexão é melhor, e isso não se trata do seu link e sim do tráfego nos seus ap's, então de cinco em cinco minutos limpando seus ap's sua rede ficará sempre livre do excesso de downloads.

    39 segundos foi o tempo ideal para mim, esse tempo é aleatório, dificilmente da os 39 segundos de liberação do cache por que a regra é feita de cinco em cinco minutos, mas o desligamento é feito de 39 em 39 segundos, então até chegar os cinco minutos novamente ele já aplicou a regra dos 39 segundos várias vezes, então, as vezes da 20 segundos outras 30, mas o importante é que libera o trafego.

    As regras são feitas no mangle,firewall filter, queue tree, scripts, scheduler.

    Uma breve explicação sobre as queuetree....

    A queuetreee é um filtro que o MK executa antes da queue simple, então se você define por exemplo uma velocidade de 200k para https, toda a sua rede dividirá 200k de https, então se você define que a queuetree não tem limite de velocidade a conexão que está marcada no mangle e adicionada a queuetree passará sem limite de velocidade antes que as regras de queue simple (limite de velocidade do cliente)sejam executadas, dessa forma a regra funciona perfeitamente.

    Outro detalhe é que se deve deixar a conexão da porta do proxy sem limite de conexões, fazendo uma exclusão na regra de limite de conexões.

    Bom, postei a idéia que tive aqui para que vocês analizem e digam o que acham e se querem implantar para teste nos seus servidores, se acharem boa a idéia deixem seus comentários que estou saindo para o almoço e logo mais a tarde postarei as regras aqui para todos implantarem.


    Bom domingo a todos.

  2. Parabens pela iniciativa, vou incrementar isso no meu server e vou testar hoje a noite



  3. Boa idéia, agora é ver e sentir os resultados.
    Vou testar tbm ....

  4. ip firewall mangle
    add chain=output src-address=172.128.254.0/24 protocol=tcp src-port=3128 \
    action=mark-connection new-connection-mark=PROXY passthrough=yes \
    comment="PROXY" disabled=no
    add chain=output connection-mark=PROXY action=mark-packet \
    new-packet-mark=semlimite passthrough=yes comment="" disabled=no

    system script
    add name="tree_on" source="/queue tree { enable \[find name=Teste_Proxyfull\] \
    }" policy=ftp,reboot,read,write,policy,test,winbox, password
    add name="tree_off" source="/queue tree { disable \[find \
    name=Teste_Proxyfull\] }" \
    policy=ftp,reboot,read,write,policy,test,winbox,password

    queue tree
    add name="Teste_Proxyfull" parent=global-out packet-mark=semlimite limit-at=0 \
    queue=default priority=1 max-limit=0 burst-limit=0 burst-threshold=0 \
    burst-time=0s disabled=yes

    system scheduler
    add name="Habilita_tree" on-event=tree_on start-date=dec/14/2007 \
    start-time=00:00:00 interval=4m comment="" disabled=no
    add name="JDesbilita_tree" on-event=tree_off start-date=dec/14/2007 \
    start-time=00:00:00 interval=39s comment="" disabled=no

    ip firewall filter
    add chain=forward src-address=172.128.254.0/24 protocol=tcp tcp-flags=syn \
    packet-mark=!semlimite connection-limit=20,32 action=drop \
    comment="LIMITANDO A 20 O NÚMERO DE CONEXÕES" disabled=no


    Não esqueçam na regra do mangle e do firewall filter mudar o range de ip's para o de suas redes.

    Funcioando perfeitamente como funciona para mim só precisa agradeçer (eheheh)


    Abração a todos e espero ter ajudado a muitos.


    Roberto.
    pirata21ml@hotmail.com
    Última edição por Roberto21; 28-12-2007 às 18:46.



  5. Pessoal...


    Quem aplicou a regra favor depois de algum tempo relatar o funcionamento, poderemos até aperfeiçoar essa regra de acordo com o relato de cada um, por exemplo:

    Agora a noite (domingo) todos em casa e muita gente conectado e navegando, cada vez que a regra era habilitada em média 3 megas de arquivos estava sendo liberado para os clientes, inclusive tive que baixar o tempo para 3 em 3 minutos para poder dar conta e o trafego ir diminuindo.Depois de umas 5 vezes em 3 minutos o tráfego começou a ficar normal e os clientes ''verdinhos verdinhos na queue simple (rssssss).


    Abraço a todos e vamos comentar os resultados.






Tópicos Similares

  1. Mandar e-mail para todos os usuarios do sendmail
    Por dark_exs no fórum Servidores de Rede
    Respostas: 2
    Último Post: 08-04-2004, 14:18
  2. Duvida interessante para todos...
    Por Danilo_Montagna no fórum Servidores de Rede
    Respostas: 8
    Último Post: 15-11-2003, 14:17
  3. Desafio para Todos Squid / FTP !!!
    Por Danielvb no fórum Servidores de Rede
    Respostas: 139
    Último Post: 17-03-2003, 14:05
  4. Senha para todos!!!
    Por MarcusMaciel no fórum Servidores de Rede
    Respostas: 0
    Último Post: 30-01-2003, 11:40
  5. Para todos... As de muitas estrelinhas... rs!
    Por JLucas no fórum Servidores de Rede
    Respostas: 8
    Último Post: 27-01-2003, 11:24

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L