+ Responder ao Tópico



  1. tenho em minha empresa o seguinte problema.

    tenho um servidor que receber dois links.

    eth0 201.xxx.xxx.xxx embratel
    eth1 189.xxx.xxx.xxx virtua

    o link da embratel é usado para hospedagem das páginas, e o da virtua seria para a navegação.

    minha configuração nesse momento é a seguinte:

    eth0 201.xxx.xxx.1
    default gw 201.xxx.xxx.254
    eth1 189.xxx.xxx.150

    levanto duas aliases na eth0

    eth0:0 10.10.10.254
    eth0:1 192.168.145.254

    eu preciso que essas redes saiam pelo link da virtua

    eu uso a seguinte regra

    iptables -t nat -A POSTROUTING -s 10.10.10.0/24 -d 0/0 -j SNAT --to 189.xxx.xxx.150
    o mesmo para a outra rede, mas ela não funciona pelo seguinte

    coloco em uma máquina o ip 10.10.10.1 e o gw 10.10.10.254 e dou um tracert e ele sai pela rede da embratel não da virtua.
    alguem tem uma idéia do que eu faço?

    obrigado!

  2. voce precisa criar 2 tabelas de roteamento 1 para cada link.. apos isso, vc precisa marcar os pacotes que vao sair pelo segundo link ...

    www.lartc.org tem como fazer passo a passo



  3. obrigado pela dica kra, mas esse link não abre, vou tentar fazer isso com o iproute2 e depois posto aqui o resultado.

    obrigadão!






Tópicos Similares

  1. Problema com roteamento IP
    Por Jose Carlos no fórum Servidores de Rede
    Respostas: 3
    Último Post: 23-06-2004, 09:38
  2. Problemas com Roteamento / Disponibilização de Internet
    Por d00m no fórum Servidores de Rede
    Respostas: 7
    Último Post: 01-06-2004, 17:54
  3. Possível problema com roteamento em um gateway
    Por André L. Melim no fórum Servidores de Rede
    Respostas: 9
    Último Post: 17-05-2004, 10:54
  4. Problemas com roteamento e ftp.
    Por no fórum Servidores de Rede
    Respostas: 1
    Último Post: 22-04-2003, 11:39
  5. IPTABLES - Problemas com Roteamento de Pacotes
    Por ATNunes no fórum Servidores de Rede
    Respostas: 0
    Último Post: 12-12-2002, 15:14

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L