Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. Analisem o mistério comigo!
    Tenho uma nat e coloco essa regra pra redirecionar a porta 80 pra 8012 (squid)
    e simplesmente não funciona!!!

    iptables -t nat -A PREROUTING -i eth0 -p tcp --dport 80 -j REDIRECT --to-port 8012

    ele não redireciona as portas!!! e mais do que isso!!! se eu do um drop na porta 80 pode ser das duas interfaces juntas a eth0 e a eth1 o user continua navegando!!!

    testei o postrouting e tá 100% mais o prerouting não tem cristo.. analisei com o tcpdump ele ele nao redireciona!!! alguma ideia?!




    wireless-2:/proc/sys/net/ipv4# iptables -t nat -L
    Chain PREROUTING (policy ACCEPT)
    target prot opt source destination
    REDIRECT tcp -- anywhere anywhere tcp dpt:www redir ports 8012

    Chain POSTROUTING (policy ACCEPT)
    target prot opt source destination
    MASQUERADE all -- 10.80.0.0/24 anywhere
    MASQUERADE all -- anywhere 10.80.0.0/24

    Chain OUTPUT (policy ACCEPT)
    target prot opt source destination

  2. cara...

    experimente fazer assim:

    Código :
    iptables -t nat -I PREROUTING -i eth0 -d 0/0 -p tcp --dport 80 -j REDIRECT --to 8012

    depois fique observando os logs do squid..



  3. Luciano obrigado pela resposta..

    bem ontem pedi ajuda pra um irmão meu... o navarini que faz uns artigos aqui na under as vezes ele acessou a maquina e fez funcionar.. só retirou a especificação de interface

    tipo de:
    iptables -t nat -A PREROUTING -i eth0 -p tcp --dport 80 -j REDIRECT --to-port 8012

    para:
    iptables -t nat -A PREROUTING -p tcp --dport 80 -j REDIRECT --to-port 8012

    não entendi muito a lógica da coisa pois essa maquina eh identica a uma outra inclusive em suas configurações que utiliza a regra de cima com sucesso, e nessa maquina nova não tinha jeito quando se especificava uma interface... locura =)

  4. então estava especificando a interface errada



  5. nao nao estava testei com ambas

    é inexplicável mesmo







Tópicos Similares

  1. Respostas: 5
    Último Post: 23-04-2009, 15:36
  2. PREROUTING não funciona
    Por cag no fórum Servidores de Rede
    Respostas: 15
    Último Post: 19-09-2005, 11:20
  3. Squid Transparente + Iptables = msn não funciona !!
    Por fotg no fórum Servidores de Rede
    Respostas: 5
    Último Post: 30-01-2005, 05:07
  4. FTP não funciona (IPTABLES + SQUID)
    Por Kreulis no fórum Servidores de Rede
    Respostas: 5
    Último Post: 19-04-2004, 16:27
  5. Iptables não funciona
    Por no fórum Servidores de Rede
    Respostas: 0
    Último Post: 08-08-2003, 06:45

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L