Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1
    Moderador Avatar de minelli
    Ingresso
    Aug 2006
    Localização
    Pres. Venceslau - SP | Pres. Prudente - SP
    Posts
    1.410
    Posts de Blog
    10

    Padrão Ddns Mk 2.9.27

    Alguem tem um script DDNS que realmente funcione???

  2. #2
    Moderador Avatar de minelli
    Ingresso
    Aug 2006
    Localização
    Pres. Venceslau - SP | Pres. Prudente - SP
    Posts
    1.410
    Posts de Blog
    10

    Padrão Script

    Vi aqui no forum um script mas o problema que ele funciona só quando quer, vou posta-lo aqui.

    :log info "DDNS: Begin"
    : global ddns-user "usuario"
    :global ddns-pass "senha"
    :global ddns-host "endereço DDNS escolhido"
    :global ddns-interface "Nome da interface de saida - Link"
    :global ddns-ip [ /ip address get [/ip address find interface=$ddns-interface] address ]
    :if ([ :typeof $ddns-lastip ] = nil ) do={ :global ddns-lastip 0.0.0.0/0 }
    :if ([ :typeof $ddns-ip ] = nil ) do={
    :log info ("DDNS: No ip address present on " . $ddns-interface . ", please check.")
    } else={
    :if ($ddns-ip != $ddns-lastip) do={
    :log info "DDNS: Sending UPDATE!"
    :log info [ /tool dns-update name=$ddns-host address=[ick $ddns-ip 0 [:find $ddns-ip "/"] ] key-name=$ddns-user key=$ddns-pass ]
    :global ddns-lastip $ddns-ip
    } else={
    :log info "DDNS: No change"
    }
    }
    :log info "DDNS: End"



  3. #3
    Moderador Avatar de minelli
    Ingresso
    Aug 2006
    Localização
    Pres. Venceslau - SP | Pres. Prudente - SP
    Posts
    1.410
    Posts de Blog
    10

    Padrão DDNS Script

    Pessoal acho que esse deu certo pelo menos atualiza de 1 em 1 minuto sem problemas e atualiza todas as vezes.
    Lembrem este script é para o changeip.com não sei se funciona com outro, tb tem de alterar as variaveis :
    ddns-user ; ddns-pass ; ddns-interface ; ddns-host

    :log info "DDNS Begin"
    :global ddns-user "usuario"
    :global ddns-pass "senha"
    :global ddns-interface "Interface Link"
    :global ddns-host "seuid.changeip.org"
    :global ddns-ip [/ip address get [/ip address find interface=$ddns-interface] address]
    :if {[ :typeof $ddns-lastip] = nil } do={ :global ddns-lastip 0.0.0.0/0 }
    :if {[ :typeof $ddns-ip] = nil} do={
    :log info "DDNS: No addres present on your interface, plesae check."
    } else={
    # :if ($ddns-ip != $ddns-lastip) do={
    :log info "DDNS: Sending update!"
    :log info [/tool dns-update name=$ddns-host address=[ick $ddns-ip 0 [:find $ddns-ip "/"] ] key-name=$ddns-user key=$ddns-pass ]
    # :global ddns-lastip $ddns-ip
    # } else={
    # :log info ("DDNS: No change.")
    # }
    }
    :log info ("DDNS: End.")

  4. #4
    Patrocinador Avatar de edcomrocha
    Ingresso
    Aug 2007
    Localização
    São Paulo, Brazil, Brazil
    Posts
    840

    Thumbs up

    Citação Postado originalmente por minelli Ver Post
    Pessoal acho que esse deu certo pelo menos atualiza de 1 em 1 minuto sem problemas e atualiza todas as vezes.
    Lembrem este script é para o changeip.com não sei se funciona com outro, tb tem de alterar as variaveis :
    ddns-user ; ddns-pass ; ddns-interface ; ddns-host

    :log info "DDNS Begin"
    :global ddns-user "usuario"
    :global ddns-pass "senha"
    :global ddns-interface "Interface Link"
    :global ddns-host "seuid.changeip.org"
    :global ddns-ip [/ip address get [/ip address find interface=$ddns-interface] address]
    :if {[ :typeof $ddns-lastip] = nil } do={ :global ddns-lastip 0.0.0.0/0 }
    :if {[ :typeof $ddns-ip] = nil} do={
    :log info "DDNS: No addres present on your interface, plesae check."
    } else={
    # :if ($ddns-ip != $ddns-lastip) do={
    :log info "DDNS: Sending update!"
    :log info [/tool dns-update name=$ddns-host address=[ick $ddns-ip 0 [:find $ddns-ip "/"] ] key-name=$ddns-user key=$ddns-pass ]
    # :global ddns-lastip $ddns-ip
    # } else={
    # :log info ("DDNS: No change.")
    # }
    }
    :log info ("DDNS: End.")

    esse script funciona legal estou usando ele faz mais de um mes e nunca falhou



  5. #5
    Moderador Avatar de minelli
    Ingresso
    Aug 2006
    Localização
    Pres. Venceslau - SP | Pres. Prudente - SP
    Posts
    1.410
    Posts de Blog
    10

    Padrão Script

    Mas só pra saber vc consegue sempre acessar o mk pelo ddns fora da rede tipo, teste.changeip.org ou vc entra no site pra ver o ip e entra pelo ip. Pq aqui nunca consigo entrar pelo ddns, mas pelo ip blz.

  6. #6
    Patrocinador Avatar de edcomrocha
    Ingresso
    Aug 2007
    Localização
    São Paulo, Brazil, Brazil
    Posts
    840

    Thumbs up

    Citação Postado originalmente por minelli Ver Post
    Mas só pra saber vc consegue sempre acessar o mk pelo ddns fora da rede tipo, teste.changeip.org ou vc entra no site pra ver o ip e entra pelo ip. Pq aqui nunca consigo entrar pelo ddns, mas pelo ip blz.

    Sim, tanto me conecto no mk fora da rede pelo winbox como pelo navegador,

    da uma olhada pra vc ver

    ctinformatica.changeip.net

    user: teste
    senha: teste