+ Responder ao Tópico



  1. Caros amigos!

    Depois de tentar incasavelmente criar uma regra para fazer um backup do mikrotik para ser enviado por e-mail e não ter tido sucesso, testando vários provedores como hotmail, brturbo, gmail e cybermais (provedor local de fox do iguaçu), resolvi partir pra outro lado.
    Criei um esqueminha para fazer o backup via FTP simples e rápido onde depois de pronto vc não vai precisar fazer nada pois o backup sempre irá pro seu HD
    Vale lembrar tb que vi outros tópicos tb ensinando fazer este tipo de backup, onde tb não consegui colocar pra funfar, entao quebrei a cabeça por algumas horas testei alguns programas adicionei algumas informaçoes úteis de outros colegas que postaram sobre o mesmo assunto e criei este tutorial.

    PS: Agradeço os nosso amigo RPSILVA e JOSEVALDO pois deles tirei algumas informaçoes que adicionei neste meu tutorial.

    1ª PARTE

    entre no winbox

    copie e cole os seguintes comandos
    /system script
    add name="bkpdiario2" \
    policy=ftp,reboot,read,write,policy,test,winbox,password,sniff source="/sy \
    ba sav name=bkpdiario2.backup"
    /system scheduler
    add comment="BACKUP FTP" disabled=no interval=5h name="bkpdiario2" \
    on-event=bkpdiario2 start-date=jan/28/2008 start-time=02:36:00

    Ps: Rode o Script e o Scheduler(agendamento) para ver se esta funcionando

    assim vc criara um script com o nome de bkpdiario2 onde o mesmo será agendado para rodar de 5 em 5 horas

    2ª PARTE

    O primeiro passo é baixar e instalar o programa ScriptFTP 2.3 que encontra-se no seguinte link ScriptFTP Download
    Após baixado e instalado execute o programa ScriptFTP
    Vá em NEW > EMPTY SCRIPT FILE
    Salve o arquivo na unidade D:\backup (exemplo) e salve o arquivo com o nome de Backup
    Após salvo o arquivo abrirá entao uma janela com um bloco de notas onde vc vai colocar o seguinte script e salvar novamente (não altere o nome do arquivo do bloco de notas)

    OPENHOST("endereço do servidor","usuário","senha")
    GETFILE("bkpdiario2.backup")
    backup_dir="d:\backup\"
    CLOSEHOST()
    exit

    Entendendo o Script
    VC DEVE MARCAR COMO O EXEMPLO ABAIXO

    OPENHOST("192.168.10.1","admin","infantefox")
    GETFILE("bkpdiario2.backup")
    backup_dir="d:\backup\"
    CLOSEHOST()
    exit

    Apos feito isso clique duas vezes no Arquivo criado "Backup" que está na unidade D:\backup
    Automaticamente vc baixará o arquivo bkpdiario2.backup para a mesma pasta D:\backup

    3ª e ultima Parte

    Devemos agora criar um agendamento no windows para que o arquivo seja salvo no Hd tb de 5 em 5 horas
    Clique no menu INICIAR DO WINDOWS > TODOS OS PROGRAMAS>ACESSÓRIOS>FERRAMENTAS DO SISTEMA>TAREFAS AGENDADAS>ADICIONAR TAREFA AGENDADA
    E siga os passos:

    AVANÇAR
    PROCURAR (localize o arquivo backup.ftp que esta d:\backup)
    Marque DIARIAMENTE
    HORARIO DE INICIO CONFORME NECESSIDADE
    Agora vem o importante: em NOME DE USUARIO E SENHA vc deve colocar um usuário de preferencia administrador do windows com sua determinada senha se nao o agendamento nao funciona
    E pra finalizar marque a opção Abrir as propriedades avançadas desta tarefa ao clicar "Concluir"

    Abra as propriedades avanças e mude conforme necessidade.
    Prontinho, Ufaaaaaaaaaa, é foda mais funciona.
    Voltando a afirmar que esse não é o método mais simples de se fazer um backup via FTP, porém funciona.


    Qualquer dúvida é so falar,

    Espero ter ajudado.
    Última edição por infantefox; 28-01-2008 às 02:44. Razão: Atualizaçoes

  2. Segui um tutorial por esse site mesmo para fazer backup via e-mail e até hj está funcionando corretamente. Não tive tempo de olhar com mais calma e achar o tutorial, mas assim que tiver tempo posto ele aqui.



  3. cara, parabens pelo tutorial, funcionando 100%
    eu so queria saber de um script pro programa upar o backup
    em outro endereço de ftp,
    ao inves de baixar na maquina, upar em um host.
    sera que é possivel isso?






Tópicos Similares

  1. Backup Do Mikrotik Via Ftp
    Por RAIJE no fórum Mikrotik
    Respostas: 4
    Último Post: 02-11-2016, 12:52
  2. Respostas: 4
    Último Post: 16-10-2007, 19:29
  3. backup do sistema via tar... kernel panic.
    Por ThunderFX no fórum Servidores de Rede
    Respostas: 2
    Último Post: 23-06-2006, 15:48
  4. Compartilhar arquivos de backup do Mikrotik
    Por marcelomg no fórum Redes
    Respostas: 14
    Último Post: 11-04-2006, 07:25
  5. Instalação do SUSE via fTP
    Por vonlinkerstain no fórum Servidores de Rede
    Respostas: 0
    Último Post: 16-09-2003, 23:39

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L