estou com o notebook sony vaio Cr220 com wireless intel 4965, tanto no ubuntu como no debian só consigo conectar se a rede for dhcp pois não consigo mais fazer tudo manualmente e se eu colocar pra fazer manual tirando de modo roamming não conecta mais nem dhcp só reiniciando pois j;á tentei reiniciar o serviço pelo /etc/init.d/ e não volta, o que será?já tentei reinstalar usando o ndiswrapper mas acontece a mesma coisa.

segue o que fiz para conectar no escritório da empresa onde os ips são fixos:

[email protected]:/home/fernando# iwconfig wlan0 essid escritorio
[email protected]:/home/fernando# ifconfig wlan0 192.168.254.219 netmask 255.255.255.255
[email protected]:/home/fernando# route del default gw 192.168.254.254
[email protected]:/home/fernando# route add default gw 192.168.254.254
[email protected]:/home/fernando# cat /etc/resolv.conf
domain domain.com
nameserver 200.222.0.35
nameserver 0.0.0.0
[email protected]:/home/fernando# iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

wmaster0 no wireless extensions.

wlan0 IEEE 802.11g ESSID:"escritorio"
Mode:Managed Frequency:2.412 GHz Access Point: Not-Associated
Retry min limit:7 RTS thrff Fragment thr=2346 B
Encryption keyff
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

[email protected]:/home/fernando# ping uol.com.br
ping: unknown host uol.com.br

com o debian acontece a mesma coisa.

se eu tentar o usar o wifi-radar tb não consigo navegar colocando os ips fixo só se eu conectar em dhcp. antes eu escolhia fazer tudo agora com não consigo mais.Acho que te haver com esse modo roamming dele ou com o drive que pode não estar maduro