Página 1 de 11 123456 ... ÚltimoÚltimo
+ Responder ao Tópico



  1. #1

    Padrão Redirecionando clientes para página de débito, sem usar server ext (para pppoe, dhcp)

    Bom vamos lá...

    Esta regra é para quem usa autenticação por PPPOE, DHCP ou mesmo IP Fixo.

    Mãos a obra:

    IP > HOTSPOT

    Com seu Mikrotik configurado, vá em HOTSPOT e ative-o através do SETUP dele (siga os passos até o final)... Será criado um servidor HOTSPOT.

    Vá na aba IP BINDIND e adicione as regras, conforme abaixo:



    / ip hotspot ip-binding
    add address=192.168.100.28 type=bypassed comment="" disabled=no
    add address=100.0.0.0/24 type=bypassed comment="" disabled=no
    add address=192.168.100.32 type=bypassed comment="" disabled=yes
    add address=0.0.0.0/0 type=regular comment="" disabled=no


    O que isso significa... Você irá criar uma regra para cada ip (address) com o tipo em "BYPASSED"... E no final, uma regra para o 0.0.0.0/0 (todos os ips), com o tipo em "REGULAR".

    Bom, o que isso irá fazer?

    A princípio, todos os ips que estiverem cadastrado com o BY-PASSED, irão navegar normalmente... Todos os ips que NÃO estiverem cadastrados no BYPASSED, irão cair na tela de login do HOTSPOT.

    Mas para que vou querer meus clientes caindo na tela de HOTSPOT??

    Oras, é só editar o arquivo LOGIN.HTM com uma mensagem de débito, que toda a vez que seu cliente entrar, será direcionado a tela inicial do HOTSPOT, que na verdade será a tela de mensagem...

    Para bloquear um cliente, desabilite o ip dele ou pegue o ip dele (no ip binding) e mude de "by-passed" para "regular"... Para desbloquear, faça o reverso (mude de "regular" para "by-passed").


    TÁ RESOLVIDO O PROBLEMA DA PÁGINA DE AVISO NO MESMO SERVIDOR... SIMPLES E FUNCIONAL!!!

    Bom, antes de mais nada... Esta solução, desenvolvi a meses ESTUDANDO... e está implantado em vários clientes....
    Última edição por catvbrasil; 05-02-2008 às 13:58.

  2. #2

    Padrão Primeirão

    Ja vou ser o primeirão a testar _o/

    Go go go



  3. #3

    Padrão

    Citação Postado originalmente por Tyallysson Ver Post
    Ja vou ser o primeirão a testar _o/

    Go go go

    Corrigindo... O arquivo é o LOGIN.HTM...

    Qualquer coisa estamos ae!!

  4. #4

    Padrão It's Ok!

    Citação Postado originalmente por catvbrasil Ver Post
    Corrigindo... O arquivo é o LOGIN.HTM...

    Qualquer coisa estamos ae!!

    Como a vida é bela.

    Ja testei e funciona lindinho mesmo

    agora falta alguma alma caridosa aparecer com esse login.html editado ou eu vou ter que ler algumas apostilas de html pra desenvolver algo bizarro pra espantar meus clientes uAHuahuahUhauhuaHhaUH


    PARABÉNS CARA!!



  5. #5

    Padrão

    Citação Postado originalmente por Tyallysson Ver Post
    Como a vida é bela.

    Ja testei e funciona lindinho mesmo

    agora falta alguma alma caridosa aparecer com esse login.html editado ou eu vou ter que ler algumas apostilas de html pra desenvolver algo bizarro pra espantar meus clientes uAHuahuahUhauhuaHhaUH


    PARABÉNS CARA!!

    Na verdade pode apagar esta página e substituir por qualquer outra... Como não terá gente logando nela, não será necessários os scripts internos da página html.

  6. #6

    Question

    Citação Postado originalmente por catvbrasil Ver Post
    Na verdade pode apagar esta página e substituir por qualquer outra... Como não terá gente logando nela, não será necessários os scripts internos da página html.
    Continuei meus testes e aconteceu algo aqui nao sei se é bem um problema da minha config ou da sua regra..

    Uso ppoe para autenticar os clientes com faixa 2.2.2.2, no entanto deixo um servidor dhcp invalido (192.168.1.X) so para nao aparecer rede nula ou limitada, no entanto quando configurei o redirecionamento funcionou por um lado e por outro nao..

    quando tento Google nao cai na pagina de hotspot.
    mas quando tento 192.168.1.1 que é o ip da interface wlan ele cai na pagina normalzin..


    -EDIT-

    fui re-ler a regra e percebi que ela pode ser usado para ppoe dhcp e ip fixo, vou tirar meu dhcp invalido e adicionar o ip do cliente ppoe fixo pra ver qual que é..
    volto ja =)
    Última edição por Tyallysson; 05-02-2008 às 14:45.