Página 1 de 4 1234 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1

    Padrão Redirecionando clientes para página de débito, sem usar server ext (para pppoe, dhcp)

    Bom vamos lá...

    Esta regra é para quem usa autenticação por PPPOE, DHCP ou mesmo IP Fixo.

    Mãos a obra:

    IP > HOTSPOT

    Com seu Mikrotik configurado, vá em HOTSPOT e ative-o através do SETUP dele (siga os passos até o final)... Será criado um servidor HOTSPOT.

    Vá na aba IP BINDIND e adicione as regras, conforme abaixo:



    / ip hotspot ip-binding
    add address=192.168.100.28 type=bypassed comment="" disabled=no
    add address=100.0.0.0/24 type=bypassed comment="" disabled=no
    add address=192.168.100.32 type=bypassed comment="" disabled=yes
    add address=0.0.0.0/0 type=regular comment="" disabled=no


    O que isso significa... Você irá criar uma regra para cada ip (address) com o tipo em "BYPASSED"... E no final, uma regra para o 0.0.0.0/0 (todos os ips), com o tipo em "REGULAR".

    Bom, o que isso irá fazer?

    A princípio, todos os ips que estiverem cadastrado com o BY-PASSED, irão navegar normalmente... Todos os ips que NÃO estiverem cadastrados no BYPASSED, irão cair na tela de login do HOTSPOT.

    Mas para que vou querer meus clientes caindo na tela de HOTSPOT??

    Oras, é só editar o arquivo LOGIN.HTM com uma mensagem de débito, que toda a vez que seu cliente entrar, será direcionado a tela inicial do HOTSPOT, que na verdade será a tela de mensagem...

    Para bloquear um cliente, desabilite o ip dele ou pegue o ip dele (no ip binding) e mude de "by-passed" para "regular"... Para desbloquear, faça o reverso (mude de "regular" para "by-passed").


    TÁ RESOLVIDO O PROBLEMA DA PÁGINA DE AVISO NO MESMO SERVIDOR... SIMPLES E FUNCIONAL!!!

    Bom, antes de mais nada... Esta solução, desenvolvi a meses ESTUDANDO... e está implantado em vários clientes....
    Última edição por catvbrasil; 05-02-2008 às 14:58.

  2. #2

    Padrão Primeirão

    Ja vou ser o primeirão a testar _o/

    Go go go



  3. #3

    Padrão

    Citação Postado originalmente por Tyallysson Ver Post
    Ja vou ser o primeirão a testar _o/

    Go go go

    Corrigindo... O arquivo é o LOGIN.HTM...

    Qualquer coisa estamos ae!!

  4. #4

    Padrão It's Ok!

    Citação Postado originalmente por catvbrasil Ver Post
    Corrigindo... O arquivo é o LOGIN.HTM...

    Qualquer coisa estamos ae!!

    Como a vida é bela.

    Ja testei e funciona lindinho mesmo

    agora falta alguma alma caridosa aparecer com esse login.html editado ou eu vou ter que ler algumas apostilas de html pra desenvolver algo bizarro pra espantar meus clientes uAHuahuahUhauhuaHhaUH


    PARABÉNS CARA!!



  5. #5

    Padrão

    Citação Postado originalmente por Tyallysson Ver Post
    Como a vida é bela.

    Ja testei e funciona lindinho mesmo

    agora falta alguma alma caridosa aparecer com esse login.html editado ou eu vou ter que ler algumas apostilas de html pra desenvolver algo bizarro pra espantar meus clientes uAHuahuahUhauhuaHhaUH


    PARABÉNS CARA!!

    Na verdade pode apagar esta página e substituir por qualquer outra... Como não terá gente logando nela, não será necessários os scripts internos da página html.

  6. #6

    Question

    Citação Postado originalmente por catvbrasil Ver Post
    Na verdade pode apagar esta página e substituir por qualquer outra... Como não terá gente logando nela, não será necessários os scripts internos da página html.
    Continuei meus testes e aconteceu algo aqui nao sei se é bem um problema da minha config ou da sua regra..

    Uso ppoe para autenticar os clientes com faixa 2.2.2.2, no entanto deixo um servidor dhcp invalido (192.168.1.X) so para nao aparecer rede nula ou limitada, no entanto quando configurei o redirecionamento funcionou por um lado e por outro nao..

    quando tento Google nao cai na pagina de hotspot.
    mas quando tento 192.168.1.1 que é o ip da interface wlan ele cai na pagina normalzin..


    -EDIT-

    fui re-ler a regra e percebi que ela pode ser usado para ppoe dhcp e ip fixo, vou tirar meu dhcp invalido e adicionar o ip do cliente ppoe fixo pra ver qual que é..
    volto ja =)
    Última edição por Tyallysson; 05-02-2008 às 15:45.



  7. #7

    Padrão

    Citação Postado originalmente por Tyallysson Ver Post
    Continuei meus testes e aconteceu algo aqui nao sei se é bem um problema da minha config ou da sua regra..

    Uso ppoe para autenticar os clientes com faixa 2.2.2.2, no entanto deixo um servidor dhcp invalido (192.168.1.X) so para nao aparecer rede nula ou limitada, no entanto quando configurei o redirecionamento funcionou por um lado e por outro nao..

    quando tento Google nao cai na pagina de hotspot.
    mas quando tento 192.168.1.1 que é o ip da interface wlan ele cai na pagina normalzin..

    Lá no servidor HOTSPOT, ative a opção address-poll e mude para uma range de ips... Vá também no profile do servidor e atribua um nome em DNS-NAME (bloqueio.com.br, por exemplo)...

  8. #8

    Padrão

    Citação Postado originalmente por catvbrasil Ver Post
    Bom vamos lá...

    Esta regra é para quem usa autenticação por PPPOE, DHCP ou mesmo IP Fixo.

    Mãos a obra:

    IP > HOTSPOT

    Com seu Mikrotik configurado, vá em HOTSPOT e ative-o através do SETUP dele (siga os passos até o final)... Será criado um servidor HOTSPOT.

    Vá na aba IP BINDIND e adicione as regras, conforme abaixo:



    / ip hotspot ip-binding
    add address=192.168.100.28 type=bypassed comment="" disabled=no
    add address=100.0.0.0/24 type=bypassed comment="" disabled=no
    add address=192.168.100.32 type=bypassed comment="" disabled=yes
    add address=0.0.0.0/0 type=regular comment="" disabled=no


    O que isso significa... Você irá criar uma regra para cada ip (address) com o tipo em "BYPASSED"... E no final, uma regra para o 0.0.0.0/0 (todos os ips), com o tipo em "REGULAR".

    Bom, o que isso irá fazer?

    A princípio, todos os ips que estiverem cadastrado com o BY-PASSED, irão navegar normalmente... Todos os ips que NÃO estiverem cadastrados no BYPASSED, irão cair na tela de login do HOTSPOT.

    Mas para que vou querer meus clientes caindo na tela de HOTSPOT??

    Oras, é só editar o arquivo LOGIN.HTM com uma mensagem de débito, que toda a vez que seu cliente entrar, será direcionado a tela inicial do HOTSPOT, que na verdade será a tela de mensagem...

    Para bloquear um cliente, desabilite o ip dele ou pegue o ip dele (no ip binding) e mude de "by-passed" para "regular"... Para desbloquear, faça o reverso (mude de "regular" para "by-passed").


    TÁ RESOLVIDO O PROBLEMA DA PÁGINA DE AVISO NO MESMO SERVIDOR... SIMPLES E FUNCIONAL!!!

    Bom, antes de mais nada... Esta solução, desenvolvi a meses ESTUDANDO... e está implantado em vários clientes....
    Boa solução pra quem não usa a tela de login para os usuários!!!
    mas, no caso de usar a tela de login para os usuários logarem em seu sistema as coisas mudam um pouco.. aí tem quer criar profile para quem estiver em débito, usar a página radvert.html, o advertise pra exibir a página de débito...etc.. etc... mas.. isso é outra história...

    Aqui eu uso a tela de login para os clientes... e outra tela para advertência... tudo no mesmo MK!

    A solução do amigo DAVID e bem simples... e funcional!!
    VLW!



  9. #9

    Smile Minhas cfgs e a duvida.

    Citação Postado originalmente por catvbrasil Ver Post
    Lá no servidor HOTSPOT, ative a opção address-poll e mude para uma range de ips... Vá também no profile do servidor e atribua um nome em DNS-NAME (bloqueio.com.br, por exemplo)...
    Aqui estou usando DHCP com range 127.0.0.2-127.0.0.50 só para nao dar conexão invalida

    PPoE Server com range 192.168.1.100-192.168.1.200 com users usando ip fixo.

    WLAN 192.168.1.1

    minha duvida é, qual ip eu coloco la no ip-binding??
    e outra duvida é, quando o hotspot é configurado ele ja atribui o ip, dns e getway.. assim meus clientes irão navegar normalzin pq ja tem o getway e tudo..

    ai fica o ppoe e o hotspot dando numa m3rda só

    diz ae uma alternativa pra mim. nem que seja tirar o ppoe server..


    ---EDIT---

    deu certo, eu só estava era confuso e tava fazendo pergunta sem precisão.

    meu entendimento para os proximos que forem ler esse topico

    Na interface do hotspot só podera ter 1 servidor dhcp (o que o hotspot cria) nele eu setei meu ip fixo automatico em 192.168.1.100

    configurei o hotspot certinho e no ip-bindings da pra se criar ranges que são permitidos
    EX:
    192.168.1.2-192.168.1.100 <- REGULAR = BLOQUEIO DIRETO PARA A PAGINA DO HOTSPOT
    192.168.1.101-192.168.1.254 <- BYPASSED = LIBERADO, QUANDO AUTENTICAR COM O PPOE CLIENT VAI NAVEGAR NORMAL

    no caso:
    192.168.1.50 = Nao navega
    192.168.1.150 = Navega


    Muito facil mesmo, agora vou pedir pra um amigo meu criar uma pagina simples pra eu trocar pelo login.html

    VLW CATVBRASIL _o/
    Última edição por Tyallysson; 05-02-2008 às 19:12.

  10. #10

    Smile Teste Ok!

    Bom galera pra provar que deu certo estou testando agora e vou comentar sobre a experiencia.

    Setei o dhcp do hotspot para uma faixa de clientes que estão em "Regular" ou seja, ja conectam bloqueados... assim que meus clientes forem logando eu vou definindo dhcp fixo e assim coloco na faixa dos que tem acesso livre...

    o interessante é, quando disco ppoe ele conecta na internet blza.. quando desconecto ele ja pula direto pra pagina do hotspot.

    o foda é que se o cliente entrar primeiro na internet e depois discar vai ocorrer um probleminha, ele vai ficar tentando acessar a net por uns tempos e vai ficar vendo a tela do hotspot.. isso só para de acontecer depois de alguns segundos que o ppoe autenticou.. e a unica solução para acesso imediato é fechando e reabrindo o browser, ai sim ja entra direto sem aparecer tela de hotspot

    bom agora que ta testado, vou pedir pra um amigo modificar o login.html para uma pagina de aviso de débito ou usuario nao autenticado



  11. #11

    Padrão

    Citação Postado originalmente por Tyallysson Ver Post
    Bom galera pra provar que deu certo estou testando agora e vou comentar sobre a experiencia.

    Setei o dhcp do hotspot para uma faixa de clientes que estão em "Regular" ou seja, ja conectam bloqueados... assim que meus clientes forem logando eu vou definindo dhcp fixo e assim coloco na faixa dos que tem acesso livre...

    o interessante é, quando disco ppoe ele conecta na internet blza.. quando desconecto ele ja pula direto pra pagina do hotspot.

    o foda é que se o cliente entrar primeiro na internet e depois discar vai ocorrer um probleminha, ele vai ficar tentando acessar a net por uns tempos e vai ficar vendo a tela do hotspot.. isso só para de acontecer depois de alguns segundos que o ppoe autenticou.. e a unica solução para acesso imediato é fechando e reabrindo o browser, ai sim ja entra direto sem aparecer tela de hotspot

    bom agora que ta testado, vou pedir pra um amigo modificar o login.html para uma pagina de aviso de débito ou usuario nao autenticado

    brow como eu tinha comentado no outro post essa é a ideia... é so avisar na propria pagina de bloquueio para o cliente discar o pppoe caso não esta conseguindo fazer a discagem provavelmente estaja com restrições no sistema "ex. debitos"...

  12. #12

    Padrão

    Bom dia amigos, eai meu peixe catv como que anda o carnaval ai no RJ

    Vamos la tem uma questão nesse caso de usar a pagina do login do hotspot como bloqueio, quando vc ativa o servidor hotspot ele n olha mais a tabela /ip arp dessa forma os MAC cadastrado na tabela /ip arp no caso IP+MAC n funcionára mais, e sim ele vai olhar a tebela MAC do HOTSPOT, dessa forma a tela de login fica bacana como ja testado, mas o controle de MAC+IP perde, pq o cliente pode ir na casa dele e mudar o IP que vai passar pq todos os IPs da rede estarão como BYPASSED, ja reparou isso catv ? como fez para resolver ? em pensando com meus botões aqui teria que coloca todos os ips dos clientes como BYPASSED mas amarrado IP+MAC la em BINDING mas imagina o trabalho, pensem ai e vejam uma solução melhor, a que eu vi foi essa.

    Abraços



  13. #13

    Padrão

    Citação Postado originalmente por tiagomatias Ver Post
    Bom dia amigos, eai meu peixe catv como que anda o carnaval ai no RJ

    Vamos la tem uma questão nesse caso de usar a pagina do login do hotspot como bloqueio, quando vc ativa o servidor hotspot ele n olha mais a tabela /ip arp dessa forma os MAC cadastrado na tabela /ip arp no caso IP+MAC n funcionára mais, e sim ele vai olhar a tebela MAC do HOTSPOT, dessa forma a tela de login fica bacana como ja testado, mas o controle de MAC+IP perde, pq o cliente pode ir na casa dele e mudar o IP que vai passar pq todos os IPs da rede estarão como BYPASSED, ja reparou isso catv ? como fez para resolver ? em pensando com meus botões aqui teria que coloca todos os ips dos clientes como BYPASSED mas amarrado IP+MAC la em BINDING mas imagina o trabalho, pensem ai e vejam uma solução melhor, a que eu vi foi essa.

    Abraços
    Fala ae Tiago!! Beleza???? Não ando pulando Carnaval não, mas estou aqui resolvendo algumas coisas particulares!! heheheheh....... Na próima semana estarei mais presente...

    A princípio, seria interessante ir amarrando mesmo o IP X MAC no próprio IP BINDING e no final ir colocar aquela regra do 0.0.0.0/0... Claro, isso é recomendado continuando a amarração com o PPPoE (mac X ip) e também na tabela ARP... Aqui uso assim, sem problemas... Faça os testes desta forma e qualquer coisa comunica...

  14. #14

    Padrão Minha solução

    Citação Postado originalmente por tiagomatias Ver Post
    Bom dia amigos, eai meu peixe catv como que anda o carnaval ai no RJ

    Vamos la tem uma questão nesse caso de usar a pagina do login do hotspot como bloqueio, quando vc ativa o servidor hotspot ele n olha mais a tabela /ip arp dessa forma os MAC cadastrado na tabela /ip arp no caso IP+MAC n funcionára mais, e sim ele vai olhar a tebela MAC do HOTSPOT, dessa forma a tela de login fica bacana como ja testado, mas o controle de MAC+IP perde, pq o cliente pode ir na casa dele e mudar o IP que vai passar pq todos os IPs da rede estarão como BYPASSED, ja reparou isso catv ? como fez para resolver ? em pensando com meus botões aqui teria que coloca todos os ips dos clientes como BYPASSED mas amarrado IP+MAC la em BINDING mas imagina o trabalho, pensem ai e vejam uma solução melhor, a que eu vi foi essa.

    Abraços
    Minha situação aqui:

    WLAN 192.168.1.1
    DHCP WLAN(dhcp do hotspot) 192.168.1.2-192.168.1.254

    ip bindings

    regular 192.168.1.2-192.168.1.254

    sendo assim todo usuario cairá na tela do hotspot, só que depois de AUTENTICAR com PPoE e fechar o browse(se já aberto antes de autenticar) vai navegar pois a conexão ultima a ser ativa vai ser a do client ppoe, e em caso de ip manual nao vai dar certo pois a faixa de ip navegavel no meu caso nao seria 192.168.1.X ? entao, todos os ips manuais forão bloqueados para ir direto para pagina do hotspot.

    e assim todo mundo fica feliz



  15. #15

    Padrão

    Tentei de varias formas e não deu certo no meu server
    so pra rever minhas configs aqui
    pool do dhcp e hotspot 10.0.2.0/24 sem discar pppoe vai direto p tela de login
    pool do pppoe 10.0.1.0/24 depois de discar não vai pra tela de login de jeito nenhun mesmo não colocando nenhun ip no ip-bindings e colocando a regra 0.0.0.0/0 não barra ninguem que ta autenticado no pppoe.
    ps A versão do meu MK á aquela velha conhecida 2.9.27

  16. #16

    Padrão

    Citação Postado originalmente por binhorp Ver Post
    Tentei de varias formas e não deu certo no meu server
    so pra rever minhas configs aqui
    pool do dhcp e hotspot 10.0.2.0/24 sem discar pppoe vai direto p tela de login
    pool do pppoe 10.0.1.0/24 depois de discar não vai pra tela de login de jeito nenhun mesmo não colocando nenhun ip no ip-bindings e colocando a regra 0.0.0.0/0 não barra ninguem que ta autenticado no pppoe.
    ps A versão do meu MK á aquela velha conhecida 2.9.27
    Brow.. essa é a ideia.. so vai para a tela de login quem não conseguir discar, seja por estar bloqueado ou não cadastrador.. entendeu.. quem estiver discando normalmente acessar a internet normal...
    A vantegem de se usar dessa for e o bloq simples e rapido.. apenas desmarcando o login do inadiplemente ele não efetua a discagem com isso ele so consegue abrir a tela de bloq.... nem msn, nem http, nem nada...



  17. #17

    Padrão

    Neste não precisa das regras ip-bindings visto que não vai ter nenhun cliente cadastrado no hotspot

  18. #18

    Padrão

    Citação Postado originalmente por binhorp Ver Post
    Neste não precisa das regras ip-bindings visto que não vai ter nenhun cliente cadastrado no hotspot
    Sim vc vai cadastrar apenas os clientes pppoe. o hotspot é apenas para pagina de bloq...



  19. #19

    Padrão

    e quem usa ip fixo cada cliente tem como???
    queria direcionar o ip 10.1.1.2 pra www.meusite.com.br/aviso.html

    tem como

  20. #20

    Padrão

    Catv, muito obr pela regra ai, vou testar e posto amanha os resultados.
    valeuuuuuu!!