+ Responder ao Tópico



  1. #1

    Padrão Não responde pelo nome

    Olá pessoal, tudo bem ?
    Estou tentando configurar um servidor apache2, mas que responda pelo nome e não pelo IP.
    Tenho o seguinte cenário: Debian ETCH, bind9 e apache2 configurado. Um IP fixo.
    O meu arquivo de configuração do apache está assim:

    <VirtualHost ip_fixo>
    ServerAdmin [email protected]
    DocumentRoot /var/www/meudominio
    ServerName www.meudominio.com.br
    ErrorLog /var/log/www.meudominio_log
    </VirtualHost>

    Bem, aqui acaba a configuração do meu apache2.

    Agora se eu for no browser e digitar www.meudominio.com.br não acessa nada, mas se eu for no browser e digitar http://IP_FIXO ele vai.

    Gostaria de saber onde posso estar errando, se é aqui o ou bind
    Configuração do BIND

    $TTL 604800
    @ IN SOA morpheu.meudominio.com.br. root.morpheu.meudominio.com.br. (
    1 ; Serial
    604800 ; Refresh
    86400 ; Retry
    2419200 ; Expire
    604800 ) ; Negative Cache TTL
    ;
    morpheu IN A 192.168.0.240
    mail IN A 192.168.0.240
    www IN A IP_FIXO
    ;
    @ IN MX 5 morpheu.meudominio.com.br.
    @ IN NS morpheu.meudominio.com.br.
    @ IN A 192.168.0.240

    O que posso estar errando ??
    Obrigado !!

  2. #2

    Wink Virtualhost ..

    Olha cara,

    penso q o seu Virtualhost está incorreto ...

    <Virtualhost www.seudominio.com.br:80>
    ...
    ...
    <\Virtualhost>



  3. #3
    Moderador Avatar de Bruno
    Ingresso
    Nov 2002
    Localização
    Guarapuava-PR
    Posts
    3.928
    Posts de Blog
    1

    Padrão

    bom dia

    seguinte seu virtualhost esta correto
    porem seu dns naum
    tem uma serta ornden para colocar os ns

    $TTL 86400
    @ IN SOA ns1.meudominio.com.br. postmaster.meudominio.com.br. (
    2008022900
    3600
    900
    604800
    86400 )

    IN NS ns1.meudominio.com.br.
    IN MX 10 mail.meudominio.com.br


    IN A IPFIXO
    ns1 IN A IPFIXO
    www IN A IPFIXO
    mail IN A IPFIXO
    morpheu IN A 192.168.0.240

    o ns tem que ser um ip valido se ele naum for valido como ele será reconhecido como dns e como vc vai registrar este dominio no registro.br

  4. #4

    Padrão

    coloca o DNS da maquina o IP do seu servidor BIND para ver!

    se for isso é pq o problema é no seu registro ou algo no Bind mesmo!

    tenta pingar para o dominio tbm para ver se resolve!



  5. #5
    Moderador Avatar de Bruno
    Ingresso
    Nov 2002
    Localização
    Guarapuava-PR
    Posts
    3.928
    Posts de Blog
    1

    Padrão

    a mais um detalhe como esta seu resolv.conf
    ele tem que estar setado para 127.0.0.1

  6. #6

    Padrão

    Citação Postado originalmente por Benatto Ver Post
    a mais um detalhe como esta seu resolv.conf
    ele tem que estar setado para 127.0.0.1
    Vou tentar....por enquanto obrigado a todos !!

    Gilcimar