+ Responder ao Tópico



  1. #1

    Padrão problemas com proxy transparente

    Boa tarde a todos. Estou tendo um problema no meu squid. Estou querendo colocar o squid como proxy transparente mas não estou conseguindo. Toda vez que vou na linha http_port 3128 e adiciono transparent, quando eu for inicia o serviço squid, da um erro FATAL.
    Já procurei vários tutotiais na internet mas continua dando o problema, alguem sabe qual pode ser a solução. Desde já agradeço. Abraço.

  2. #2

    Padrão

    mostra o erro

    assim nao tem como te ajudar!



  3. #3

    Padrão

    é.. será difícil saber o que está errado se você nem ao menos disse qual versão do squid está usando.

  4. #4

    Padrão

    Olá, desculpem pelo transtorno, é que tive que deixar esse post ai bem rapido, nao deu nem tempo de postar versão ou o erro
    Mas está aqui!
    Versão: 2.5 STABLE8

    Erro: login as:
    root [email protected]'s password:
    [email protected]:~# /etc/squid/sbin/squid start
    FATAL: Bungled squid.conf line 3: http_port 3128 transparent Squid Cache (Version 2.5.STABLE8): Terminated abnormally. CPU Usage: 0.000 seconds = 0.000 user + 0.000 sys Maximum Resident Size: 0 KB Page faults with physical i/o: 193 Aborted [email protected]:~#
    [email protected]:~#
    [email protected]:~# killall -9 squid
    [email protected]:~# /etc/squid/sbin/squid start FATAL: Bungled squid.conf line 3: http_port 3128 transparent Squid Cache (Version 2.5.STABLE8): Terminated abnormally. CPU Usage: 0.000 seconds = 0.000 user + 0.000 sys Maximum Resident Size: 0 KB Page faults with physical i/o: 193 Aborted -bash: [email protected]:~#: command not found [email protected]:~# [email protected]:~# /etc/squid/sbin/squid start -bash: [email protected]:~#: com

    Ja mandaram eu atualizar meu squid, se não tiver vou optar em atualizar.
    Obrigado a todos e abraço!



  5. #5

    Padrão

    coloca isso

    httpd_accel_host virtual
    httpd_accel_port 80
    httpd_accel_with_proxy on
    httpd_accel_uses_host_header on


    pq seu squid é 2.5.X e precisa dessas configurações
    o transparent começou a partir do 2.6

  6. #6
    Analista de Sistemas Avatar de MDdantas
    Ingresso
    Apr 2007
    Localização
    Caruaru - Pernambuco
    Posts
    423

    Padrão

    smoke,

    Bom dia. Conforme nosso amigo anderson falou, a implementação do transparent começa a partir do 2.6, ok. Só lembrando também, para funcionar corretamente o proxy transparente, você tem que habilitar o controle de encaminhamentos de pacotes por IP (Control IP Forwarding), acessa o arquivo sysctl.conf e ative, lembrando:

    0 -> Disabled
    1 -> Enabled


    Espero ter ajudado.

    Atenciosamente,



  7. #7

    Padrão

    ele jah tah assim ;X
    se eu adiciona na linha http_port 3128 o transparent da akele erro ali em cima =(
    mas mesmo assim obrigado
    Abraço

  8. #8

    Padrão

    como eu disse

    se colocar o transparent no squid 2.5 ele da erro mesmo!



  9. #9

    Padrão

    ok entao, vou atualizar meu servidor proxy
    obrigado ai pela ajuda, valeu mesmo
    Qalquer coisa posto aqui denovo.
    Abraço!

  10. #10

    Padrão

    Smoke

    Você não precisa atualizar, faça como o andersoneduardo passou anteriormente, adicione as seguinte regras no seu squid.conf


    http_port 3128
    icp_port 0

    #Para proxy transparente
    httpd_accel_host virtual
    httpd_accel_port 80
    httpd_accel_single_host off
    httpd_accel_with_proxy on
    httpd_accel_uses_host_header on

    Nesta sua versão, esqueço o http_port 3128 transparent (só na versão superior)

    Att.



  11. #11

    Padrão

    Olá amigos. Desculpem pela demora para responder. Seguinte
    Tentei fazer como vocês falaram, pra fala a verdade antes já estava assim. Como nao teve jeito e por vontade de ter o squid mais atualizado, baixei a versao 3.0 STABLE1
    Está funcionando perfeitamente, mas mesmo assim agradeço a todos vocês.
    Abraço!