+ Responder ao Tópico



  1. Resolvi baixar o MK 3.3 para testar o cache full, conforme regras de grandes colegas aqui do forum... Porem nao esta funcionando o meu MK... Vou postar aqui as regras que peguei do forum...

    /ip firewall mangle
    add action=mark-connection chain=output comment="" content="X-Cache: HIT" disabled=no \
    new-connection-mark=squid-connection-HIT passthrough=yes protocol=tcp src-port=3128
    add action=mark-packet chain=output comment="" connection-mark=squid-connection-HIT disabled=no \
    new-packet-mark=squid-packet-HIT passthrough=yes

    /queue tree
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=0 name="squid" \
    packet-mark=squid-packet-HIT parent=global-out priority=8 queue=ethernet-default

    /queue simple
    add comment="" direction=both disabled=no dst-address=0.0.0.0/0 interface=all limit-at=0/0 max-limit=64000/64000 \
    name="teste" parent=none priority=8 queue=default-small/default-small target-addresses=192.168.30.6/32 \
    total-queue=default-small

    /ip proxy
    set always-from-cache=no cache-administrator="webmaster" cache-drive=system cache-hit-dscp=4 cache-on-disk=yes enabled=yes \
    max-cache-size=4096KiB max-client-connections=600 max-fresh-time=3d max-server-connections=600 parent-proxy=0.0.0.0 \
    parent-proxy-port=0 port=3128 serialize-connections=no src-address=0.0.0.0
    /ip proxy access
    add action=deny comment="block telnet & spam e-mail relaying" disabled=no dst-port=23-25
    /ip proxy cache
    add action=deny comment="don't cache dynamic http pages" disabled=no dst-host=":cgi-bin \\\?"
    add action=allow comment="youtube" disabled=no dst-host=http*youtube*get_video*
    add action=allow comment="youtube" disabled=no dst-host=http*youtube*video*
    add action=allow comment="Youtube" disabled=no dst-host="http*youtube*yva_get_video_in f o*"
    add action=allow comment="" disabled=no dst-host=":\\\\\\\\.flv\$"
    add action=allow comment="Globo BBB" disabled=no dst-host=http*globo*get_video*
    add action=allow comment="Globo BBB" disabled=no dst-host=http*globo*video*
    add action=allow comment="Google" disabled=no dst-host=http*googlevideo*get_video*
    add action=allow comment="Google" disabled=no dst-host=http*googlevideo*video*
    add action=allow comment="Google" disabled=no dst-host=http*video.google*get_video*
    add action=allow comment="Google" disabled=no dst-host=http*video.google*video*
    add action=allow comment=" Video play" disabled=no dst-host=http*videoplay*
    add action=allow comment="Google" disabled=no dst-host=http*74.125.15.83*get_video*
    add action=allow comment=" flash" disabled=no dst-host=:/.swf*
    add action=deny comment="banco" disabled=yes dst-host=https://
    add action=deny comment="don't cache dynamic http pages" disabled=no dst-host=":cgi-bin \\\?"
    add action=allow comment="youtube" disabled=no dst-host=http*youtube*get_video*
    add action=allow comment="youtube" disabled=no dst-host=http*youtube*video*
    add action=allow comment="Youtube" disabled=no dst-host="http*youtube*yva_get_video_in f o*"
    add action=allow comment="" disabled=no dst-host=":\\\\\\\\.flv\$"
    add action=allow comment="Globo BBB" disabled=no dst-host=http*globo*get_video*
    add action=allow comment="Globo BBB" disabled=no dst-host=http*globo*video*
    add action=allow comment="Google" disabled=no dst-host=http*googlevideo*get_video*
    add action=allow comment="Google" disabled=no dst-host=http*googlevideo*video*
    add action=allow comment="Google" disabled=no dst-host=http*video.google*get_video*
    add action=allow comment="Google" disabled=no dst-host=http*video.google*video*
    add action=allow comment=" Video play" disabled=no dst-host=http*videoplay*
    add action=allow comment="Google" disabled=no dst-host=http*74.125.15.83*get_video*
    add action=allow comment=" flash" disabled=no dst-host=:/.swf*
    add action=deny comment="banco" disabled=yes dst-host=https://

    Valeu pela ajuda...

  2. faz download do wireshark

    Wireshark: Download

    ele eh um sniffer tcp/udp
    vc roda na SUA maquina.. abre ele.. ativa o filtro na porta 80 ... e faz um download

    o primeiro e o segundo pacote sao os headers do servidor web.. entao vc analisa se o squid do mk esta marcando os pacotes com o X-Cache: HIT



  3. Bom desse jeito ñ estão esperimente alterar as seguintes regras:

    /ip firewall mangle
    add action=mark-connection chain=output comment="" content=!"X-Cache: HIT" disabled=no \
    new-connection-mark=squid-connection-HIT passthrough=yes protocol=tcp src-port=3128

    /queue tree
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=0 name="squid" \
    packet-mark=squid-packet-HIT parent=global-out priority=2 queue=ethernet-default

    /queue simple
    add comment="" direction=both disabled=no dst-address=0.0.0.0/0 interface=all limit-at=0/0 max-limit=64000/64000 \
    name="teste" parent=none priority=8 queue=ethernet-default/ethernet-default target-addresses=192.168.30.6/32 \
    total-queue=ethernet-default

    /ip proxy
    set always-from-cache=yes cache-administrator="webmaster" cache-drive=system cache-hit-dscp=4 cache-on-disk=yes enabled=yes max-cache-size=1024000000KiB max-client-connections=1000 max-fresh-time=1d max-server-connections=1000 parent-proxy=0.0.0.0 \
    parent-proxy-port=0 port=3128 serialize-connections=yes src-address=0.0.0.0

  4. bom coloco aqui a regra que funciona para a versao 3.3 experimente ! mk 3.3= uma sequencia de bugs ainda


    segue as

    /ip firewall mangle
    add action=mark-connection chain=output comment="" content="X-Cache: HIT" disabled=no new-connection-mark=cache_hit passthrough=yes protocol=tcp \
    src-address=10.10.10.1 src-port=1080
    add action=mark-packet chain=output comment="" connection-mark=!cache_hit disabled=no new-packet-mark=cachefull passthrough=no



    queue tree

    name="cachefull" parent=global-out packet-mark=cachefull limit-at=1000000 queue=default priority=1 max-limit=1000000 burst-limit=0 burst-threshold=0
    burst-time=0s
    Última edição por eniak; 04-03-2008 às 22:39.



  5. Citação Postado originalmente por minelli Ver Post
    Bom desse jeito ñ estão esperimente alterar as seguintes regras:

    /ip firewall mangle
    add action=mark-connection chain=output comment="" content=!"X-Cache: HIT" disabled=no \
    new-connection-mark=squid-connection-HIT passthrough=yes protocol=tcp src-port=3128

    /queue tree
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=0 name="squid" \
    packet-mark=squid-packet-HIT parent=global-out priority=2 queue=ethernet-default

    /queue simple
    add comment="" direction=both disabled=no dst-address=0.0.0.0/0 interface=all limit-at=0/0 max-limit=64000/64000 \
    name="teste" parent=none priority=8 queue=ethernet-default/ethernet-default target-addresses=192.168.30.6/32 \
    total-queue=ethernet-default

    /ip proxy
    set always-from-cache=yes cache-administrator="webmaster" cache-drive=system cache-hit-dscp=4 cache-on-disk=yes enabled=yes max-cache-size=1024000000KiB max-client-connections=1000 max-fresh-time=1d max-server-connections=1000 parent-proxy=0.0.0.0 \
    parent-proxy-port=0 port=3128 serialize-connections=yes src-address=0.0.0.0
    Minelli, obrigado por vossa atenção... Fiz os testes... e continua o problema... vou postar toda a conf...

    /ip firewall nat
    add action=masquerade chain=srcnat comment="" disabled=no \
    out-interface=Publica
    add action=redirect chain=dstnat comment="" disabled=no dst-port=80 \
    in-interface=Cliente protocol=tcp to-ports=3128

    /ip firewall mangle
    add action=mark-connection chain=output comment="" content="!X-Cache: HIT" \
    disabled=no new-connection-mark=squid-connection-HIT passthrough=yes \
    protocol=tcp src-port=3128

    /queue tree
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
    max-limit=0 name="squid" packet-mark=squid-packet-HIT parent=global-out \
    priority=2 queue=ethernet-default

    /queue simple
    add comment="" direction=both disabled=no dst-address=0.0.0.0/0 interface=all \
    limit-at=0/0 max-limit=256000/256000 name="teste" parent=none priority=8 \
    queue=default-small/default-small target-addresses=192.168.31.6/32 \
    total-queue=default-small

    /ip proxy
    set always-from-cache=yes cache-administrator="webmaster" cache-drive=system \
    cache-hit-dscp=4 cache-on-disk=yes enabled=yes max-cache-size=32671000KiB \
    max-client-connections=1000 max-fresh-time=1d max-server-connections=1000 \
    parent-proxy=0.0.0.0 parent-proxy-port=0 port=3128 \
    serialize-connections=yes src-address=0.0.0.0






Tópicos Similares

  1. SERVIDOR COM MK 3.30 + CACHE FULL + PCC
    Por rafaelcm no fórum Redes
    Respostas: 0
    Último Post: 31-05-2011, 23:58
  2. Respostas: 6
    Último Post: 05-11-2010, 20:46
  3. Respostas: 11
    Último Post: 07-06-2010, 21:57
  4. Ajuda com Cache Full MK em Cascata com Linux
    Por fnandoicatel no fórum Redes
    Respostas: 1
    Último Post: 18-02-2009, 17:36
  5. MK Bridge com Cache full
    Por paulojrandrade no fórum Redes
    Respostas: 9
    Último Post: 01-05-2008, 22:48

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L