+ Responder ao Tópico



  1. #1

    Question AJUDA com WEBPROXY

    Galera, eu já tentei de tudo aqui e o webproxy nao funciona.

    Seguinte, meu modem ta em bridge conectado a uma placa que eu a nomeei de LINK que está com o ip 192.168.252.254/24 e a LOCAL que esta no Switch é 192.168.253.254/24...
    O mk disca pppoe e conecta, eu consigo navegar tudo blz...

    Primeiramente, o NAT ta dando alguma bronca... eu configuro da seguinte forma: chain=srcnat, Out Interface=LINK(MARCADO), se nao marcar, a net nao funciona...

    O webproxy ta da seguinte forma: ip-webproxy-settings ... src address em branco, port=3128, transparent proxy marcado, parent e parent port desmarcado, cache adm marcado webmaster, max obj 4096, cache drive=system, max cache size=83886080, max ram size=1048576.

    em ip-firewall-mangle ta assim: chain=output, protocol=6tcp, src port=3128, advance-content=X-Cache: HIT, action-action=mark connection, new connection marc=squid-connection-HIT, passth marcado.
    chain=output, connection mark=squid-connection-HIT, action-action=mark packet, new mark=squid-packet-HIT, passth marcado...


    Galera, o q estou fazendo de errado???

    Obrigado

  2. #2

    Talking MKT Brigde PPPOE

    Amigo,

    Fiz isso ontem pra um cliente e deu td certo, tenho a receita de bolo, te passo pelo MSN: [email protected]

    Boa Sorte...



  3. #3

    Talking

    Posta sua receita aqui para q possamos aprender tb... gostaria de saber como vc isso tb....
    Obrigado

  4. #4

    Padrão mesmo problema

    Citação Postado originalmente por Andr0x Ver Post
    Galera, eu já tentei de tudo aqui e o webproxy nao funciona.

    Seguinte, meu modem ta em bridge conectado a uma placa que eu a nomeei de LINK que está com o ip 192.168.252.254/24 e a LOCAL que esta no Switch é 192.168.253.254/24...
    O mk disca pppoe e conecta, eu consigo navegar tudo blz...

    Primeiramente, o NAT ta dando alguma bronca... eu configuro da seguinte forma: chain=srcnat, Out Interface=LINK(MARCADO), se nao marcar, a net nao funciona...

    O webproxy ta da seguinte forma: ip-webproxy-settings ... src address em branco, port=3128, transparent proxy marcado, parent e parent port desmarcado, cache adm marcado webmaster, max obj 4096, cache drive=system, max cache size=83886080, max ram size=1048576.

    em ip-firewall-mangle ta assim: chain=output, protocol=6tcp, src port=3128, advance-content=X-Cache: HIT, action-action=mark connection, new connection marc=squid-connection-HIT, passth marcado.
    chain=output, connection mark=squid-connection-HIT, action-action=mark packet, new mark=squid-packet-HIT, passth marcado...


    Galera, o q estou fazendo de errado???

    Obrigado
    boa tarde amigo estou com o mesmo problema poderia me ajudar se conseguiu resolveu o seu problema



  5. #5

    Padrão web-proxy ??

    Não entendí muito bem, mas me parece q tá faltando muita coisa nessas regras... onde estão as regras de NAT ? e as marcações dos pacotes e prerouting ?? e o queue tree ??
    Põe tudo aí amigão pra gente apreciar...

    Abç,

  6. #6

    Post Todas as regras

    Amigo, mandei um anexo de todas as regras que estou tentando usar aqui se puder me dar uma ajuda fico grato, espero que nao se encomode de ter mandado como anexo.
    Arquivos Anexos Arquivos Anexos



  7. #7

    Padrão

    Citação Postado originalmente por jmsfn Ver Post
    Amigo, mandei um anexo de todas as regras que estou tentando usar aqui se puder me dar uma ajuda fico grato, espero que nao se encomode de ter mandado como anexo.
    [[email protected]] > /ip web-proxy print
    enabled: yes
    src-address: 0.0.0.0
    port: 3129
    hostname: "servidor"
    transparent-proxy: yes
    parent-proxy: 0.0.0.0:0
    cache-administrator: "administrador"
    max-object-size: 4096KiB
    cache-drive: system
    max-cache-size: 2000000KiB
    max-ram-cache-size: unlimited
    status: running
    reserved-for-cache: 1999872KiB
    reserved-for-ram-cache: 753664KiB


    [[email protected]] > ip firewall nat print
    Flags: X - disabled, I - invalid, D - dynamic
    0 chain=srcnat src-address=172.20.2.0/24 action=masquerade

    1 chain=dstnat src-address=172.20.2.0/24 protocol=tcp dst-port=80
    action=redirect to-ports=3129

    [[email protected]] > ip firewall mangle print
    Flags: X - disabled, I - invalid, D - dynamic
    0 chain=output protocol=tcp src-port=3129 content=X-Cache: HIT
    action=mark-connection new-connection-mark=conexao-squid passthrough=yes

    1 chain=output connection-mark=conexao-squid action=mark-packet
    new-packet-mark=pacotes-squid passthrough=yes


    [[email protected]] > queue tree print
    Flags: X - disabled, I - invalid
    0 name="queue1" parent=global-out packet-mark=pacotes-squid limit-at=0
    queue=default priority=8 max-limit=0 burst-limit=0 burst-threshold=0
    burst-time=0s


    Aí está um configuração que está funcionando direitinho. Só alterar alguns dados e pronto!

  8. #8

    Padrão

    Muito obrigado! Valeu mesmo, deixei do jeito que me enviou e funcionou.
    Acho que o problema era duas regras de proxy para nao acessar sites seguros, depois que adicionei elas parou de gravar de novo. Vou postar aqui se puder me ajudar!

    IP>WEB-PROXY>CACHE
    ;;; don't cache dynamic http pages
    url=":cgi-bin \\\\?" action=deny
    ;;; don't cache dynamic https pages
    url="https://" action=deny

    E nao consigo abrir nem orkut e nem logar o msn.
    Origadao por enquanto!



  9. #9

    Padrão

    Citação Postado originalmente por jmsfn Ver Post
    url=":cgi-bin \\\\?" action=deny
    Troque isto por: url=":cgi-bin \\?" action=deny