+ Responder ao Tópico



  1. #1

    Padrão Atualização ports erro ao instalar prog apos a atualização

    Olá amigos...
    eu atualizei o ports e esta dando erro quando vou instalar todos os programas....
    atualizei o ports usando o fetch e baixei o pacote e deletei o velho e extrai o novo pacote apos nao consigo mais instalar nada
    Código :
    host1# cd usr/ports/net/hping
    host1# make install clean
    On FreeBSD before 6.2 ports system unfortunately can not set default X11BASE by itself so please help it a bit by setting X11BASE=${LOCALBASE} in make.conf.
    On the other hand, if you do wish to use non-default X11BASE, please set variable USE_NONDEFAULT_X11BASE.
    *** Error code 1
    Stop.

  2. #2

    Padrão

    make install USE_NONDEFAULT_X11BASE=1



  3. #3

    Thumbs up

    Amigao muito obrigado funcionou.

    So mais uma coisinha....quando eu uso dentro do ports make install USE_NONDEFAULT_X11BASE=1
    instala normal...
    mas se eu executo make install clean da o mesmo erro....
    eu tenho q colocar em algum arquivo para carregar automaticamente?

  4. #4

    Padrão

    Citação Postado originalmente por zzzhhh Ver Post
    Amigao muito obrigado funcionou.

    So mais uma coisinha....quando eu uso dentro do ports make install USE_NONDEFAULT_X11BASE=1
    instala normal...
    mas se eu executo make install clean da o mesmo erro....
    eu tenho q colocar em algum arquivo para carregar automaticamente?
    bsd#echo X11BASE=/usr/local >> /etc/make.conf

    depois disso nao precisa usar o USE_NONDEFAULT_X11BASE=1, pode usar normalmente!



  5. #5