Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1

    Padrão loadbalance por marcação de pacotes ADSL+ADSL

    Caros colegas do forum, to com um problema seriu sobre conecções..
    fiz um balanceamento de carga com 2 links adsl e nas config NTH coloquei 1,1,0 e 1,1,1... so que minha rede ta lenta demais, tem horas que num abre nenhuma pagina, so abre quando tem poucos clientes conectados..
    Alguem poderia me passar alguma config de nth para melhorar minha rede pois quase num abre nada..
    Quando coloco 0,0,0 na configuração do modem 1 parece que turbina minha rede.. so que quando muitos clientes se conectam e claro que fica lento por causa do trafego.. mas o caso acima ai e de pacotes mesmo que num ta passando o suficiente..

  2. #2

    Padrão

    Ola....




    Peço que verifique se não existem tráfegos espúrios (indesejados).

    Como se faz isso?
    Resp: Desabilite a interface de rede que conecta aos seus clientes... e o trafego nas interfaces de links com internet deverá ser nulo. Caso não seja... revise as regras do "ip firewall filter".



    Poste as suas regras: (dentro da tag "CODE"... cada bloco)
    ip firewall mangle print
    ip firewall nat print
    ip route print detail


    Isso ajudará a expor sua situação aos membros do forum para receber ajuda.





    Abraços,



  3. #3

    Padrão

    Citação Postado originalmente por mson77 Ver Post
    Ola....




    Peço que verifique se não existem tráfegos espúrios (indesejados).

    Como se faz isso?
    Resp: Desabilite a interface de rede que conecta aos seus clientes... e o trafego nas interfaces de links com internet deverá ser nulo. Caso não seja... revise as regras do "ip firewall filter".



    Poste as suas regras: (dentro da tag "CODE"... cada bloco)
    ip firewall mangle print
    ip firewall nat print
    ip route print detail


    Isso ajudará a expor sua situação aos membros do forum para receber ajuda.





    Abraços,
    As configurações que usei foi essas ai.. se tiver algo que possa corrigir, me ajudem pois to com meu link rachado.
    / ip address
    Código :
    add address=10.1.1.2/24 network=10.1.1.0 broadcast=10.1.1.255 interface=ether1 comment="" disabled=no 
    add address=10.2.2.2/24 network=10.2.2.0 broadcast=10.2.2.255 interface=ether2 comment="" disabled=no 
    add address=172.16.0.1/24 network=172.16.0.0 broadcast=172.16.0.255 interface=ether4 comment="" disabled=no
    / ip firewall mangle
    Código :
    add chain=prerouting in-interface=ether4 connection-state=new nth=1,1,0  action=mark-connection new-connection-mark=odd passthrough=yes comment="" disabled=no 
    add chain=prerouting in-interface= ether4 connection-mark=odd action=mark-routing new-routing-mark=odd passthrough=no comment="" disabled=no
     
    add chain=prerouting in-interface= ether4 connection-state=new nth=1,1,1 action=mark-connection new-connection-mark=even passthrough=yes comment="" disabled=no 
    add chain=prerouting in-interface= ether4 connection-mark=even action=mark-routing new-routing-mark=even passthrough=no comment="" disabled=no
    / ip firewall nat
    Código :
    add chain=srcnat connection-mark=odd action=src-nat to-addresses=10.1.1.2 to-ports=0-65535 comment="" disabled=no 
    add chain=srcnat connection-mark=even action=src-nat to-addresses=10.2.2.2 to-ports=0-65535 comment="" disabled=no
    / ip route
    Código :
     
    add dst-address=0.0.0.0/0 gateway=10.1.1.1 scope=255 target-scope=10 routing-mark=odd comment="" disabled=no 
    add dst-address=0.0.0.0/0 gateway=10.2.2.1 scope=255 target-scope=10 routing-mark=even comment="" disabled=no

  4. #4

    Padrão

    Ola...



    Na tabela de roteamento (ip route)... adicione uma regra de roteamento para aquelas conexoes que nao tiverem a marcacao "odd" e nem "even" e defina um gateway padrao p essas conexoes.




    Abracos,



  5. #5

    Padrão

    Citação Postado originalmente por mson77 Ver Post
    Ola...







    Na tabela de roteamento (ip route)... adicione uma regra de roteamento para aquelas conexoes que nao tiverem a marcacao "odd" e nem "even" e defina um gateway padrao p essas conexoes.




    Abracos,
    ta ai a regra correta, e que eu acabei esquecendo de botar ela...

    Código :
    / ip route 
    add dst-address=0.0.0.0/0 gateway=10.2.2.1 scope=255 target-scope=10 routing-mark=odd \
        comment="" disabled=no 
    add dst-address=0.0.0.0/0 gateway=10.1.1.1 scope=255 target-scope=10 routing-mark=even \
        comment="" disabled=no 
    add dst-address=0.0.0.0/0 gateway=10.1.1.1 scope=255 target-scope=10 comment="" \
        disabled=no
    Última edição por wireless&cia; 10-03-2008 às 17:09.

  6. #6

    Padrão

    Se pretende selecionar informacao... "esquecendo".



    Acabei de esquecer esse tópico.
    Por sua conta agora.




    Abracos,



  7. #7

    Padrão

    Citação Postado originalmente por mson77 Ver Post
    Se pretende selecionar informacao... "esquecendo".




    Acabei de esquecer esse tópico.
    Por sua conta agora.




    Abracos,
    Que e isso mosso, akela configuração tava em um txt que tava faltando akela regra.. tive de ir no mk conferir para mandar novamente..

  8. #8

    Padrão

    Ola...




    As configuracoes / regras apresentadas estão TODAS corretas.

    Qto a ordem delas... nao posso opinar pois eu nao as vejo.


    BOA SORTE.





    Abraços.



  9. #9

    Padrão loadbalance por marcação de pacotes ADSL+ADSL

    Galera nestas minhas configurações de nth tem 1,1,0 e 1,1,1, gostaria de saber o significado destes numeros e quantidade de pacotes passam por eles, se alguem sabe de um post que fala sobre isso me indica ai, pq to querendo compreender isto a dias e num sei para onde correr.

  10. #10



  11. #11

    Padrão

    resolveu seu problema após o acrescimo da ultima regra?

  12. #12

    Padrão

    Citação Postado originalmente por mson77 Ver Post
    Ola...



    Sugiro voce a ler esse topico:



    https://under-linux.org/forums/mikro...der-o-nth.html



    Abraços,
    Ola amigo... seguinte... tem alguma diferença em usar a regra desta forma:
    Código :
    /ip firewall nat
    add chain=srcnat [COLOR=Red]connection-mark[/COLOR]=odd action=src-nat to-addresses=IPLINK1 to-ports=0-65535 comment="" disabled=no 
    add chain=srcnat [COLOR=Red]connection-mark[/COLOR]=even action=src-nat to-addresses=IPLINK2 to-ports=0-65535 comment="" disabled=no
    ou desta forma?
    Código :
    chain=srcnat [COLOR=Red]routing-mark[/COLOR]=odd action=src-nat to-addresses=IPLINK1 to-ports=0-65535
    chain=srcnat [COLOR=Red]routing-mark[/COLOR]=even action=src-nat to-addresses=IPLINK2 to-ports=0-65535
    Vlw.. abraços



  13. #13

    Padrão

    Ola froyer...





    Com referencia ao /IP FIREWALL NAT


    Nao sei te responder o REAL motivo/causa.
    Eu mesmo j atestei com essa opção "mark-routing"... mas não funciona.

    Funciona com opção MARK-CONNECTION.






    Abraços,

  14. #14
    Moderador Avatar de minelli
    Ingresso
    Aug 2006
    Localização
    Pres. Venceslau - SP | Pres. Prudente - SP
    Posts
    1.409
    Posts de Blog
    10

    Padrão LB

    Já testei os dois e ambos funcionam, mas cada um para uma topologia de rede diferente.

    Bom vim aqui para tentar ajudar então esperimente usar essas regras que são a correção desta que vc utilisou.

    Essa é que vc utiliza agora:
    Load Balancing - MikroTik Wiki

    Essa que vc deve utiliazar:
    Load Balancing Persistent - MikroTik Wiki

    Alguem sempre pergunta qual a diferença???? Então la vai:
    A primeira se o sistema altera o gatway pode congelar e até dar erro de acesso a pagina.
    A segunda torna a sessão percistente - Quer dizer que ñ acontece do cliente perder a conexão por o sistema alterar o gateway derepente.
    Espero ter ajudado, depois poste o resultado.



  15. #15

    Padrão

    Ola...




    Com referencia a esses 02 modelos de fazer LB citados pelo "minelli". PARABÉNS!


    É claro que tudo é opção pessoal... com prós e contras.


    A "ALMA" das tecnicas de LBs... por tecnica de round-robin... usando se contadores Nth... baseia-se na distribuição cíclica das NOVAS CONEXOES nos N-valores possiveis do contador.

    É o exemplo citado na URL1 do "minelli".


    A URL2 faz com que... uma vez definido um LINK para acessar internet... as regras MANGLE (iniciais) fazem com que esse COMPUTADOR passe a trafegar somente nesse LINK... nao mais fazendo LB (para esse computador)... e definindo uma VIDA de 01 dia.


    Por isso que FORUM é bom... e coloco aqui essa questão para ser DISCUTIDA/DEBATIDA... para que TODOS possam colaborar com PROS e CONTRAS de cada solucao: URL1 e URL2 postados por minelli.

    ==> Quais são os pontos POSITIVOS e NEGATIVOS da URL1?

    ==> Quais são os pontos POSITIVOS e NEGATIVOS da URL2?

    Eu sempre costumo questionar em casos onde o sistema falha... os links de internet principalmente. Ou seja... WAN1 deu pau... ou WAN2 deu pau...etc... (modem está ligado e pingando gateway... o link das WAN1/WAN2 nao funcionam.. um de cada vez).
    Pensar nisso... antes de viver isso.





    wish-list wellcomming
    Abraços,

  16. #16

    Padrão

    Citação Postado originalmente por mson77 Ver Post
    Ola froyer...





    Com referencia ao /IP FIREWALL NAT


    Nao sei te responder o REAL motivo/causa.
    Eu mesmo j atestei com essa opção "mark-routing"... mas não funciona.

    Funciona com opção MARK-CONNECTION.






    Abraços,
    Eu notei este detalhe num post seu aqui: https://under-linux.org/forums/mikro...tml#post303453
    veja que na seção /ip firewall nat vc estah usando routing-mark e nao connection-mark
    Está errado no seu post entao?
    vlw



  17. #17

    Padrão

    Ola froyer...





    Com referencia ao /IP FIREWALL NAT


    Eu mesmo ja testei com essa opção "mark-routing"... mas não funciona.

    Funciona com opção MARK-CONNECTION.


    Se houve essa referencia... ocorreu um equivoco.
    SNAT baseado em routing-mark ==> NAO FUNCIONA!





    Abraços,

    ps: (editado)
    Ola froyer... eu vi o meu erro.
    Recordo-me que estava apressado no dia... ao responder p liandrocarniel... pois ele jurava que as regras dele nao funcionavam. E eu respondi quase que copiando e colando regras. ERRO MEU.
    Última edição por mson77; 18-03-2008 às 11:18.

  18. #18

    Padrão

    Citação Postado originalmente por mson77 Ver Post
    Ola froyer...





    Com referencia ao /IP FIREWALL NAT


    Eu mesmo ja testei com essa opção "mark-routing"... mas não funciona.

    Funciona com opção MARK-CONNECTION.


    Se houve essa referencia... ocorreu um equivoco.
    SNAT baseado em routing-mark ==> NAO FUNCIONA!





    Abraços,
    Blz pura... era só para esclarecer minha duvida mesmo..
    abraços



  19. #19

    Padrão

    Eu fiz uma edição posterior a sua leitura.




    Abraços,

  20. #20

    Padrão

    Citação Postado originalmente por mson77 Ver Post
    Eu fiz uma edição posterior a sua leitura.




    Abraços,
    Amigao... tem como a gente trocar umas ideias pelo msn? se sim me adiciona ai... [email protected]
    abs