Página 1 de 6 12345 ... ÚltimoÚltimo
+ Responder ao Tópico



  1. #1

    Padrão Balanceamento com NTH tendo problemas com sites de bancos

    Amigos boa tarde, pessoal tenho um balanceamento rodando aqui com 2 ADSL, funcionando td perfeito, MSN, orkut, navegação porem agora tenho um cliente usando o site do Bradesco e não consegui, pois o IP muda durante a sessão de acesso ao Site. Alguem tem uma dica ai pra poder me ajudar, abaixo segue as informações de configuração do meu servidor Mikrotik

    ENDEREÇAMENTO IP
    / ip address
    add address=189.47.176.133/24 network=189.47.176.0 broadcast=189.47.176.255 interface=ADSL01 comment="" disabled=no
    add address=189.47.130.139/24 network=189.47.130.0 broadcast=189.47.130.255 interface=ADSL02 comment="" disabled=no
    add address=192.168.100.1/24 network=192.168.100.0 broadcast=192.168.100.3 interface=RADIOS comment="" disabled=no
    ROTAS
    / ip route
    add dst-address=0.0.0.0/0 gateway=189.47.130.1 scope=255 target-scope=10 comment="" disabled=no
    add dst-address=0.0.0.0/0 gateway=189.47.130.1 scope=255 target-scope=10 routing-mark=segunda_rota comment="" disabled=no
    add dst-address=0.0.0.0/0 gateway=189.47.176.1 scope=255 target-scope=10 routing-mark=primeira_rota comment="" disabled=no
    MANGLE
    / ip firewall mangle
    add chain=prerouting in-interface=RADIOS connection-state=new nth=1,1,0 action=mark-connection new-connection-mark=primeiro passthrough=yes comment="Loadbalance" disabled=no
    add chain=prerouting in-interface=RADIOS connection-mark=primeiro action=mark-routing new-routing-mark=primeira_rota passthrough=no comment="" disabled=no
    add chain=prerouting in-interface=RADIOS connection-state=new nth=1,1,1 action=mark-connection new-connection-mark=segunda passthrough=yes comment="" disabled=no
    add chain=prerouting in-interface=RADIOS connection-mark=segunda action=mark-routing new-routing-mark=segunda_rota passthrough=no comment="" disabled=no
    NAT
    / ip firewall nat
    add chain=srcnat connection-mark=primeiro action=src-nat to-addresses=189.47.176.139 to-ports=0-65535 comment="NAT" disabled=no
    add chain=srcnat connection-mark=segunda action=src-nat to-addresses=189.47.130.133 to-ports=0-65535 comment="" disabled=no
    Abraços

    Clecio

  2. #2

    Padrão

    tenta direcionar os ips 200.155.84.15 e 200.155.88.15 para o mesmo link e veja se resolve. se nao resolver eu tenho uma outra lista de ips do Bradesco aqui ok? Mas acho que o problema ocorre com esses dois ips mesmo.

    Abraço
    Fabricio



  3. #3

    Padrão

    opa amigo, você teria uma lista com ips do bb e bradesco ai?

  4. #4

    Padrão

    Ola cleciorodrigo...



    Esse problema é típico para TODOS os tipos de load balancing. Ou seja, não é privilegio do universo mikrotik.

    O problema decorre pois os sites de bancos (conexão tcp:443) verificam se os acessos originam-se do mesmo IP (cliente).

    Assim... a única forma de resolver isso é filtrar a porta tcp:443 e direcionar para APENAS um link específico.

    Ao inves de ficar listando IP por IP de sites de bancos... (voce vai ficar louco e vai deixar o processador do MK.RouterOS tambem fervendo)... faz um sourcenat especifico tcp:443 para um link que voce escolher: link1 ou link2.

    Ou seja:

    Código :
    /ip firewall nat add
    chain=srcnat
    protocol=tcp 
    dst-port=443 
    action=src-nat 
    to-addresses=<IP DO LINK1> 
    to-ports=0-65535
    Aproveito para sugerir o uso da mesma técnica para [tcp:1863] pois o MSN tambem está verificando se a conexão parte do mesmo IP.




    Abraços,



  5. #5

    Padrão Redirecinamento de bancos.

    Amigo,

    Eu criei uma regra no mangle direcionando todas as conexões via porta 443 para o link1 (adsl1), antes das regras de balanceamento, e acabou os problemas com o bradesco.

    Segue:

    ;;; Rota1 - Para Bancos
    chain=forward src-address=192.168.0.0/16 protocol=tcp dst-port=443 connection-state=new action=mark-connection new-connection-mark=Rota1 passthrough=yes

    Pode fazer que funciona.

  6. #6

    Padrão

    Caro mson77 já tinha efetuado um teste da forma que vc passo, porem não obtive sucesso. Farei o teste novamente com a sua regra e com a postada pelo limajr.

    Obrigado

    Clecio

    Citação Postado originalmente por mson77 Ver Post
    Ola cleciorodrigo...



    Esse problema é típico para TODOS os tipos de load balancing. Ou seja, não é privilegio do universo mikrotik.

    O problema decorre pois os sites de bancos (conexão tcp:443) verificam se os acessos originam-se do mesmo IP (cliente).

    Assim... a única forma de resolver isso é filtrar a porta tcp:443 e direcionar para APENAS um link específico.

    Ao inves de ficar listando IP por IP de sites de bancos... (voce vai ficar louco e vai deixar o processador do MK.RouterOS tambem fervendo)... faz um sourcenat especifico tcp:443 para um link que voce escolher: link1 ou link2.

    Ou seja:

    Código :
    /ip firewall nat add
    chain=srcnat
    protocol=tcp 
    dst-port=443 
    action=src-nat 
    to-addresses=<IP DO LINK1> 
    to-ports=0-65535
    Aproveito para sugerir o uso da mesma técnica para [tcp:1863] pois o MSN tambem está verificando se a conexão parte do mesmo IP.




    Abraços,