+ Responder ao Tópico



  1. #1

    Question migrando redhat para debian (compartilhar internet)

    Bom dia, utilizo fedora a 2 anos no servidor e gostaria de migrar o sistema para debian.

    Não estou conseguindo compartilhar a internet no debian...

    Onde fica o arquivo network no debian ?
    Exemplo dos rh...

    Código :
    NETWORKING=yes
    FORWARD_IPV4=yes
    HOSTNAME=internet
    GATEWAY=200.x.x.x
    GATEWAYDEV=eth0
    #NOZEROCONF=yes

    No caso acima, onde eu configuro os parametros GATEWAYDEV e FORWARD_IPV4 ?

    Segue abaixo as minhas conf...

    eth0 = internet
    eth1 = rede interna

    Código :
    # This file describes the network interfaces available on your system
    # and how to activate them. For more information, see interfaces(5).
    # The loopback network interface
    auto lo
    iface lo inet loopback
    # The primary network interface
    allow-hotplug eth0
    allow-hotplug eth1
    auto eth0
    iface eth0 inet static
    address 192.168.0.252
    netmask 255.255.255.0
    broadcast 192.168.0.255
    gateway 192.168.0.254
     
    auto eth1
    iface eth1 inet static
    address 192.168.1.254
    netmask 255.255.255.0
    broadcast 192.168.1.255

  2. #2

    Padrão

    Então amigo... Sua conf ai ta legal!
    Para configurar no Debian o ip_forward você tem que editar o arquivo

    Código :
    /etc/network/options
    E sobre o GATEWAYDEV você já definiu isso quando configurou o parametro "gateway" na eth0!

    Qualquer coisa poste ai!



  3. #3

    Padrão

    E sobre as regras de iptables, agora que me dei conta que você colocou no post que quer compartilhar internet, é necessário criar um arquivo novo para as regras do firewall!

    Você pode colocar esse arquivo no

    Código :
    /etc/init.d/<nome do seu script>
    e depois executar

    Código :
    update-rc.d <nome do seu script> defaults
    Esse último comando gera os links para os diretóorios de inicialização /etc/rcX.d/!

  4. #4

    Padrão

    valeu criei o arquivo options e adicionei

    Código :
    net.ipv4.ip_forward=1
    ip_forward=yes

    deu certo.

    Obrigado



  5. #5

    Padrão

    Só uma correção amigos, o arquivo /etc/network/options é deprecated, essas configurações são feitas no /etc/sysctl.conf.

    falow, abraço.