+ Responder ao Tópico



  1. Bom dia,

    Configurei minha vpn matriz->filial, so que so estou conseguindo dar ping do servidor para a filial o inverso nao esta funcionando, acretido que seja alguma coisa no roteamaneto

    meu cliente esta configurado assim:
    ------------------------------------------------
    remote 200.200.200.200
    dev tun
    proto udp
    port 22222
    keepalive 10 120
    comp-lzo
    persist-key
    persist-tun
    float
    ifconfig 10.0.0.2 10.0.0.1
    secret static.key
    ------------------------------------------------

    o servidor esta assim:

    dev tun
    proto udp
    port 22222
    keepalive 10 120
    comp-lzo
    persist-key
    persist-tun
    float
    ifconfig 10.0.0.1 10.0.0.2
    secret static.key


    ------------------------------------------------

    no servidor eu tenho 2 inteface de rede:

    eth0 -> 200.200.200.200 <- ip fixo
    eth1 -> 192.168.0.142 <- ip da rede interna

    -----------------------------------------------

    No servidor eu nao estou ainda usando um firewall so adicionei essas regras:

    echo 1 > /proc/sys/net/ipv4/ip_forward
    iptables -t nat -s 10.0.0.2 -A POSTROUTING -o eth0 -j MASQUERADE


    Alguem pode me dar uma ajuda?


    Grato

  2. Cara, kd as chaves? Acredito que vc usara criptografia.
    Seguindo o how-to do site do openvpn, acredito que vc nao tera problemas.
    De uma olhada nestes exemplos de configuracao do servidor e cliente para openvpn 2.x:

    HOWTO

    Leia, teste e, qualquer erro reporte aqui.

    Ab, Duca.



  3. E não use chaves estáticas, salvo em algumas ocasiões utilize TLS e depois de testado e funcionando, você poderá TLS+chave estática para incrementar a segurança.

    Ab, Duca.

  4. Citação Postado originalmente por Duca Ver Post
    E não use chaves estáticas, salvo em algumas ocasiões utilize TLS e depois de testado e funcionando, você poderá TLS+chave estática para incrementar a segurança.

    Ab, Duca.
    Consegui fazer funcionar,

    to usando certificados + autenticacao com senha, eu refiz a configuracao do servidor e do cliente, agora esta ok.

    Muito obrigado pela dica



  5. Otimo!

    Estou tentando utilizar o openvpn-web-gui.
    Tenho tres servidores de openvpn e este aplicativo ajudar a monitorar os clientes. Existem outros mas este me parece mas atraente, contudo ainda nao consegui faze-lo funcionar aqui. Estou em contato com o desenvolver afim de resolver o problema, rsrs
    De uma olhada nele, seria uma boa pra ti.

    OpenVPN Web GUI 0.3.x

    Ab, Duca.






Tópicos Similares

  1. Respostas: 2
    Último Post: 07-06-2014, 17:58
  2. Openvpn - problema com rotas
    Por igorliberato no fórum Servidores de Rede
    Respostas: 4
    Último Post: 26-10-2009, 14:22
  3. OPENVPN com problema de rotas
    Por laerciok no fórum Servidores de Rede
    Respostas: 4
    Último Post: 10-10-2006, 20:49
  4. OpenVPN + Rota
    Por WC no fórum Servidores de Rede
    Respostas: 7
    Último Post: 28-04-2006, 09:47
  5. rota OpenVPN
    Por whinston no fórum Servidores de Rede
    Respostas: 14
    Último Post: 09-08-2005, 19:06

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L