Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1

    Padrão Load Balance sem Marcação de pacotes

    Utilizo intenet via radio, e tenho dois links no mesmo provedor (na minha cidade estamos com um problema de link a embratel nao quer mais investir na cidade, e os provedores estao super-carregados).
    O Que acontece e o seguinte, tenho dois links com ips invalidos, cada conexao de 128kbps, e estou fazendo load balance com um servidor com o BrazilFW instalado, o balanceamento funciona 100%, so que queria que ele fosse feito no MK, mas nao achei nem uma dica de como fazer isso, todas as dicas de load balance sao com marcacao de pacote, e eu queria q ele apenas gerenciasse cada conexao, tipo assim, uma pra um link a outra pro outro, pois nao vou ter problema com o msn e nem com sites de banco, pois os links por serem de ips invalidos eles recebem o ip do roteador do meu provedor, como mostra na figura

    Roteador do Provedor
    |
    |
    |
    |
    |
    ----Provedor ----
    |
    |
    |
    |
    Link 01 link 02

    |
    |
    |
    |
    ---Servidor MK--
    |
    |
    |
    |
    |
    Rede Interna

    Me Ajudem, Obrigado

  2. #2

    Padrão Sim

    Saudações,

    Amigo eu aqui usava sem marcação de pacotes e funciona bem se você tiver dois links e no MK as suas wans tenham ip´s públicos. Desta forma você consegue rotear por multiplos gateways sem estressar muito.

    Algo assim:

    wan1=200.xxx.xxx.xxx
    wan2=201.xxx.xxx.xxx

    Nas rotas:

    0.0.0.0/0 =200.xxx.xxx.xxx
    =200.xxx.xxx.xxx
    =201.xxx.xxx.xxx

    Note que duas vezes aparece o gateway da wan1 isso aumenta a carga sobre o link 1.

    Agora basta seguir até o NAT e mapear para os ips que você designou para as suas wans.

    Pronto, funciona muito bem! Espero ter ajudado.



  3. #3

    Padrão ainda nao....

    Olá amigo,


    eu pois e desse modo, eu iria carregar mais um link do que o outro, e nao e essa minha intencao.
    meus ips sao invalidos..
    precisaria q o meu mk mandasse uma pra um uma pra outro, e nao uma pra um e duas pra outra!

    se voce puderme ajudar agradeco....

  4. #4

    Padrão

    Vc queria dividir seus clientes pelos links ?
    tipo 100 clientes = 50 link1 e 50 link2 ?
    isso é facil, marque o ip dele no mangle e na rota sete ele para o gateway e pronto.



  5. #5

    Padrão Simples

    No procedimento que passei apenas coloque apenas uma rota pra cada link e pronto ja vai estar funcionando.

    Um abraço.

  6. #6

    Padrão

    Já testei todos os balanceamentos que tem aqui no forum e o site da mikrotik.com; este balanceamento parece funcionar bem ...
    mas e se um dos links cair. oque vai acontecer? Tem alguma regra pra isso?



  7. #7

    Padrão Verificação de Rota

    Na regra de rota, adicione para que o MK verifique se a rota esta UP, podendo ser feito com PING ou pelo ARP. Creio que o ping seja o mais interessante no caso.

    Espero ter ajudado. Um abraço,

    Marzio.

  8. #8

    Padrão

    ja vi alguma coisa assim no forum vou verificar e posto o resultado
    valew



  9. #9

    Unhappy To Quase

    eu adicionei duas rotas, uma rota pra cada ip, ta funcionando, so q nao da a velocidade maxima, eu sei da no maximo 75% dela, eu percebi q quando pingo pra um determinado gateway um tem uma resposta de 150ms e o outro tem uma resposta de 900ms sera q e issu q ta fazendo com que ele nao utilize toda a banda dos links/:???

  10. #10

    Padrão

    [FONT='Arial','sans-serif']E o seguinte, todos nos sabemos q quando agente abre uma pagina, essa pagina e dividida em pacotes, cada imagem e um pacote, a estrutura e outro e assim por diante, isso e feito para aumentar a velocidade do acesso, se não fosse feito isso, o navegador iria primeiro fazer download da estrutura depois de terminar iria baixar uma imagem e assim por diante, fazendo com q a conexão perdesse alguns % de sua velocidade, o que acontece e o seguinte, gostaria de fazer com que meu mikrotik fizesse automaticamente essa distribuição de pacotes, tipo pacote 1 pra uma conexão pacote dois pra segunda, sempre respeitando o peso de cada conexão, e assim nunca sobrecarregando uma conexão mais que a outra,[/FONT][FONT='Times New Roman','serif'][/FONT]
    [FONT='Arial','sans-serif']no meu caso, como disse anteriormente não me importo com sites de bancos, sites seguros, pois meus ips são inválidos, e assumem um único ip valido quando passam pelo roteador do meu provedor, [/FONT][FONT='Times New Roman','serif'][/FONT]
    [FONT='Times New Roman','serif'] [/FONT]
    [FONT='Arial','sans-serif']resumindo, queria um load balance apenas fizesse uma divisão ( com peso predeterminado) das conexões, sem se importar com a porta "x" sair por um ip determinado, pra mim não faz diferença em qual ip saia, apenas q elas sejam divididas...[/FONT]
    [FONT='Arial','sans-serif'] [/FONT]
    [FONT='Arial','sans-serif']eu estou usando um outro programa pra fazer o meu load balance, e funciona direito, uso o brazilfw uma distribuição Linux [/FONT]
    [FONT='Arial','sans-serif']tenho esse link que mostra como funciona o load balance que preciso.[/FONT]
    [FONT='Times New Roman','serif']http://www.brazilfw.com.br/forum/viewtopic.php?f=39&t=62557[/FONT]
    [FONT='Times New Roman','serif']alguém tem uma luz de como fazer o mikrotik funcionar igual a ele?[/FONT]
    [FONT='Times New Roman','serif'] [/FONT]
    [FONT='Arial','sans-serif']poooooooooooooorrrrrrr fffffffffffffaaaaaaaaaaaaaaaaaaavvvvvvvvvvvvvoooooooooooorrrrrrrrrrrrrrrrrrrrr me ajudem....[/FONT][FONT='Times New Roman','serif'][/FONT]
    [FONT='Arial','sans-serif']hehehehehe[/FONT]



  11. #11

    Padrão

    E o seguinte, todos nos sabemos q quando agente abre uma pagina, essa pagina e dividida em pacotes, cada imagem e um pacote, a estrutura e outro e assim por diante, isso e feito para aumentar a velocidade do acesso, se não fosse feito isso, o navegador iria primeiro fazer download da estrutura depois de terminar iria baixar uma imagem e assim por diante, fazendo com q a conexão perdesse alguns % de sua velocidade, o que acontece e o seguinte, gostaria de fazer com que meu mikrotik fizesse automaticamente essa distribuição de pacotes, tipo pacote 1 pra uma conexão pacote dois pra segunda, sempre respeitando o peso de cada conexão, e assim nunca sobrecarregando uma conexão mais que a outra,
    no meu caso, como disse anteriormente não me importo com sites de bancos, sites seguros, pois meus ips são inválidos, e assumem um único ip valido quando passam pelo roteador do meu provedor,

    resumindo, queria um load balance apenas fizesse uma divisão ( com peso predeterminado) das conexões, sem se importar com a porta "x" sair por um ip determinado, pra mim não faz diferença em qual ip saia, apenas q elas sejam divididas...
    eu estou usando um outro programa pra fazer o meu load balance, e funciona direito, uso o brazilfw uma distribuição Linux
    tenho esse link que mostra como funciona o load balance que preciso.
    http://www.brazilfw.com.br/forum/viewtopic.php?f=39&t=62557
    alguém tem uma luz de como fazer o mikrotik funcionar igual a ele?

    poooooooooooooorrrrrrr fffffffffffffaaaaaaaaaaaaaaaaaaavvvvvvvvvvvvvoooooooooooorrrrrrrrrrrrrrrrrrrrr me ajudem....
    hehehehehe
    Última edição por rodolfofp; 25-04-2008 às 01:44.

  12. #12

    Padrão

    Ola rodolfofp,


    Exemplo hipotético:
    Vamos imaginar que voce seu MK possui 04 interfaces ethernet e dessas 04 interfaces... 03 delas sao de links para internet e 01 para sua rede interna. Assim:


    • ether1 ==> nome = link1
    • ether2 ==> nome = link2
    • ether3 ==> nome = link3
    • ether4 ==> nome = redeinterna


    E... considere que cada link possui as seguintes velocidades (ou peso):


    • link1 = 600Kbps (nesse link voce quer peso 1)
    • link2 = 1200Kbps (nesse link voce quer peso 2)
    • link3 = 1800Kbps (nesse link voce quer peso 3)


    Entao, voce precisa de um contador com range de 6 valores.
    Na versao v2.9.x existe o contador Nth... e esse contador começa do "0".

    exemplo: Nth


    • (5,1,0) ==> para LINK1
    • (5,1,1) ==> para LINK2
    • (5,1,2) ==> para LINK2
    • (5,1,3) ==> para LINK3
    • (5,1,4) ==> para LINK3
    • (5,1,5) ==> para LINK3

    Na tabela "mangle" (/IP FIREWALL MANGLE)
    faça as marcações de conexão e roteamento;

    Na tabela "nat" (/IP FIREWALL NAT)
    faça os devidos sourcenat/masquerades

    Na tabela "routes" (/IP ROUTES)
    faça os roteamentos com seus 3 gateways... (3 links), conforme marcação de roteamentos realizados na "mangle"


    É isso!!!
    Boa sorte!


    Se desejar, embaixo na minha assinatura tem um LINK para voce visitar a minha LISTA DE DESEJOS da Livraria Cultura.



    Abraços,



  13. #13

    Padrão

    Olá.. mson77

    Tenho q agradecer em nome de todos aki do forum.. o quanto
    vc esta ajudando a comunidade no quesito LB, pois com suas respostas.. limpas, claras e formatadas.. Acho que o LB ficou muito claro para todos...

    Conforme venho acompanho suas respostas....

    Obrigado..

    É muito saudável ter pessoas como voce no forum.

    Abraços..
    T+

  14. #14

    Padrão

    Olas...


    igualmente, digo aqui que... reciprocidade na vida é saudável.

    Se achar que vale a pena fazer uma "gentileza", um "agrado", um "reconhecimento"... não deixe de visitar a minha lista de desejos. Sei que o mundo é uma grande via de mãos duplas... ou simplesmente "agradeça". É saudável ter boas atitudes como hábito.

    Aqui... o maior conhecimento não é de tecnologia, mikrotik ou linux. O maior conhecimento é... de postura, de VIDA.

    Segue o link da minha lista de desejos nesse parágrafo. Basta clicar aqui.



    Abraços,



  15. #15

    Question Obrigado

    Agradeco a todos por me ajudarem aqui no forum, principalmente ao "mson77".


    Mas ja li no forum sobre loadbalance com NTH, so que nunca funciona quando edito as configuracoes, oque ha de errado nelas? uso uma rb150, sendo q a primeira e a segunda porta uso para entrada de internet, e as outras uso em bridge pra rede.

    segue minhas configuracoes!!! existe algum erro????

    Internet 01
    IP: 10.0.28.104
    GT: 10.0.28.1
    DNS1: 200.242.199.130
    DNS2: 200.242.199.131

    Internet 02
    IP: 10.0.2.14
    GT: 10.0.2.1
    DNS1: 200.242.199.130
    DNS2: 200.242.199.131

    Rede Local
    IP: 192.168.1.1
    MSK: 255.255.255.0


    /ip address
    add address=192.168.1.1/24 network=192.168.1.0 broadcast=192.168.0.255 interface=Local comment="" disabled=no
    add address=10.0.28.104/24 network=10.0.28.0 broadcast=10.0.28.255 interface=Internet01 comment="" disabled=no
    add address=10.0.2.14/24 network=10.0.2.0 broadcast=10.0.2.255 interface=Internet01 comment="" disabled=no
    /ip firewall mangle
    add chain=prerouting in-interface=Local connection-state=new nth=1,1,0action=mark-connection new-connection-mark=link01 passthrough=yes comment="" disabled=no
    add chain=prerouting in-interface=Local connection-mark=link01 action=mark-routing new-routing-mark=odd passthrough=no comment="" disabled=no
    add chain=prerouting in-interface=Local connection-state=new nth=1,1,1 action=mark-connection new-connection-mark=Link02 passthrough=yes comment="" disabled=no
    add chain=prerouting in-interface=Local connection-mark=Link02 action=mark-routing new-routing-mark=Link02 passthrough=no comment="" disabled=no
    / ip firewall nat
    add chain=srcnat connection-mark=link01 action=src-nat to-addresses=10.0.28.104 to-ports=0-65535 comment="" disabled=no
    add chain=srcnat connection-mark=Link02 action=src-nat to-addresses=10.112.0.2 to-ports=0-65535 comment="" disabled=no
    / ip route
    add dst-address=0.0.0.0/0 gateway=10.0.28.1 scope=255 target-scope=10 routing-mark=link01 comment="" disabled=no
    add dst-address=0.0.0.0/0 gateway=10.0.2.1 scope=255 target-scope=10 routing-mark=Link02 comment="" disabled=no
    add dst-address=0.0.0.0/0 gateway=10.0.28.1 scope=255 target-scope=10 comment="" disabled=no



    Alguma sugestão??

    Obrigado

  16. #16

    Padrão

    Ola rodolfofp,



    Que tal... corrigir a nomenclatura de roteamento?

    Citação Postado originalmente por rodolfofp Ver Post
    /ip firewall mangle
    add chain=prerouting in-interface=Local connection-mark=link01 action=mark-routing new-routing-mark=odd passthrough=no comment="" disabled=no
    / ip route
    add dst-address=0.0.0.0/0 gateway=10.0.28.1 scope=255 target-scope=10 routing-mark=link01 comment="" disabled=no



    Boa sorte!
    Clique aqui se tudo deu certo!




    Abraços,



  17. #17

    Padrão Opss..........

    Olá mson77,

    Foi Erro de digitaçao.... hehehe mas mesmo assim nao funciona, quando eu configuro, eu nao consigo mais acessar internet nos clientes, eu reinicio as maquinas a rb e nada, mas se eu for pelo winbox e da um ping no meu dns ele funciona, a internet funciona na rb mas nao e repassada para os clientes,???

    eu preciso de mais alguma configuracao alem dessas?/


    obrigaodo

  18. #18

    Padrão

    Ola rodolfofp,





    As suas regras estão corretas.
    Nota 10!

    Boa sorte!





    Abraços,



  19. #19

    Padrão Ainda Nao Funciona

    Se elas estao corretas? pq nao funcionam??
    obrigado

  20. #20

    Padrão

    Ola rodolfofp,


    "talvez" o cenário que eu estou lendo... mediante a sua exposição... me limite a dizer apenas isso, na minha mais honesta opinião.



    Boa sorte!
    Clique aqui e demonstre o valor da minha ajuda!




    Abraços,