+ Responder ao Tópico



  1. #1
    Luciana-Martins
    Visitante

    Padrão Dúvida / Problema estranho / Mudança de Rota

    Bom pessoal!

    Tenho 03 Links

    01 - 2 Mb Full Brt (200.16.xxx.xxx)
    01 - 1 Mb Full Brt (189.30.xxx.xxx)
    01 - 2 Mb Full Embratel ( 200.248.xxx.xxx)

    Fiz um balaceamento baseador por mudança de rota/link por grupo de IP

    Por exemplo

    - Deixei o defaul GW o 200.16.xxx.1 do link de 2mb da Brt
    - Defini o link 02 1mb da Brasil telecom no mark no route como link02br
    - Defini o link 03 2mb da Embratel no mark no route como link03emb


    Perfeito

    - Fiz os nat`s para os endereços que queria ( Grupos, 02 Grupos por link )


    No mangle
    - chain=prerouting src-address-list=Srclist-GRUPO C/D action=mark-routing new-routing-mark=Link02br passthrough=yes comment="Nova Rota Link 02 Brt" disabled=no
    - chain=prerouting src-address-list=Srclist-GRUPO E/F action=mark-routing new-routing-mark=Link03emb passthrough=yes comment="Nova Rota Link 03 Embratel" disabled=no

    Bom!

    No Scr list, adicionei as faixas para cada grupo!
    Tipo Scrlist-Grupo C/D = 192.168.0.0/24
    Tipo Scrlist-Grupo E/F = 192.168.1.0/24

    Perfeito

    Agora o problema!

    - Possuo um servidor de DNS ligado no Link01 da Brasil telecom 201.16.xxx.2 201.16.xxx.3 ( Funcionando perfeitamente )

    - O Usuários que conectado saindo pelo link 201.16.xxx.xxx usando como dns 201.16.xxx.2 e 201.16.xxx.3, navegam normalmente, perfeito.
    - Os usuário que sau pelo 189.30.xxx.xxx com os DNS 201.16.xxx.2 e 201.16.xxx.3 ( Meus mesmos ) não navegam com este dns, não resolve nenhum nome, se eu colocar outro DNS de fora , perfeito!
    - Os usuário que sau pelo 200.248.xxx.xxx com os DNS 201.16.xxx.2 e 201.16.xxx.3 ( Meus mesmos ) não navegam com este dns, não resolve nenhum nome, se eu colocar outro DNS de fora , perfeito! ( Mas tem que ser algum do bloco da embratel, o mesmo que funcionou para os que saem pelo 189.30. não funcioana aqui!

    Alguma regra errada ou faltando em mangle ou nat?


    Obrigado

    *sorry pelo big texto!

  2. #2
    Moderador Avatar de minelli
    Ingresso
    Aug 2006
    Localização
    Pres. Venceslau - SP | Pres. Prudente - SP
    Posts
    1.409
    Posts de Blog
    10

    Padrão Dns

    Cadastre o seguinte dns em /ip dns e ative ele 208.67.222.222 ai depois no cliente em dns coloque o gatway dele resolvera seu problema.



  3. #3
    Luciana-Martins
    Visitante

    Padrão

    Citação Postado originalmente por minelli Ver Post
    Cadastre o seguinte dns em /ip dns e ative ele 208.67.222.222 ai depois no cliente em dns coloque o gatway dele resolvera seu problema.

    Não funcionou!
    Somente sentando o IP 208.67.222.222 como DNS diretamente no cliente!

    Mas a real situação , quero descobrir o motivo pelo qual meu DNS não responde!

    ;/

    Para estes links :/

  4. #4
    Moderador Avatar de minelli
    Ingresso
    Aug 2006
    Localização
    Pres. Venceslau - SP | Pres. Prudente - SP
    Posts
    1.409
    Posts de Blog
    10

    Padrão Dns

    Em / IP DNS vc marcou a opção Allow Request Dns ....?



  5. #5
    Luciana-Martins
    Visitante

    Padrão

    Sim, testei marcado e desmarcado :/

  6. #6
    Moderador Avatar de minelli
    Ingresso
    Aug 2006
    Localização
    Pres. Venceslau - SP | Pres. Prudente - SP
    Posts
    1.409
    Posts de Blog
    10

    Padrão Erro

    Add msn fica mais facil ai logo no serve e vejo.



  7. #7

    Padrão

    eu estav usando esse mesmo sistema seu, rodando perfeito mas depois por algum motivo o msn ficou caindo
    pra resolver esse problema de dns eu redirecionei o ip que tava setado nos clientes para um dns valido
    a regra nao tenho pois achei aki no forum
    e mais ou menos assim:
    ip>firewall>nat
    add uma nova regra
    em chain marca dstnat
    dst adrdress coloca o ip de tua placa de rede tipo 192.168.1.254 que deve ser o dns que ja esta no cliente
    em action marca dst-nat
    em to addresses coloca um ip valido que seja da operadora que o bloco de ip vai sair

    espero ter ajudado e ao amigo que postou no forum essa regra(pois nao me lembro o nome o qual esta de parabens) pode me corrigir e lembrando que os creditos dessa regra nao sao meus so fiz te passar o que achei, pois aki por um tempo funfou mas quando deu pau deve ter sido alguma besteira que fiz aki depois