Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. Fala galera, como estão as coisas?

    Pessoal, tenho configurado o logrotate para os LOGs do squid mas ele não está comprimindo os arquivos de LOG rodados, pelas configurações está tudo OK, a não ser que eu esteja esquecendo de algo, alguém já viu isso??

    Código :
    #
    #  Logrotate fragment for squid.
    #
    /var/log/squid/*.log {
       daily
       missingok
       rotate 30
       compress
       delaycompress
       nocreate
       sharedscripts
       prerotate
          test ! -x /usr/sbin/sarg-maint || /usr/sbin/sarg-maint
       endscript
       postrotate
          test ! -e /var/spool/squid/logs/squid.pid || /usr/sbin/squid -k rotate
       endscript
    }

    valeu

  2. A bronca é o seguinte, é quem esta rotacionando é o squid e nao o logrotate em si, aqui ta o problema:

    postrotate
    test ! -e /var/spool/squid/logs/squid.pid || /usr/sbin/squid -k rotate



  3. não lembro onde vi ou li, mas se fizer a rotação do log do squid sem o "squid -k rotate" dá pau no squid.

    mas pensando agora, se tirar essa linha e a linha "nocreate" acho que vai beleza...

  4. o duro é fazer alguma alteração e dá pau no squid por causa do arquivo de log..

    se parar o processo lasca tudo..



  5. depois que comentei as linhas abaixo, além de não comprimir os logs, os arquivos estavam zerados, por pouco que não dá tilt no squid.. heheheh

    Código :
       nocreate
       postrotate
          test ! -e /var/spool/squid/logs/squid.pid || /usr/sbin/squid -k rotate   
    endscript






Tópicos Similares

  1. não está enviando ou não está recebendo...
    Por ozzymaia no fórum Servidores de Rede
    Respostas: 0
    Último Post: 20-05-2003, 10:59
  2. Squid não esta atualizando
    Por _MANCHESTER_ no fórum Servidores de Rede
    Respostas: 2
    Último Post: 12-04-2003, 18:33
  3. VirtualHost nao esta 100%
    Por no fórum Servidores de Rede
    Respostas: 2
    Último Post: 17-02-2003, 16:06
  4. DNS Nao esta funcionando
    Por earaujos no fórum Servidores de Rede
    Respostas: 3
    Último Post: 12-02-2003, 14:40
  5. acl no squid não está funcionando. O que fazer ?
    Por no fórum Servidores de Rede
    Respostas: 3
    Último Post: 20-12-2002, 16:01

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L