Página 1 de 4 1234 ÚltimoÚltimo
+ Responder ao Tópico



  1. Ola pessoal, abraço a todos, gostaria de saber se tem algum amigo q possa nos dar uma luz.
    Seguinte montei um Maquina com MK em Hotspot, mas na hora q configurei o Webproxy nao senti diferença, ao contrari senti lentidão, até ai tudo bem, fui tentar aplicar as regras para cache full, essas regras pegas do nosso colega Alexandre Correa, mas sem sucesso. Vejo os graficos da regra mangle onde mostra os pacotes sendo marcados, mas nao hora do download, num vira nao... ele faz download na velocidade do cliente... digamos 320k... q o hostap cria para o usuario. Mesmo colocando sem limite no Queue Tree nao faz download alto... faz na velocidade q esta simple queue.
    Alguem poderia dar uma ajuda ou mostrar inde se pode conseguir essa receita.
    Agradeçemos desde já e desculpe-me pela msg muito longa

  2. Amigo uso aqui e não tenho problemas, bom sera que tem como vc passar mais informações sobre sua configuração e extrutura, tipo vc qual a velocidade definida no profile dos usuarios? qual a sua configuração de firewall filter, nat e mangle... vc se o proxy na profile do hotspot ou pelo firewall que vc efetua o redirecionamento.

    Abraços

    Clecio



  3. Obrigado por responder Clecio, bom irei te mandar minha configuração full.... os comandos todos peguei aqui no forum.

    / ip firewall mangle
    add chain=output protocol=tcp src-port=3128 content="X-Cache: HIT" \
    action=mark-connection new-connection-mark=proxyfull passthrough=yes \
    comment="PROXY FULL" disabled=no
    add chain=output connection-mark=proxyfull action=mark-packet \
    new-packet-mark=proxyfull passthrough=yes comment="" disabled=no
    add chain=output connection-mark=proxyfull action=return comment="" \
    disabled=no
    add chain=prerouting p2p=all-p2p action=mark-connection \
    new-connection-mark=P2P-Conexao passthrough=yes comment="CONTROLE P2P" \
    disabled=no
    add chain=prerouting protocol=tcp p2p=all-p2p connection-limit=40,32 \
    action=mark-connection new-connection-mark=P2P-Conexao-Limite \
    passthrough=yes comment="" disabled=no
    add chain=prerouting connection-mark=P2P-Conexao action=mark-packet \
    new-packet-mark=P2P-Pacotes passthrough=no comment="" disabled=no
    add chain=prerouting connection-mark=P2P-Conexao-Limite action=mark-packet \
    new-packet-mark=P2P-Pacotes passthrough=no comment="" disabled=no
    add chain=prerouting protocol=udp dst-port=5060 action=mark-connection \
    new-connection-mark=voip_in passthrough=yes comment="VOIP-IN" disabled=no
    add chain=prerouting connection-mark=voip_in action=mark-packet \
    new-packet-mark=VOIP_IN passthrough=yes comment="" disabled=no
    add chain=prerouting protocol=udp src-port=5060 action=mark-connection \
    new-connection-mark=voip_out passthrough=yes comment="VOIP-OUT" \
    disabled=no
    add chain=prerouting connection-mark=voip_out action=mark-packet \
    new-packet-mark=VOIP_OUT passthrough=yes comment="" disabled=no
    / ip firewall nat
    add chain=srcnat src-address=192.168.1.0/24 action=masquerade comment="masquerade hotspot \
    network" disabled=no

    / ip firewall filter
    add chain=virus protocol=tcp dst-port=445 action=drop comment="bloqueio de \
    VIRUS conhecidos" disabled=no
    .......
    add chain=input in-interface=Net protocol=tcp dst-port=3128 action=drop \
    comment="bloqueia Xeretas" disabled=no

    -----------------------------------------------------------

    / ip hotspot
    add name="hotspot1" interface=Lan address-pool=hs-pool-1 profile=hsprof1 idle-timeout=5m \
    keepalive-timeout=none addresses-per-mac=2 disabled=no
    / ip hotspot service-port
    set ftp ports=21 disabled=no
    / ip hotspot profile
    set default name="default" hotspot-address=0.0.0.0 dns-name="" html-directory=hotspot \
    rate-limit="" http-proxy=0.0.0.0:0 smtp-server=0.0.0.0 login-by=cookie,http-chap \
    http-cookie-lifetime=3d split-user-domain=no use-radius=no
    add name="hsprof1" hotspot-address=192.168.1.1 dns-name="hotspot.arnetms.com.br" \
    html-directory=hotspot rate-limit="" http-proxy=0.0.0.0:0 smtp-server=0.0.0.0 \
    login-by=cookie,http-chap,http-pap http-cookie-lifetime=3d split-user-domain=no \
    use-radius=no
    / ip hotspot user
    add name="admin" password="XXXXX" profile=default comment="" disabled=no
    add server=hotspot1 name="paulo" password="XXXXX" profile=640k comment="" disabled=no
    / ip hotspot user profile
    set default name="default" idle-timeout=none keepalive-timeout=2m status-autorefresh=1m \
    shared-users=1 transparent-proxy=yes open-status-page=always advertise=no
    add name="160k" address-pool=hs-pool-1 idle-timeout=none keepalive-timeout=2m \
    status-autorefresh=1m shared-users=1 rate-limit="60k/160k" transparent-proxy=no
    add name="320k" address-pool=hs-pool-1 idle-timeout=none keepalive-timeout=2m \
    status-autorefresh=1m shared-users=1 rate-limit="80k/320k" transparent-proxy=no
    add name="640k" address-pool=hs-pool-1 idle-timeout=none keepalive-timeout=2m \
    status-autorefresh=1m shared-users=1 rate-limit="120k/640k" transparent-proxy=no

    ---------------------------------------------------------------

    / ip web-proxy
    set enabled=yes src-address=0.0.0.0 port=3128 hostname="proxy" transparent-proxy=yes parent-proxy=0.0.0.0:0 \
    cache-administrator="webmaster" max-object-size=20000KiB cache-drive=secondary-master max-cache-size=unlimited \
    max-ram-cache-size=393216KiB
    / ip web-proxy access
    add dst-port=23-25 action=deny comment="block telnet & spam e-mail relaying" disabled=no
    / ip web-proxy cache
    add url=":cgi-bin \\?" action=deny comment="don't cache dynamic http pages" disabled=no
    add url="youtube.com*" action=allow comment="youtube" disabled=no
    add url="orkut.com*" action=allow comment="orkut" disabled=no
    add url="video.youtube.com*" action=allow comment="videos" disabled=no


    Essa é minha configuração, unica q encurtei é o bloquio de virus q peguei aqui no forum.
    Obrigado desde já pela força

  4. Amigo pelo que vi faltou a regra no firewall redirecionando o trafego da porta 80 pra porta do proxy, segue ele ai pra vc

    /ip firewall nat
    add chain=pre-hotspot in-interface=RADIOS protocol=tcp dst-port=80 hotspot=auth action=redirect to-ports=3128 comment="Redirecionamento Proxy - HotSpot"

    Abraços

    Clecio



  5. Clecio, muito obrigado, estava com a mesma dúvida...
    eu montava as regras do cache full e funcionava,
    mas quando eu ativava o hotspot aí ele controlava a banda de acordo com o simple queue.

    com esta regra q vc colou, eu adicionei mudando a interface=RADIOS para a minha interface de saída para os clientes..
    e tudo está perfeito.

    Grande abraço.






Tópicos Similares

  1. Bridge, hotspot, webproxy, cache full
    Por liloliver no fórum Redes
    Respostas: 1
    Último Post: 04-07-2009, 09:24
  2. Hotspot + webproxy cache full
    Por liloliver no fórum Redes
    Respostas: 1
    Último Post: 29-06-2009, 18:34
  3. Respostas: 6
    Último Post: 22-09-2008, 00:05
  4. Hotspot com cache full dor de cabeça
    Por brunosamuel no fórum Redes
    Respostas: 3
    Último Post: 06-08-2008, 20:54
  5. HotSpot X Cache Full
    Por guttoballa no fórum Redes
    Respostas: 1
    Último Post: 09-05-2008, 20:39

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L