Página 1 de 3 123 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1

    Thumbs up Codigo load balance com Marcação de pacotes !

    Pessoal, eu sou meio leigo ainda em relação ao MK mas, tenho um script pronto , deixarei ele com algums parenteses para guiar melhor aonde voces deveram modificar de acordo com as configurações de seus respectivos MK. COPIEM PARA O BLOCO DE NOTAS PARA UMA MELHOR VISUALIZAÇÃO,SÓ APAGUEM O QUE ESTÁ ENTRE PARENTESES.

    se houver algum erro por favor postem para um melhor funcionamento.
    ====================================================

    (NO IN-INTERFACE PONHA O NOME DO DA SAIDA PARA CLIENTES)
    / ip firewall mangle
    add chain=prerouting in-interface=Local connection-state=new nth=1,1,0 action=mark-connection new-connection-mark=odd passthrough=yes comment="Balanceamento de carga" disabled=no
    add chain=prerouting in-interface=Local connection-mark=odd action=mark-routing new-routing-mark=odd passthrough=no comment="" disabled=no
    add chain=prerouting in-interface=Local connection-state=new nth=1,1,1 action=mark-connection new-connection-mark=even passthrough=yes comment="" disabled=no
    add chain=prerouting in-interface=Local connection-mark=even action=mark-routing new-routing-mark=even passthrough=no comment="" disabled=no

    (NO TO-ADDRESSES PONHA O ENDEREÇO PONHA O Nº DO IP DA SUA SAIDA PARA CLIENTES)
    / ip firewall nat
    add chain=srcnat connection-mark=odd action=src-nat to-addresses=10.80.1.254 to-ports=0-65535 comment="Balanceamento de carga" disabled=no
    add chain=srcnat connection-mark=even action=src-nat to-addresses=10.80.1.254 to-ports=0-65535 comment="outro" disabled=no

    (NA GATEWAY PONHA O ENDEREÇO DOS LINKS DE SUA INTERNET.) ("NOTA = O "COMMENT" VOCE PODE POR O NOME DO MODEM OU O QUAL DESEJAR")
    / ip route
    add dst-address=0.0.0.0/0 gateway=10.15.40.254 scope=255 target-scope=10 routing-mark=odd comment="GW Planet" disabled=no
    add dst-address=0.0.0.0/0 gateway=10.15.30.254 scope=255 target-scope=10 routing-mark=even comment="GW SpeedStream" disabled=no

    add dst-address=0.0.0.0/0 gateway=10.15.40.254 scope=255 target-scope=10 comment="Link Principal" disabled=yes

    (SE TIVER UMA REGRA NAT CRIADO DESABILITE-O EM CASO DE MAL FUNCIONAMENTO)
    Última edição por magrock; 14-05-2008 às 16:31. Razão: troca do titulo

  2. #2

    Padrão

    Magrock, essa é a minha solução que procuro a algum tempo. MAs no meu caso o mangle não está sendo criado da forma que vc postou, uso o mikrotik versão 3.2, e no parametro nth ele só aceita 1,0 e 1,1, não aceita 1,1,0, no caso criei um com 1,0 e o segundo 1,1. Só que ele só marca o 1,0, não chega a marcar o segundo pacote, portanto ele não faz o balanceamento.. toda a carga cai em um único link e o outro fica zerado.
    Veja como ficou meu script:

    / ip firewall mangle
    /ip firewall mangle
    add action=mark-connection chain=prerouting comment="LB Odd" \
    connection-state=new disabled=yes in-interface=clientes \
    new-connection-mark=odd nth=1,0 passthrough=yes
    add action=mark-routing chain=prerouting comment="Odd LB" connection-mark=odd \
    disabled=yes in-interface=clientes new-routing-mark=odd passthrough=no
    add action=mark-connection chain=prerouting comment="LB Even" \
    connection-state=new disabled=yes in-interface=clientes \
    new-connection-mark=even nth=1,1 passthrough=yes
    add action=mark-routing chain=prerouting comment="Even LB" \
    connection-mark=even disabled=yes in-interface=clientes \
    new-routing-mark=even passthrough=no

    /ip firewall nat
    add action=passthrough chain=unused-hs-chain comment="place hotspot rules \
    here" disabled=yes
    add action=masquerade chain=srcnat comment="masquerade hotspot network" \
    disabled=no src-address=50.10.10.0/24
    add action=src-nat chain=srcnat comment="LB Redirect odd" connection-mark=odd \
    disabled=yes nth=0,0 to-addresses=201.48.16.198 to-ports=0-65535
    add action=src-nat chain=srcnat comment="LB Redirect even" \
    connection-mark=even disabled=yes to-addresses=192.168.254.254 \
    to-ports=0-65535

    /ip route
    add comment="LB Route Odd" disabled=yes distance=1 dst-address=0.0.0.0/0 \
    gateway=201.48.16.198 routing-mark=odd scope=255 target-scope=10
    add comment="LB Route Odd" disabled=yes distance=1 dst-address=0.0.0.0/0 \
    gateway=192.168.254.254 routing-mark=even scope=255 target-scope=10
    add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 \
    gateway=201.48.16.198 scope=255 target-scope=10
    add comment="LB Route No Mark" disabled=yes distance=1 dst-address=0.0.0.0/0 \
    gateway=201.48.16.198 scope=255 target-scope=10



    Citação Postado originalmente por magrock Ver Post
    Pessoal, eu sou meio leigo ainda em relação ao MK mas, tenho um script pronto , deixarei ele com algums parenteses para guiar melhor aonde voces deveram modificar de acordo com as configurações de seus respectivos MK. COPIEM PARA O BLOCO DE NOTAS PARA UMA MELHOR VISUALIZAÇÃO,SÓ APAGUEM O QUE ESTÁ ENTRE PARENTESES.

    se houver algum erro por favor postem para um melhor funcionamento.
    ====================================================

    (NO IN-INTERFACE PONHA O NOME DO DA SAIDA PARA CLIENTES)
    / ip firewall mangle
    add chain=prerouting in-interface=Local connection-state=new nth=1,1,0 action=mark-connection new-connection-mark=odd passthrough=yes comment="Balanceamento de carga" disabled=no
    add chain=prerouting in-interface=Local connection-mark=odd action=mark-routing new-routing-mark=odd passthrough=no comment="" disabled=no
    add chain=prerouting in-interface=Local connection-state=new nth=1,1,1 action=mark-connection new-connection-mark=even passthrough=yes comment="" disabled=no
    add chain=prerouting in-interface=Local connection-mark=even action=mark-routing new-routing-mark=even passthrough=no comment="" disabled=no

    (NO TO-ADDRESSES PONHA O ENDEREÇO PONHA O Nº DO IP DA SUA SAIDA PARA CLIENTES)
    / ip firewall nat
    add chain=srcnat connection-mark=odd action=src-nat to-addresses=10.80.1.254 to-ports=0-65535 comment="Balanceamento de carga" disabled=no
    add chain=srcnat connection-mark=even action=src-nat to-addresses=10.80.1.254 to-ports=0-65535 comment="outro" disabled=no

    (NA GATEWAY PONHA O ENDEREÇO DOS LINKS DE SUA INTERNET.) ("NOTA = O "COMMENT" VOCE PODE POR O NOME DO MODEM OU O QUAL DESEJAR")
    / ip route
    add dst-address=0.0.0.0/0 gateway=10.15.40.254 scope=255 target-scope=10 routing-mark=odd comment="GW Planet" disabled=no
    add dst-address=0.0.0.0/0 gateway=10.15.30.254 scope=255 target-scope=10 routing-mark=even comment="GW SpeedStream" disabled=no

    add dst-address=0.0.0.0/0 gateway=10.15.40.254 scope=255 target-scope=10 comment="Link Principal" disabled=yes

    (SE TIVER UMA REGRA NAT CRIADO DESABILITE-O EM CASO DE MAL FUNCIONAMENTO)
    Última edição por dougdoidao; 28-05-2008 às 16:45. Razão: inclusão de scripts



  3. #3

    Padrão Balanceamento

    Amigo eu tentei fazer o balanceamento que vc passo a baixo e parece que deu certo, mais vamos supor que um dos links caia o outro assumi a rede?


    E outra coisa como que eu sei que está funcionando tem alguma lugar para olhar e saber se está funcionando ou não???


    Desde já agradeço té mais....





    Citação Postado originalmente por magrock Ver Post
    Pessoal, eu sou meio leigo ainda em relação ao MK mas, tenho um script pronto , deixarei ele com algums parenteses para guiar melhor aonde voces deveram modificar de acordo com as configurações de seus respectivos MK. COPIEM PARA O BLOCO DE NOTAS PARA UMA MELHOR VISUALIZAÇÃO,SÓ APAGUEM O QUE ESTÁ ENTRE PARENTESES.

    se houver algum erro por favor postem para um melhor funcionamento.
    ====================================================

    (NO IN-INTERFACE PONHA O NOME DO DA SAIDA PARA CLIENTES)
    / ip firewall mangle
    add chain=prerouting in-interface=Local connection-state=new nth=1,1,0 action=mark-connection new-connection-mark=odd passthrough=yes comment="Balanceamento de carga" disabled=no
    add chain=prerouting in-interface=Local connection-mark=odd action=mark-routing new-routing-mark=odd passthrough=no comment="" disabled=no
    add chain=prerouting in-interface=Local connection-state=new nth=1,1,1 action=mark-connection new-connection-mark=even passthrough=yes comment="" disabled=no
    add chain=prerouting in-interface=Local connection-mark=even action=mark-routing new-routing-mark=even passthrough=no comment="" disabled=no

    (NO TO-ADDRESSES PONHA O ENDEREÇO PONHA O Nº DO IP DA SUA SAIDA PARA CLIENTES)
    / ip firewall nat
    add chain=srcnat connection-mark=odd action=src-nat to-addresses=10.80.1.254 to-ports=0-65535 comment="Balanceamento de carga" disabled=no
    add chain=srcnat connection-mark=even action=src-nat to-addresses=10.80.1.254 to-ports=0-65535 comment="outro" disabled=no

    (NA GATEWAY PONHA O ENDEREÇO DOS LINKS DE SUA INTERNET.) ("NOTA = O "COMMENT" VOCE PODE POR O NOME DO MODEM OU O QUAL DESEJAR")
    / ip route
    add dst-address=0.0.0.0/0 gateway=10.15.40.254 scope=255 target-scope=10 routing-mark=odd comment="GW Planet" disabled=no
    add dst-address=0.0.0.0/0 gateway=10.15.30.254 scope=255 target-scope=10 routing-mark=even comment="GW SpeedStream" disabled=no

    add dst-address=0.0.0.0/0 gateway=10.15.40.254 scope=255 target-scope=10 comment="Link Principal" disabled=yes

    (SE TIVER UMA REGRA NAT CRIADO DESABILITE-O EM CASO DE MAL FUNCIONAMENTO)

  4. #4

    Padrão

    O Load Balance por nth requer muito conhecimento e dedicação para deixá-lo rodando tudo certim. Você terá que criar excessões nas regras pra Bancos, etc.
    Faça por rotas estaticas, tipo:
    link 01 default
    link 02 msn, orkut, etc...
    e monte o script de monitoramento pra quando um cair o outro assumir e vice versa.



  5. #5

    Padrão sofrendo pra fazer o balance

    Citação Postado originalmente por rps67 Ver Post
    O Load Balance por nth requer muito conhecimento e dedicação para deixá-lo rodando tudo certim. Você terá que criar excessões nas regras pra Bancos, etc.
    Faça por rotas estaticas, tipo:
    link 01 default
    link 02 msn, orkut, etc...
    e monte o script de monitoramento pra quando um cair o outro assumir e vice versa.

    amigo, to tentando fazer um load balance com 2 ADSL, achei interessante como você falou sobre link 01 default e 02 man, orkut, etc....

    como faço isso? tens algum link que eu possa ver os scripts???

  6. #6

    Padrão

    meu amigo não qubre a cabeça com relação a esse script, vai uma dica que eu aderi e gostei muito
    procure informações sobre um aparelho da marca D-LINK DI-LB604 ele sim faz balanceamento de carga, trabalho como redundante e soma seu link sem nenhuma preocupação, esse script que eu criei só deu dor de cabeça na minha rede, pois ela tem 160 usuarios, nos dias de pico ficam 120 conectados, e o msn trava totalmente, impedindo que voce envie a sua mensagem ao destinatario, esse aparelho eu aderi e aprovo, facil configuração e não da dor de cabeça aqui no RJ custou 250,00 mas no mercado livre é até mais barato procure saber mais..
    fica ai a dica mas se voce optar pelo MK não discordo de voce pois ele é poderoso, mas como eu sou leigo sobre ele ai fica dificil eu uso esse aparelho junto ao MK sem nenhum problema qualquer coisa ta ai meu msn:[email protected]
    abraços