Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1

    Padrão Proxy em paralelo com o mikrotik

    ae pessoal gostaria de saber da opniao de vcs a respeito dessa solucao, ou se alguem ja tenha feito.

    Linux: Proxy em paralelo com o mikrotik [Artigo]

  2. #2

    Padrão

    Se é boa eu não sei amigo, mais q muita gente usa dessa forma, isso usa, ate eu vou usar agora, pois so me faltava esse manual, valeu mesmo amigo!



  3. #3

    Padrão

    Citação Postado originalmente por rogeriodj Ver Post
    Se é boa eu não sei amigo, mais q muita gente usa dessa forma, isso usa, ate eu vou usar agora, pois so me faltava esse manual, valeu mesmo amigo!
    Já até postei minha experiência aki. O meu ficou show de bola

    Servidor brazilfw com squid

    agora seguinte não uso proxy em cascata do tipo webproxy com parent proxy

    o que fiz foi desviar de rota todas as conexões à porta 80 para o servidor paralelo

  4. #4

    Padrão

    Citação Postado originalmente por diegovilela01 Ver Post
    ae pessoal gostaria de saber da opniao de vcs a respeito dessa solucao, ou se alguem ja tenha feito.

    Linux: Proxy em paralelo com o mikrotik [Artigo]
    É isto mesmo amigo,
    Usar proxy em paralelo com o linxu é muito bom.



  5. #5

    Padrão

    Outra coisa nesse artigo, fala sobre a versão 3.x do MK, para versão 2.9.51 é a mesma coisa, ou tem alguma diferença?

    E ai JHONNE, teria como vc dar mais detalhes de como vc fez com o BrazilFW + MK, pois ja estou tentando fazer isso a muio tempo mais sem sucesso, e usar o BFW como Squid+Sarg seria bem mais facil, se puder postar mais detalhes de como proceder eu agradeço!!!
    Última edição por rogeriodj; 02-06-2008 às 08:21.

  6. #6



  7. #7

    Padrão

    Ai galera aproveitando o tópico .... eu gostaria de que alguém me indicasse a solução pro meu caso: Tenho um Link de Fibra que entra no meu mikrotik através do Ip 192.168.254.252 ( esse um ip ficticio antes que perguntem ) .... nesta mesma interface tenho tb um servidor Linux Debian junto com o Switch ... o ip do servidor eh : 192.168.254.251 .... bom no meu mikrotik eu tenho o Famoso Parent PRoxy .... nesta mesma interface eu tenho o link backup q responde por 192.168.1.1 ..........


    BOm .... essa semana tive uns problemas com meu link de fibra ... ele caiu duas vezes ... e fiquei na mao ... pois bem .... fiz um script .... a função do script eh .... desativar a rota do Link de Fibra .... e ativar a rota do Reserva ... mudar o DNS .... e setar o valor do parent proxy para 0.0.0.0:0000 pq no caso ele iria desativar o parent proxy .... e deixaria soh no webproxy do mikrotik .... o X da questão :


    Tem como eu fazer essa mudança sem ter que desativar o parent proxy ? PQ no meu caso o Linux continuaria com o gateway do link de fibra ativado ai toda vez que o mikrotik consultasse o parent proxy daria que está fora do ar jah que o Gateway do Linux está fora do ar.


    desde jah agradeço a ajuda dos colegas...

  8. #8

    Padrão

    Seguinte montei um servidor bfw conectado ao mesmo link de internet que o mikrotik através de um switch


    em mangle marquei por rota todos os pacotes destinados a porta 80

    criei em routes um gateway para esses pacotes marcados (o gateway é o servidor bfw)

    Citação Postado originalmente por rogeriodj Ver Post
    Outra coisa nesse artigo, fala sobre a versão 3.x do MK, para versão 2.9.51 é a mesma coisa, ou tem alguma diferença?

    E ai JHONNE, teria como vc dar mais detalhes de como vc fez com o BrazilFW + MK, pois ja estou tentando fazer isso a muio tempo mais sem sucesso, e usar o BFW como Squid+Sarg seria bem mais facil, se puder postar mais detalhes de como proceder eu agradeço!!!



  9. #9

    Padrão

    Acho q entendi, vou tentar fazer aqui, depois posto aqui o resultado.

  10. #10

    Padrão

    Belo material, será muito útil, pois estou montando uma maquina para montar o proxy e esse material com certeza irá ajudar.



  11. #11

    Padrão

    Citação Postado originalmente por JHONNE Ver Post
    Seguinte montei um servidor bfw conectado ao mesmo link de internet que o mikrotik através de um switch


    em mangle marquei por rota todos os pacotes destinados a porta 80

    criei em routes um gateway para esses pacotes marcados (o gateway é o servidor bfw)

    Jhonne olá cara, brother estou tentando fazer o mesmo que vc a, mas estou tendo umas duvidas, como adiciono esse gateway para os pacotes? essa regra do mangle são as mesmas que tem pro proxy do MKT, no caso mudamos somente aa porta?? desde já obrigado.

  12. #12

    Padrão

    Citação Postado originalmente por georgegomes Ver Post
    Jhonne olá cara, brother estou tentando fazer o mesmo que vc a, mas estou tendo umas duvidas, como adiciono esse gateway para os pacotes? essa regra do mangle são as mesmas que tem pro proxy do MKT, no caso mudamos somente aa porta?? desde já obrigado.
    Este gateway(route) para os pacotes é criado em /ip route.
    Primeiro deve-se marcar os pacotes com destino a porta 80 e na ação colocar um new routing para a mesma, em /ip route criar o gateway.

    Ex:

    /ip firewall mangle add chain=prerouting src-address=192.168.100.0/24 protocol=tcp dst-port=80 action=mark-routing new-routing-mark="porta80" passthrough=yes disabled=no comment="marcacao para porta 80"

    /ip route add gateway=192.168.1.1 routing-mark=porta80


    Com isto aí ele marca tudo o que passa pela porta 80 e coloca em um gateway específico, pode ser um link separado ou uma rede criada somente para atender a este serviço, no linux ou mikrotik.

    É isto aí.

    Qualquer coisa...
    Última edição por Raniel; 14-06-2008 às 21:29. Razão: editar alguns erros na regra de mangle, tudo ok



  13. #13

    Padrão

    Citação Postado originalmente por Mr. RG Ver Post
    Este gateway(route) para os pacotes é criado em /ip route.
    Primeiro deve-se marcar os pacotes com destino a porta 80 e na ação colocar um new routing para a mesma, em /ip route criar o gateway.

    Ex:

    /ip firewall mangle add chain=output src-address=192.168.100.0/24 dst-port=80 action=mark-routing new-routing-mark="porta80" passthrough=yes disabled=no comment="marcacao para porta 80"

    /ip route add gateway=192.168.1.1 routing-mark=porta80


    Com isto aí ele marca tudo o que passa pela porta 80 e coloca em um gateway específico, pode ser um link separado ou uma rede criada somente para atender a este serviço, no linux ou mikrotik.

    É isto aí.

    Qualquer coisa...
    rapaz vc me deu a luz que falatava, muito obrigado mesmo é sempre bom achar pessoas que estão disposta a compartilhar conheçimento , mas olha só vi em um outro post, do proprio Jhonne e lá ele usou o termo prerouting. estou na duvida só enquanto a isso, e em chain, escolho output ou prerouting e na classe de ip que vc usou, aqui uso 2 classe de ips pra os clientes, como faço pra que todos passem pela marquação?

    olhe a esplicação dele [https://under-linux.org/forums/mikro...d-linux-2.html[/link]

  14. #14

    Padrão

    [quote=georgegomes;327451]... estou na duvida ...em chain, escolho output ou prerouting e na classe de ip que vc usou, aqui uso 2 classe de ips pra os clientes, como faço pra que todos passem pela marquação?[quote]

    Amigo,
    É prerouting mesmo, foi um erro de digitação. Para que todos os ips passem pela regra é colocar 0.0.0.0/0 ou deixar em branco.

    Obs: faltou informar o protocol=tcp na regra acima.

    /ip firewall mangle add chain=prerouting src-address=0.0.0.0/0 protocol=tcp dst-port=80 action=mark-routing new-routing-mark="porta80" passthrough=yes disabled=no comment="marcacao para porta 80"

    Qualquer coisa...



  15. #15

    Padrão

    [quote=Mr. RG;327456][quote=georgegomes;327451]... estou na duvida ...em chain, escolho output ou prerouting e na classe de ip que vc usou, aqui uso 2 classe de ips pra os clientes, como faço pra que todos passem pela marquação?

    Amigo,
    É prerouting mesmo, foi um erro de digitação. Para que todos os ips passem pela regra é colocar 0.0.0.0/0 ou deixar em branco.

    Obs: faltou informar o protocol=tcp na regra acima.

    /ip firewall mangle add chain=prerouting src-address=0.0.0.0/0 protocol=tcp dst-port=80 action=mark-routing new-routing-mark="porta80" passthrough=yes disabled=no comment="marcacao para porta 80"

    Qualquer coisa...

    Mr. MG pow brother, fiz tudinho como vc me disse e segui tbm o esqueminha do Jhonne, mas não consegui navegar, não sei o que tem de errado?

    mas valews pelas dicas.

  16. #16

    Padrão

    [quote=georgegomes;327598][quote=Mr. RG;327456]
    Citação Postado originalmente por georgegomes Ver Post
    ... estou na duvida ...em chain, escolho output ou prerouting e na classe de ip que vc usou, aqui uso 2 classe de ips pra os clientes, como faço pra que todos passem pela marquação?


    Mr. MG pow brother, fiz tudinho como vc me disse e segui tbm o esqueminha do Jhonne, mas não consegui navegar, não sei o que tem de errado?

    mas valews pelas dicas.
    posta as regras ai, quem sabe agente acha o erro!

    te add no msn confomre mp.



  17. #17

    Padrão

    [quote=JHONNE;327599][quote=georgegomes;327598]
    Citação Postado originalmente por Mr. RG Ver Post

    posta as regras ai, quem sabe agente acha o erro!

    te add no msn confomre mp.
    nos ips ficou assim no MKT
    / ip address
    add address=10.100.100.2/29 network=10.100.100.0 broadcast=10.100.100.7 \
    interface=SQUID comment="IP´s Squid" disabled=no <-- interface 1

    add address=10.200.200.1/30 network=10.200.200.0 broadcast=10.200.200.3 \
    interface=SQUIFOUT comment="" disabled=no <--interface 2

    add address=172.19.100.110/28 network=172.19.100.96 broadcast=172.19.100.111 \
    interface=WAN comment="gateway net" disabled=no

    no mangle :
    / ip firewall mangle
    add chain=prerouting protocol=tcp dst-port=80 action=mark-routing \
    new-routing-mark="Porat 80" passthrough=yes comment="" disabled=no

    e no route assim :
    ip route
    add dst-address=0.0.0.0/0 gateway=172.19.100.100 scope=255 target-scope=10 \
    comment="" disabled=no
    add dst-address=0.0.0.0/0 gateway=10.100.100.1 scope=255 target-scope=10 \
    routing-mark="Porat 80" comment="" disabled=no

    configurei os ips no BFW como está no esquema, cloquei até as placas como vc usa e tudo mais.
    pow amigo se vc puder add mesmo, fico muito grato e pago até se for preciso, estava usando aqui um webproxy do MT, tudo indo bem, mas depois ficou uma merda.

    agradeço muito.

  18. #18

    Padrão

    [quote=georgegomes;327611][quote=JHONNE;327599]
    Citação Postado originalmente por georgegomes Ver Post

    nos ips ficou assim no MKT
    / ip address
    add address=10.100.100.2/29 network=10.100.100.0 broadcast=10.100.100.7 \
    interface=SQUID comment="IP´s Squid" disabled=no <-- interface 1

    add address=10.200.200.1/30 network=10.200.200.0 broadcast=10.200.200.3 \
    interface=SQUIFOUT comment="" disabled=no <--interface 2

    add address=172.19.100.110/28 network=172.19.100.96 broadcast=172.19.100.111 \
    interface=WAN comment="gateway net" disabled=no

    no mangle :
    / ip firewall mangle
    add chain=prerouting protocol=tcp dst-port=80 action=mark-routing \
    new-routing-mark="Porat 80" passthrough=yes comment="" disabled=no

    e no route assim :
    ip route
    add dst-address=0.0.0.0/0 gateway=172.19.100.100 scope=255 target-scope=10 \
    comment="" disabled=no
    add dst-address=0.0.0.0/0 gateway=10.100.100.1 scope=255 target-scope=10 \
    routing-mark="Porat 80" comment="" disabled=no

    configurei os ips no BFW como está no esquema, cloquei até as placas como vc usa e tudo mais.
    pow amigo se vc puder add mesmo, fico muito grato e pago até se for preciso, estava usando aqui um webproxy do MT, tudo indo bem, mas depois ficou uma merda.

    agradeço muito.

    crie a rota marcada primeiro que as outras



  19. #19

    Padrão

    [quote=JHONNE;327832][quote=georgegomes;327611]
    Citação Postado originalmente por JHONNE Ver Post


    crie a rota marcada primeiro que as outras
    Jhonne pows brother valews mesmo, olha é o seguinte o problemas é o seguinte quando ligo meu laptop no BFW e coloco recebendo via dhcp ele funfa legal acesso todos os sites bom mesmo, mas quando plugo no MKT ele não funfa pois não está dhcp, e o dns dele fica como o ip do BFW, agora tenho é que fazer o MKt pegar o ip via dhcp ou ajeitar o ip nomkt mas não estou ligado como, outra coisa comom tenho certeza que o squid esta cacheando tudo?? tentei aqui assim ligado direto no bfw, baixei um arquivo de 4MB, depois apaguei e deletei os arquivos temporarios, baixei novamente, masnão notei diferença, jpa que está tudo sem controle de banda.

    valews seu esquema funfa massa mesmo, mas pra pessoas como eu que estõ começando é phoda!

  20. #20

    Padrão

    [quote=georgegomes;327856][quote=JHONNE;327832]
    Citação Postado originalmente por georgegomes Ver Post

    Jhonne pows brother valews mesmo, olha é o seguinte o problemas é o seguinte quando ligo meu laptop no BFW e coloco recebendo via dhcp ele funfa legal acesso todos os sites bom mesmo, mas quando plugo no MKT ele não funfa pois não está dhcp, e o dns dele fica como o ip do BFW, agora tenho é que fazer o MKt pegar o ip via dhcp ou ajeitar o ip nomkt mas não estou ligado como, outra coisa comom tenho certeza que o squid esta cacheando tudo?? tentei aqui assim ligado direto no bfw, baixei um arquivo de 4MB, depois apaguei e deletei os arquivos temporarios, baixei novamente, masnão notei diferença, jpa que está tudo sem controle de banda.

    valews seu esquema funfa massa mesmo, mas pra pessoas como eu que estõ começando é phoda!
    Cara quanto ao bfw é preciso ter certeza que o transparent proxy do squid está ativado, senão realmente o cache não vai funcionar. Volte ao wizard do bfw e verfique a faixa de ip que vc colocou na rede, desative o dhcp e coloque o ip manualmente mesmo no mk